Previous 1 2 Next 22 Replies Latest reply: Nov 15, 2015 12:40 PM by Rob Gilgan
lindswah007 Level 1 (0 points)

This is driving me CRAZY. For my job I have to open a number of images. Sometimes while I have an image open I will randomly get a prompt that says "The document "_" could not be autosaved." This is when I know the trouble is about to start. After I get this message, if I close the image and try and reopen it, or if I try and open any other image I get the message "The file “_” couldn’t be opened because you don’t have permission to view it." and I can't open anything! I have tried repairing permissions, using 'get info' to unlock the files. The only thing that works is if I restart my computer, which means that I must restart my computer every time I want to open an image. This is about 20 times a day and is ridiculous. I would really appreciate some help from someone. Thank you.

iMac, Mac OS X (10.7.3)
  • X423424X Level 6 (14,215 points)

    What app is posting this message?

  • lindswah007 Level 1 (0 points)


  • X423424X Level 6 (14,215 points)

    Hmm, another Lion "feature".  Maybe these articles will help (or not):


    OS X Lion: About Auto Save and Versions


    Turn Off File Locking in OS X Lion


    And this youtube video:


    How to disable Auto Save in Mac OS X Lion

  • Linc Davis Level 10 (184,930 points)

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.


    Back up all data now. Before proceeding, you must be sure you can restore your system to its present state


    Launch the Terminal application in any of the following ways:


    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    Open LaunchPad. Click Utilities, then Terminal in the page that opens.


    Drag or copy — do not type — the following line into the Terminal window, then press return:


    chmod -R -N ~


    The command will take a noticeable amount of time to run. When a new line ending in a dollar sign ($) appears below what you entered, it’s done. You may see a few error messages about an “invalid argument” while the command is running. You can ignore those. If you get an error message with the words “Permission denied,” enter this:


    sudo !!


    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.


    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.


    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.


    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens. You’re not going to reset the password.


    Select your boot volume if not already selected.


    Select your username from the menu labeled Select the user account if not already selected.


    Under Reset Home Directory Permissions and ACLs, click the Reset button.


    Select ▹ Restart from the menu bar.

  • lindswah007 Level 1 (0 points)

    I tried this, however I still have the same problem.

  • -scstraus- Level 1 (0 points)

    I'm having the same problem. Definitely not due to permissions, but rather to OSX itself. Any more ideas?

  • njyacht Level 1 (0 points)

    I have a sneaking suspicion I might have a rather simpler answer, by sheer accident. Try creating a new user (Admin) and see if you can recreate the problem. If you can't, you've solved one issue and, in my experience, created another; a user with no files, nothing... I have the same problem so if someone can help with this bit I'd be grateful!


    How do I know this? This is the short version... In fairly quick succession I upgraded Filemaker to v12 and OS X from Leopard via Snow Leopard to Lion. Filemaker told me, wrongly, that v12 would only work with Lion (actually it works with Snow Leopard I later found), so I thought as I'm about to lose MobileMe anyway, the writing's on the wall, so get Lion.


    Having done all this and converted Filemaker files to the latest version I then found that  Filemaker's "send mail" script didn't work - it sends via your default email client or direct SMTP, as you prefer. It wouldn't communicate with Mail. I tried it in v11. Nothing. In v12 at least I got an opaque error message saying:


    "Some of the files that are needed are either damaged or have not been installed. Please run the installer to correct this problem."


    Which installer? No idea.


    Before reinstalling either Filemaker or Lion I put the same Filemaker files on an old iBook G4 (PowerPC, not Intel). The script worked perfectly, ergo it's not Filemaker at fault. I reinstalled Lion. No difference.


    I could find nothing on this issue anywhere. Finally I called Filemaker support and having gone through everything either of us could think of the lady I spoke to said, "Have you tried from another user?" No, there's only me.


    I created a new (Admin) user, logged out, in, opened Filemaker, ran the script, Mail sprang to life. Solved.


    So some preference or permission file somewhere is corrupted (yes, I repaired permissions, made no difference), but which? Now I have a new user who has no access to anything but operates Filemaker's send mail script perfectly!


    By the time I got this far Filemaker's support had gone home, so I've no idea what happens next until tomorrow when I'll call again. In the meatime if anyone knows how to resolve the different user problems I'd be delighted to know.


    Hope this solves your problem guys. Try it. Good luck.

  • LafayetteAndrew Level 1 (0 points)

    I had this exact problem...


    I used the disk utility to check permissions, then reparied permissions, restarted the computer and it was fixed...


    Good luck.

  • sashaki Level 1 (0 points)

    This works -- other user account works fine.


    I haven't tried Linc's long complicated solution yet. But I tried every other one in this thread, and nothing else worked. Repairing permissions via Disk Utility included.


    And I have the most standard specs ever: naw Macbook, latest Lion with all updates, hardly anything additional tweaked or installed.

  • Ferranp Level 1 (0 points)

    I tried what LafayetteAndrew did and it worked for me too. Make sure you reboot your computer to make it effective


    "I used the disk utility to check permissions, then reparied permissions, restarted the computer and it was fixed..."



  • rudyfromquebec city Level 1 (0 points)

    What is the step by step "how to" of what is mentioned above (I used the disk utility to check permissions, then reparied permissions, restarted the computer and it was fixed..)





  • LafayetteAndrew Level 1 (0 points)

    Just like it says...

    Go to disk utility

    Choose check permissions

    Choose repair permissions

    Restart computer

  • mcd1400 Level 1 (0 points)

    Perfect, simple, it worked. Thank you!

  • fabruver Level 1 (0 points)

    I have been having the same issue. I was going to try the disk permission advice but I have found that quiting Preview and opening the file again fixed my problem.

    I hope that my short, yet frustating experience helps others.

Previous 1 2 Next