Previous 1 2 Next 18 Replies Latest reply: Jul 11, 2012 12:41 PM by si71
koneu Level 1 (0 points)



I've just upgraded my iMac to 10.7.4 and now find myself unable to use my magic mouse. The reason I found so far is that bluetooth has been deactivated, and I cannot turn it back on via the settings panel. I've tried it both via the status bar icon and the settings pane, but neither activate bluetooth.


The iMac is the 27", late 2009 model. It has a 3,06 GHz Core 2 processor. Mac OS was updated to 10.7.4 (11E53). Up until the update, the system worked flawlessly.

iMac, Mac OS X (10.7.3)
  • softwater Level 5 (5,370 points)

    Hold down the 'option' key and click on the icon in the menubar.


    Does the 'Turn Bluetooth On' option work from there?


    If not, see if the 'Create Diagnostics Report on the Desktop...' option in the same menu will give you anything.

  • koneu Level 1 (0 points)

    Well, turning it on with the option key pressed also did not change anything.


    The Create Diagnostics report did infact yield a report; but now the question is, what to do with that? Is there anybody within apple that requires this for futher debugging – or somebody else, for that matter?

  • softwater Level 5 (5,370 points)

    If you unpack that report, at the bottom of the folder you should see something called 'top.txt'. If you paste it here I can compare it to mine and see if anything stands out. The most likely cause of your problem is s/w conflict with some 3rd party process. The 'top.txt' should provides some clues as to what that might be.

  • softwater Level 5 (5,370 points)

    BTW, before we go down this road, might I just suggest you try restarting the computer and seeing if that resolves the problem.

  • irish21 Level 1 (0 points)

    I have a MacPro i7 (just updated this am to 10.7.4) and I had the issue where my bluetooth keyboard and mouse would not connect. Bluetooth was showing that it was on but I could not get either device to connect.


    All I did was disable bluetooth and re-enable it... Now they work...

  • koneu Level 1 (0 points)

    Well, about four reboots later, Bluetooth turned up again and I have control of my mouse back.


    Thank you very much!

  • ian.swope Level 1 (0 points)

    I'm having the same issue. I've rebooted a couple of times since updating to 10.7.4 and even ran a fix permissions and fix disk session from the recovery partition and bluetooth seems messed up still. Just clicking on the bluetooth icon gives me the spinning beachball for a few seconds before the drop down menu comes down and this never did this before. Also, the battery percentage isn't being displayed although it does show my mouse and keyboard connected.


    The keyboard works, a little, although there are now random strange keypresses and it's a little "crazy" acting, for lack of a better description. The mouse is completely non-responsive. It connects but does not do anything at all.


    I've unpaird the keyboard and mouse and repaired them with the mac and still nothing. This is the first update I've ever had any issues with so I'm very surprised by this.

  • softwater Level 5 (5,370 points)

    That sounds like a different issue. Try this:


    1. Open Activity (Applications > Utilities > Activity


    2. Select 'All Processes' from the drop down menu next to the search bar (called 'Filter:') and type in 'mds'.


    Is that process running at something like 90% or more? If no, report back. If yes,


    3. Select the process name 'mds' with user 'root'. Click the 'Quit Process' button at the top. You will be asked to supply your password.

  • ian.swope Level 1 (0 points)

    Nope. MDS is running at about 0.5% with 8 processes. There actually isn't anything weird that's running out of control in activity monitor.


    And another thing I've noticed is if I turn bluetooth off then I can select the bluetooth icon and get the dropdown menu from the task bar immediately with no lag. If I turn bluetooth on, I can get the dropdown immediately with no lag also until it connects to the keyboard and mouse and then once they've connected it's the spinning beachball if I click on the bluetooth icon for a minute or so until it reacts.


    With bluetooth on or off there is nothing out of the ordinary in Activity Monitor.

  • softwater Level 5 (5,370 points)

    Can you try this please.


    1. Open Terminal (Applications > Utilities >, and copy/paste this command


    sudo mv /Library/Preferences/ ~/Desktop/


    Press 'return'. Enter your password.


    Restart the computer.


    This forces the OS to recreate the bluetooth preferences file when you restart.

  • ian.swope Level 1 (0 points)

    Dumping the plist file seemed to speed up bluetooth power since I can turn it on and off and select devices from the icon in the task bar without the spinning beach ball now.


    The mouse now moves the cursor but, like the keyboard, it's really jumpy and shoots all over the screen at times. Also, the scrolling doesn't seem to work at all anymore.

  • ian.swope Level 1 (0 points)

    I tried opening up bluetooth preferences and deleting both the keyboard and mouse and setting them up new but it won't pair now. I keep getting errors for both of them saying the device can't be paired.

  • softwater Level 5 (5,370 points)

    Don't think I can offer any further ideas here, sorry. I'm a bit stumped.


    If you think things are worse now since trashing the preferences file with that previous command, you can restore it to the way it was before by undoing that command with this one:


    sudo mv ~/Desktop/ /Library/Preferences/


    (that's all one line).


    Again, you'll probably have to enter your password (sudo times out after about 5 minutes).


    Log out and log in again.


    This will simply restore the prefs back to the way they were before you tried the previous command.

  • ian.swope Level 1 (0 points)

    Thanks for the help anyway. I was really not wanting to have to go to the Apple store today but I'm thinking that might have to happen. I might try running diskwarrior on it beforehand, though. Not sure if that would help but running out of ideas.

Previous 1 2 Next