Previous 1 2 3 Next 31 Replies Latest reply: Jan 15, 2013 7:19 PM by lethargic
PPeelen Level 1 Level 1 (0 points)

Hi!

 

After updating to OS X 10.7.4 last week on my MacBookAir3,2 I have been experiencing USB-Ethernet problems. Just out of the blue it suddenly disconnects.

Just now I connected my iPhone 4 and it just dropped my ethernet connection. I know there is nothing wrong with the cable, which besides that cannot be affected by upgrading my OS... Of course!

 

The Wifi works great, but is just drops the USB-Ethernet. The only way of resetting it, it seems, is rebooting... but I have better things to do during my day to reboot over and over again.

 

Any other people experiencing this? Any better workaround to "reboot" the USB port or similar?

I have tried switching on and off the usb ehternet in the networks settings. Tried different ports as well. Also tried waiting a while and last but not least tried reconnecting the cable and different cables.

 

Best regards,

Paul Peelen


MacBook Air, Mac OS X (10.7.4)
  • iGnaciomx Level 1 Level 1 (0 points)

    Hi, I have the same issue, also after updating to OS X 10.7.4, I hope that Apple can fix tha soon.

  • PPeelen Level 1 Level 1 (0 points)

    It got worse today, as soon as I connected my iPhone to the computer my USB Ehternet got permanently disconnected. I could boot with both connected, but disconnecting the iphone and reconnecting it would again permanently disconnect it.

     

    Really anoying!

  • PPeelen Level 1 Level 1 (0 points)

    This is just weird...

    I launched my virtual machine (VMWare Fusion) and re-connected the USB-Ethernet adapter and the VM recognized it and connected with it... however, my actual machine did not. The VM runs 10.7.3. Maybe I should share the connection from my VM to its host so it can surf!

  • teemumm Level 1 Level 1 (0 points)

    I have had also similar problems. I have 2011 Macbook Air and after update to 10.7.4 I have started to have problems with USB Ethernet adapter. If I remove it, use Wifi for a while and then reconnect it, the computer doesn't anymore recognize the adapter. Only way to make it work again is to reboot. With 10.7.3 I didn't have any problems.

  • GaltJohn Level 1 Level 1 (0 points)

    I am facing the same problem since 10.7.4 update on my MBAir (bought one month ago). I need to reboot to get the ethernet usb working. Moreover, to understand the problem I printed the interfaces in my terminal using : ifconfig.

     

    My usb ethernet appears normally under : en2

     

    But when I plug a usb device (android phone, usb key, usb hard drive, event usb hub), the interface en2 vanishes... It is the same on both usb ports (left and right)...

     

    This is really stupid and I hope that Apple is gonna solve this soon !

  • rudy_ Level 1 Level 1 (0 points)

    Yes, thank you!!!

    I upgraded to 10.7.4 today, and I am now on my fourth restart. The ethernet connection on my MacBook Air just simply drops and a restart is the only thing that works to bring it up.

     

    I'm really fed up. In fact, I'm posting this via my Android phone. I'm too tired and frustrated to wait for yet another startup.

     

    This is a serious bug, and it really shocks me that this wasn't caught by QC. Perhaps it's true what I've read... as Apple has grown and is rushing product to market, QC has suffered greatly. Plus, I'm sure that the priority is on Mountain Lion.

     

    Apple. Please read, and please fix.

     

    Rudy

  • rudy_ Level 1 Level 1 (0 points)

    UPDATE:

    I seem to be working fine now.

     

    I have a mid 2011 MacBook Air connected to a 1st Gen 27" Thunderbolt monitor. Since the beginning, I never was able to get the Display Ethernet to work properly. But since I had the USB Ethernet on the Air, and it was working, it didn't concern me. So, I stayed connected to my server that way, and forgot about the Display's port.

     

    Well... tonight, after the 10th restart, I suddenly remembered the existence of the Display Ethernet port. On a whim, I pulled the ethernet from the Air's USB port and plugged it into the display's ethernet port. Guess what? This seems to be working just fine now. I've been connected several hours now, no problems.

     

    My thought is that, with 10.7.4, Apple fixed issues with the Display Ethernet and inadvertently cobbled the USB Ethernet.

     

    I hope that this info helps someone else.

     

    This still needs fixed though. I take my Air and plug into client networks via the USB Ethernet port. I don't need to be restarting several times while on a clients network.

     

    Cheers.

    Rudy

  • PPeelen Level 1 Level 1 (0 points)

    I still have the problem. I really hope Apple can fix this soon... but their lack of absense marks their interests I guess in solving this.

    I just connected my USB cable to the USB... it wasn't even connected to my iPhone and the ethernet quit on me. I do not have any thunderbolt screen, currently I am not even using my 28" external screen since I like not having to use an external one.

     

    I am ready to throw this p*ece of s*it right out through the window soon, sorry for my wording... but this is getting too much. How hard is it to be able to use a normal f*cking ethernet connection? I am really getting mad here!

     

    Br,

    Paul

  • zag0 Level 1 Level 1 (0 points)

    +1

     

    If I close the lid of my MBA, when I open it ethernet is down and the only way to fix it is to reboot.

     

    Come on Apple!

  • teemumm Level 1 Level 1 (0 points)

    It seems that USB Ethernet adapter stops working also when you connect external harddisk to another USB-port.

  • redbull66 Level 1 Level 1 (20 points)

    I just spent 90 minutes on the phone with Apple tech support.  We were able to track this specific problem to the "Android File Transfer Agent" which was in my Login Items list.  This Google program is used to allow Mac OSX the ability to communicate via MTP to an Android phone. This software lets you see the Android as a drive in Mac OSX.  If you uninstall this software, the behaviour listed goes away.

     

    I hope this helps.

  • GaltJohn Level 1 Level 1 (0 points)

    Thanks ! I have also this "Android File Transfer Agent", I will try if this cause a problem.

     

    However, the thing that is not normal is that it is happening this upgrading to 10.7.4.

  • redbull66 Level 1 Level 1 (20 points)

    I think we need Google to update the "Android File Transfer Agent" based on the new Mac OSX 10.7.4. I have been looking for an alternate MTP file transfer software package for Mac, but have not found one yet.  I removed "Android File Transfer Agent" because I rarely connect my Android to my Mac, but Google should still update the software.  I do not know how to report this problem to Google.

  • teemumm Level 1 Level 1 (0 points)

    That was it. After removing Anroid File Transfer Agent, the Ethernet adapter started to work like it did in 10.7.3. Thanks.

Previous 1 2 3 Next