Skip navigation

No WiFi after 5.1.1 iPhone OS upgrade

184610 Views 180 Replies Latest reply: Oct 15, 2013 12:53 PM by mouche RSS
1 2 3 ... 13 Previous Next
SuzeRam Calculating status...
Currently Being Moderated
May 16, 2012 5:29 AM

Lost wifi connectivity on 3GS after 5.1.1 OS upgrade. Have tried EVERY remedy, short of wiping my whole phone (have done reboot, backup and restore, reset network settings, reset all settings, etc.). Apple says my "hardware must be broken." Hard to believe, with 350,000  hits with same problem on Google search, just in these few days since upgrade was released. What's the deal?  I do not want to wipe my phone and start over (for obvious reasons), nor do I unnecessarily want to purchase a new phone (for even more obvious reasons). Clearly there needs to be a fix from Apple!

iPhone 3GS, iOS 5.1.1, Upgrade problems to iOS 5.1.1
  • Dermie1 Calculating status...
    Currently Being Moderated
    May 16, 2012 8:44 AM (in response to SuzeRam)

    Same problem here on iPhone 4S after upgrading to 5.1.1. Can't link to home wifi while all the family's iPod Touch's, iPad2 and ATV2 - not upgraded - still work fine. Not upgrading those in a hurry.

    Tried wiping all network settings on iPhone no luck. Connection flashes up for a few milliseconds then disappears again.

    Strangely, when I swopped out the home router, ZyXEL for a Netgear, then the iPhone connected and stayed connected....haven't tried swopping back yet.

  • DanaBMusic Calculating status...
    Currently Being Moderated
    May 16, 2012 1:12 PM (in response to SuzeRam)

    I've tried everything imagineable to resolve my 3GS wifi probs since 5.1. Resetting, you name it. I even restored my 3GS as a brand new iPhone and it did not solve the wifi issue. 5.1.0 and 5.1.1 killed my wifi reception down to only a few feet. What a coincidence that so many of us are having "hardware failure" after installing 5.1.

     

    Save yourself some time and headache and don't bother restoring your phone, it likely won't fix the wifi problem so many of us are having with 5.1.* over 2.4ghz wifi.

     

    Note that 5.1.1 works nicely on iPad 2 over 5ghz. All my Apple and non Apple devices see my wifi clear as a bell with full signal. My iPhone 3GS now can't see 12 local networks since 5.1.

  • pdstevenson Calculating status...
    Currently Being Moderated
    May 17, 2012 6:45 AM (in response to DanaBMusic)

    The same thing is happening with me.  I haven't been able to detect a wifi network at home or any of the number of networks at work for the last week or so since upgrading to 5.1.1.

    Resetting to factory settings has not worked.

  • opensky Calculating status...
    Currently Being Moderated
    May 18, 2012 3:39 PM (in response to SuzeRam)

    Same problem here. I used to connect to wifi on my 4s at home and at work.Since the upgrade to 5.1.1, at work I can only stay connected for 1-2 minutes at the most before pages stop loading. Home wifi still works with no problems.

     

    I tried resetting network settings, but no improvement. I hope a fix is released soon.

  • s49 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2012 3:49 PM (in response to SuzeRam)

    I am having a similar problem since updating to 5.1.1. I can connect to my home network but not the public wifi at work. I was able to get it to work after resetting my phone but only for one day. The wifi symbol shows in the menu bar but nothing will load, safari, mail, Facebook. I'm just glad I'm not the only one. Now I know it's not just my phone.

  • imaginenikkie Calculating status...
    Currently Being Moderated
    May 19, 2012 6:10 AM (in response to SuzeRam)

    Same here.  Under settings, I can't even try to connect - it's greyed out and says "No Wi-Fi". I just upgraded a few days ago.  I really don't want to waste the time resetting or anything like that, I just hope we get a solution from Apple soon... I'm very displeased. 

  • jlo2168 Calculating status...
    Currently Being Moderated
    May 19, 2012 8:33 AM (in response to pdstevenson)

    I have the same problem with my 4S.  It keeps losing connectivity to stored wifi and often does not detect the wifi at all! 

  • et482 Calculating status...
    Currently Being Moderated
    May 19, 2012 3:28 PM (in response to SuzeRam)

    After updating my iphone 4s to 5.1.1, it would not auto connect to my home wifi.  This is what worked for me.  First off, I have an access list in my netgear router.  I removed my iPhone from it and reset it.  Then reset network settings on iPhone.  Added my phone mac address back in my router access list.  Disabled iPhone wifi, and re-enabled it and selected it to 'Ask to Join Networks'.  I selected my network when it came up, entered the password, and was connected to my wifi.  From then on, its stayed connected.

     

    I have no idea why this worked.  I've spent days trying to fix it.  I know my case it a little different because I use the router access list to save mac addresses.  I think by deleting it, it probably fixed it. 

  • Martin G. Calculating status...
    Currently Being Moderated
    May 21, 2012 12:42 AM (in response to SuzeRam)

    Same problem here. Tried a load of stuff. Went to my phone shop and the guy simply told me to wait for the next upgrade. How long do I have to wait? It's been a week since this trouble started. WHERE IS APPLE ON THIS!? Come on guys, get your butts into gear.

  • RazvanB Calculating status...
    Currently Being Moderated
    May 21, 2012 1:11 AM (in response to SuzeRam)

    Hey

       I'm having a smilar problem here. Upgraded to 5.1.1 on my 4s and since then I cannot find any wifi networks. My wife's 4 finds 6-7 networks (including my home one) in the building while mine just searches and searches and nothing. Tried hard reset, tried reset network settings and even tried a restore (Unfortunetlly i was backing up on iCloud and now i canot restore anything as you can only do it over wifi!).

        I was thinking of trying a downgrade to 5.1  - not sure if it would help but i found a way to do it without jailbreaking the phone. I bought it without contract from Apple US and the guys at Apple support in Europe are not allowed to even touch my phone.

        Please let me know if anyone found any other ways arround this issue.

  • pitouras Calculating status...
    Currently Being Moderated
    May 21, 2012 2:31 AM (in response to SuzeRam)

    Hi

    Same here since 5.1.1 on iphone 4 i can not connect to any of my wifi spots (office-home) and my ipad2 also the same problem..When i press the button forget this network and enter the codes again then i connect...But who can do this all the time...Why must apple fix something by loosing something else???

    They must fix this ASAP

  • Martin G. Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 22, 2012 5:25 AM (in response to SuzeRam)

    So is Apple on to this now? Not only have I not been able to establish a continuous wifi connection for two weeks now, since today my battery is hemorrhaging. Come on guys. Geez.

  • decmiami Calculating status...
    Currently Being Moderated
    May 23, 2012 8:09 PM (in response to SuzeRam)

    I have the same problem.  When I upgraded to IOS 5.1.1, the problem started immediately.   I spent over two hours on the phone with apple today and have wiped my phone several times, even restored it as a new phone just to check if it was something in a backed up file.  She was unable to resolve the problem.  Would be nice if Apple fixed this apparent but quickly!!!

1 2 3 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.