Previous 1 9 10 11 12 13 Next 180 Replies Latest reply: Oct 15, 2013 12:53 PM by mouche Go to original post
  • karenfrommallala Level 1 (0 points)

    THank you thank you thank you... After trying everything else, restore, reset, even put it in the freezer briefly( got anxious and had to take it out), took to a repair shop who told me they only fix hardware and to take it to someone who does software.... I saw your post, the only one who suggested this, and it works. Again thank you

  • kal602921 Level 1 (0 points)

    Thank you so much rbrann.  I've removed the case and the WiFi connected right away.  I've been having this problem for over a year...WiFi unable to search for the networks rbrann is the answer.

  • undercut Level 1 (0 points)

    sounds like a grounding issue with the wifi connector

  • Madelynn1 Level 1 (0 points)

    I lost the wifi connection on my iPhone 4S after the latest update. I scheduled an appt at the "Genius Bar" at the Apple store here in Naples, Florida. They should relabel it the "Idiot Bar." After losing my apps doing a diagnostic I was told the antenna is bad and there is nothing they can do for me other than my buying a new phone. When I left the store I noticed there was NOTHING on the phone. Just arrows going nowhere. When I saw the technician leaving the store she informed me she was "off the clock." Fortunately the manager witnessed this exchange and was at least able to regain my mail and contacts. I cannot sync it with my iTunes as that is on my  home computer in Boston. Nor can I sync with the cloud because I have no wifi. All details explained to her before my iPhone had been rendered virtually useless. Eligible for contract upgrade in July. Questioning whether I should go with the then 5s or Samsung Satellite 4.

  • Andrew1214 Level 1 (0 points)

    This problem is not only with iphone updates, but ipod updates also. I just updated my ipod touch and now my wifi is grayed out. I have tried resetting all settings and have restored the ipod to factory. Nothing seems to work. I wont update my iphone until apple starts to see that this is a software issue and not a hardware issue like they claim.

  • dvit123 Level 1 (10 points)

    I actually turned my wireless router on and off and then reset it. Then I reset my network setting on my phone and that fixed it

  • Iceflake24 Level 1 (0 points)

    So nothing has helped me! I have no money to get a new iPhone and they deleted everything off my phone and I couldn't even back it up! Apple are a poor customer service company. You think buying a new iPhone you would get 1yr warranty no I got 3 months! I'm furious.

  • mouche Level 1 (0 points)

    A couple of days ago my 4s was updated to the lates OS and afterwards refused to connect to my home WiFi.

    I had no idea there were so many problems with Apple products after surfing for possible solutions and was seriously considering an iPad for my wife for Christmas - not really sure now .

    Having tried just about every possible fix through this and other forums I decided to pop into the local 'phone shop this morning and just ask them if they would try to connect my 4s to their WiFi for me, temporarily and just for a test..

    They just tapped their connection name - typed in their password - and down came all the email .

    I asked them what type of security key they were using and they answered WEP.

    When I got home I checked my own security key and it was WPA with a rediculously long access key which would be impossible to input on the iPhone, so I changed my key to WEP which gave a much shorter (and obviously less secure...) access key.

    Then I went to Settings - WiFi - and chose Other Network.

    When asked I input the new access code and voila - WiFi connection under the name of my home WiFi network.

    It has been connected 6-7hrs, hasn't dropped out like it used to before and the Internet is faster for surfing. It also displays a much stronger signal .

    I really hope what did it for me will do if for some of you.

    Recap: The 4s was seeing mine an neighbours networks but just refusing to connect.

    After proving the 4s worked elsewhere I changed my home network security from WPA to WEP.

    (I did read this somewhere before but decided to confirm conectivity elsewhere before trying it).

    Good Luck.

  • deggie Level 9 (52,652 points)

    WEP security is extremely poor, not much better than none at all. Might be time to upgrade to a router with WPA2 security.

  • mouche Level 1 (0 points)

    Hi deggie.

    You are right of course. "Slowly, slowly,catchee Monkey"

    Just gone from no WiFi to a poor security connection so improving on that is the next step. Not sure how to input the massive security key with weird symbols though?

    That could well be my next post ;-)

  • deggie Level 9 (52,652 points)

    WPA2 does not require a massive security key. You can set whatever password you want.

  • mouche Level 1 (0 points)


    If I select WPA2 in my router config, I am invited to choose a random generated sec key which very long.

    I have not tried yet but maybe I can type my own key in?

  • deggie Level 9 (52,652 points)

    You can use your own key. Check the manual for your router make and model.

  • mouche Level 1 (0 points)

    OK, I'll try that tomorrow.

    Thank you for the contact & advice.

    I'm working from the iPhone now :-)

  • mouche Level 1 (0 points)

    Sri - contact & advice.