Previous 1 2 3 4 5 6 Next 80 Replies Latest reply: Sep 22, 2014 11:45 AM by ChadSD Go to original post
  • Big Robs Level 1 (0 points)

    The hardwired connection prevents the connections to reset, when it goes into sleep mode.  Use wifi, or set it to not go to sleep, and it should fix your problem.  It all goes back to a max of 100 connection max, and an inability to release the connections.  I have noticed the stuttering on my atv3, when the number connections gets high.

     

    Apple has been pretty poor in responding to bugs lately.  This shocks me, and lets me know that I should wait to adopt the next version of OSX.

     

    I miss Steve...

  • DERISCO Level 1 (0 points)

    Apple Normally never acknoledges bugs just fixes them behind the scene!

  • Big Robs Level 1 (0 points)

    The bug fixes are described generally in the release notes.  This bug hasn't been fixed in MANY months.  I have over 3TB of content i have PURCHASED from Apple, and this bug affects my ability to use what I paid for.  I still have a few bugs from OSX 10.4.7 that I was expecting to be fixed a long time ago.  No, they arent fixing them behind the sceen, they arent fixing them at all!

  • texinick Level 1 (15 points)

    I don't know if this will help anyone or not...

     

    I have 3 AppleTV's in the house.  Two are wi-fi, and one with a wired connection.  Every time I came to use the AppleTV's (regardless of network connection) I'd have to restart iTunes as per everyone else here.

     

    After reading through this post, I thought I'd try an experiment.  Last night, I pulled the ethernet cable from the only wired AppleTV.  I've tried it twice since, and both times, my AppleTV's have worked without having to restart iTunes.

     

    I'll keep an eye on it and re-post if anything happens, but it seems that even one wired AppleTV on the network will cause all the others to no longer see iTunes.

     

    Fingers crossed it's that simple! :^)

     

    My guess (hope?) is that when the AppleTV's wake up through the night, they're maybe establishing some sort of connection to iTunes, but the wired ones aren't dropping the connection properly, causing the available connections in iTunes to max out.  That's my theory anyway!!

  • SilverSevens Level 1 (0 points)

    texinick: Have you tried the wired\no sleep option??

  • texinick Level 1 (15 points)

    @silverSevens, no I haven't, since pulling the Ethernet cable out, all my appleTV devices have been working without needing to restart iTunes. I figured that's better than leaving it on all the time :)

  • dschamis Level 1 (0 points)

    I can confirm that after a Mountain Lion upgrade this problem still exists.

     

    I haven't tried the wifi-only solution yet - will try today - seems stupid after I wired my whole house with CAT6 but probably still worth trying.

  • abby'sdad Level 1 (0 points)

    I have the same problem. Three Apple TVs. It wasn't always the case, but I'm not sure when exactly I started noticing it. Nowadays, I have to restart iTunes every day if I want my Apple TVs to be able to connect via Home Share to my iTunes library.

  • alecksjaycubs Level 1 (0 points)

    @abby\'sdad

    It seems the fix is to either set the AppleTV to never sleep, or to change the connection to WiFi. Personally I use the never sleep fix. Just make sure you have a screen saver turned on to avoid any screen burn.

  • SilverSevens Level 1 (0 points)

    Same here, the never sleep option workd best for me. I just switch to a different source since I only use it for movies and music.I also put it on one of the black and white menu screens and no screensaver. That way the processor has very little to do but keep a few characters up. Been working great so far.

  • intangybles Level 1 (0 points)

    Hi, Just to confim it dose not seem to matter at all what platform your itunes is running on, itunes will still seem to go to sleep when left to its own devices for a while!

  • SilverSevens Level 1 (0 points)

    Correct. Platform is not an issue. We believe it's an issue with the ATV's. Specifically the ATV3

  • New Jersey Jason Level 1 (0 points)

    Until Apple gets off their butts to fix this, you can do this.  Create a workflow that 1. Closes iTunes, 2. Pauses 10 seconds, 3. Opens iTunes.  Then Save it as an Application.

    Screen Shot 2012-09-09 at 8.52.49 PM.png

    Then...

     

    Create an Apple Script by "recording yourself" launching your new workflow.  Save that Apple Script.

    Screen Shot 2012-09-09 at 8.53.10 PM.png

    Finally..

     

    Go into Mail, and create a Rule that when you receive an email with the subject as "Restart iTunes" it will run your Apple Script (wchich launches your workflow app).

    Screen Shot 2012-09-09 at 8.53.34 PM.png

    Just send yourself an email from you chair!!!  :-)  Please reply if this works for you.  It works GREAT for me on Mountain Lion!

     

    Enjoy!

     

    Jason

  • SilverSevens Level 1 (0 points)

    Jason: We've discovered that you could just disable Sleep Mode on your ATV's. Place them on a Black and White Menu screen instead of putting them to sleep - Has been working for months without a single restart.

    Worth a try.

    Thanks for your option though - another temporary solution people can use.

  • spiffing Level 1 (5 points)

    The ATV3 sleep disable fixed this issue for me. It also fixed a really serious issue that effectively broke the iOS Remote app to control iTunes too. Apple really need to fix this serious issue quick.