Previous 1 2 3 Next 35 Replies Latest reply: Jul 31, 2012 4:09 PM by Simbahart
Ron24 Level 1 (0 points)

ipad cannot connect to itunes store?


iPad, iOS 5.1.1
  • boobooboobooboo Level 3 (870 points)

    Are you getting an error message?

  • Texas Mac Man Level 8 (46,565 points)

    Can't connect to the iTunes Store

    http://support.apple.com/kb/TS1368

     

    You may not be connecting to the internet via wifi.

     

    Look at iOS Troubleshooting Wi-Fi networks and connections  http://support.apple.com/kb/TS1398

     

    iPad: Issues connecting to Wi-Fi networks  http://support.apple.com/kb/ts3304

     

    iOS: Recommended settings for Wi-Fi routers and access points  http://support.apple.com/kb/HT4199

     

    Additional things to try.

     

    Try this first. Turn Off your iPad. Then turn Off (disconnect power cord) the wireless router & then back On. Now boot your iPad. Hopefully it will see the WiFi.

     

    Go to Settings>Wi-Fi and turn Off. Then while at Settings>Wi-Fi, turn back On and chose a Network.

     

    Change the channel on your wireless router. Instructions at http://macintoshhowto.com/advanced/how-to-get-a-good-range-on-your-wireless-netw ork.html

     

    Another thing to try - Go into your router security settings and change from WEP to WPA with AES.

     

    How to Quickly Fix iPad 3 Wi-Fi Reception Problems

    http://osxdaily.com/2012/03/21/fix-new-ipad-3-wi-fi-reception-problems/

     

    If none of the above suggestions work, look at this link.

    iPad Wi-Fi Problems: Comprehensive List of Fixes

    http://appletoolbox.com/2010/04/ipad-wi-fi-problems-comprehensive-list-of-fixes/

     

    Fix iPad Wifi Connection and Signal Issues  http://www.youtube.com/watch?v=uwWtIG5jUxE

     

    ~~~~~~~~~~~~~~~

     

    If any of the above solutions work, please post back what solved your problem. It will help others with the same problem.

     

     Cheers, Tom

  • aussiedee77 Level 1 (0 points)

    I can't connect to the store either but have no problems surfing, playing online games etc so it's obviously not wifi. Seems thi only began after the latest os5 update. I'm also replying on my iPad so I know it's not wifi problem.

     

    I have 10 app updates and can't update them because of this issue. I can browse iTunes browse apps but the second I try to update an app it says cannot connect to iTunes store.

  • Vignesh24 Level 1 (0 points)

    I've got the same problem too. . Solution anyone?

  • Demo Level 10 (88,801 points)

    Sometimes rebooting the router will help. Sometimes signing out of your Apple ID, restarting the iPad and then signing in again can help. Sometimes a stalled download in iTunes can cause problems.

     

    Check iTunes and see if you have a pending or stalled download in there. If you do, finish that download or delete it if you can. If you can't finish or delete the download on the iPad, do it in iTunes on your computer and then sync the iPad. Then go back to the app store and see if you can connect.

     

    If that doesn't work or if that was not the problem, go to Settings>Store >Apple ID, tap your ID and sign out. Then reboot the iPad, Reboot the iPad by holding down on the sleep and home buttons at the same time for about 10-15 seconds until the Apple Logo appears - ignore the red slider - let go of the buttons.

     

    Then go back to Settings>Store>Sign in and sign in again and see if you can connect and download.

     

    One other thing that you can try is to turn airplane mode on and off and see if that helps.

  • Vignesh24 Level 1 (0 points)

    Thank you. . Rebooting the router and then switching wifi ON/OFF on the iPad seems to help. . Thanks again!!

  • Doughnutno Level 1 (0 points)

    No

  • Gracie77 Level 1 (0 points)

    Thanks so much, Demo! I've been struggling with this issue for a few weeks. Your suggestions worked like a charm! Finally able to download apps again!

  • Demo Level 10 (88,801 points)

    Great. I'm glad that something in there worked for you!

  • Djwuk Level 1 (0 points)

    Have same problem with my iPad since latest iOS update. Have tried all the above :(

  • eillAAllie Level 1 (0 points)

    Yeah every time i try to download an app it says cannot connect to iTunes. Idk wat to do I've seen some ppl say it's an apple problem but not sure:/

    And I'm on my iPhone rite now( didn't think wud b difference from iPad in this case)so wifi isn't a problem

  • fwd@ Level 1 (0 points)

    I also have the problem, that "Cannot connect to iTunes Store" appears everytime I want to download an App from my iPad. The only way I can download something to my iPad is by downloading it to my computer first and then syncronising it with my iPad.

    I don't have any wifi issues on my iPad since everything else works fine.

    I already tried siging out my AppleID and turning off and on my iPad and then signing in again ... but nothing seems to do the trick. I have also tunred off and on my router - just in case ... but that didn't help either.

    Is there anything else I could try?

  • Dottore de Funk Level 1 (0 points)

    I'm getting this on both iPhone and iPad on 5.1.1 I think its an Apple problem they haven't bothered to sort yet. I'm currently wasting time and effort resetting the iPad which is taking forever. On the iPhone I can't be bothered to go through the agony so have found that if I keep trying to download app updatesand going backwards and forwards between the app store update I do get can't connect message but after a few tries most apps will update. Very painful very tedious and typical Apple - and I'm a fan since 1991! Its nothing to do with routers, wi-fi settings its just a flat out Apple issue in my view.

  • praveedh Level 1 (0 points)

    Same here, just now I bought a new iPad2, cannot connect to itunes store message pops up and it doesn't install. Even though I have successfully upgraded the software.

     

    Regards

     

    Praveedh

Previous 1 2 3 Next