Previous 1 2 3 4 Next 54 Replies Latest reply: Aug 23, 2014 11:25 AM by John Gordon3 Go to original post
  • hyperlitebitt Level 1 Level 1

    I had a similar issue with my ipod nano 2nd generation (i know very old school) after upgrading to itunes 11.0.2. My ipod was not recognized by my itunes. It turned out to be a simple solution for me. All I had to do was reset my iPod Nano and plug it back into my USB port and it was immediately recognized. Instructions on how to reset each type of ipod can easily be found on this support community. Simple but I hope it helps.

  • HelpJenna Level 1 Level 1

    Hi, my ipod nano (from 2007) wont connect to my itunes either. It happened when I updated my itunes awhile ago in Otober 2012. But it hasnt been a problem until now since my iphone was recently stolen. When I connected my ipod it charges and everything but itunes does not recognize it all. I am not sure how to follow the previous advice about "device manager" because im using a macbook pro.... I am also not the most technical savy person in the world so any help would be appreciated! Thanks.

  • goodgirlpam Level 1 Level 1


    im having connection issues to.  had to get a new pc as other one died, now running Windows 7.  i have a ipod nano 6th gen. i loaded ITunes onto pc, connected Nano, checked for updates it said it didnt need any.  when i go to ITunes it shows my device and my music but it is all "greyed" out so I cant play anything or access it.  i have authorised this pc (not sure if that would make a difference) i have uninstalled and installed ITunes twice.  After reading some of the above problems i went to Device Manager and i have a "USB mass storage device" with an exclamation mark against it (im assuming this is my Nano).   i checked for update driver and it says i have the latest.  i uninstalled the driver and it reloaded it but still shows the same thing.  Again reading above problems i tried another Apple cable i have and that hasnt made a difference.  Any ideas please ?

  • Alex hippo Level 1 Level 1

    Hi plan b77,


    Please could you help me!!! My ipod nano 6th generation won't appear on itunes but my computer knows my ipod is connected because it makes the same sound as usual. any info would be great

  • Alex hippo Level 1 Level 1

    My ipod nano 6 generation won't be reconized by itunes but computer makes the same sound as usual as its plugged in. any info would be great

  • Cousin0Dave Level 1 Level 1

    My ipod nano (6th) won't 'boot up' either. It is exactly like goodgirlpam"s problem...the nano will not be reconized by windows 7.  Of couse I called the "help" people, but after $20 they said my warrenty has expired!  So, why did my ipod work with windows XP and not with windows 7?  I have expended many hours trying all the 'fixes', but even when I take it to the computer stores it won't work.  WTFO?

  • Cow Patty Bingo Level 1 Level 1

    I have a 6th Gen Nano and am running Windows 7, and have been dealing with these exact same issues for roughly 2 weeks now. Throughout all of this, I've regularly been plugging in my ipod classic, as well as a shuffle, with no issues whatsoever, so it seems to be some glitchy issue related specifically to the nano (possibly the iphone as well based on other threads I've read, so maybe it's a touch issue) and Windows 7/8. During this insane quest, I even tested it on a Mac, and it worked just fine.


    Initially the Nano, when plugged in, would make the sound, pull up itunes, be visible under My Computer, but wouldn't show up in itunes.


    A list of the things I've done: uninstalled every trace of itunes/reinstalled (numerous times), run a registry cleaner, played with the firewall settings, played with the startup items, uninstalled/reinstalled drivers, reset the ipod, restored the ipod, reformatted the ipod, tried different cables, tried different usb ports, tried everything possible in Device Management, googled every error message I've gotten....and even made 3 separate Genius Bar appointments at the Apple Store, all to no avail.


    Once, I actually got it to appear in itunes, and celebrated like a mental patient, but then my elation quickly crashed when itunes wouldn't let me drag/drop anything onto it, then after ejecting went back to not recognizing it.

 's what I did that finally got this thing working. In an attempt to leave no stone unturned, I finally decided to try an itunes alternative, just to see what would happen. A quick google search led me to a Lifehacker article detailing the top 10 free itunes alternatives, so I downloaded the #1 choice, MediaMonkey, and after installing and importing my library I plugged the Nano in, and it popped up immediately on the left. I tested it by dragging/dropping songs onto it, ejecting it, plugging it back in, etc etc, and it works perfectly and functions more or less the same as itunes, so there's no real learning curve. I'm now thoroughly convinced this whole thing is just a glitchy itunes/windows compatibility issue that'll hopefully be resolved by the next version of itunes.


    I hope this helps someone avoid all the frustration I dealt with.

  • Dftbarr Level 1 Level 1

    I had the same problem, and the device connectivity tests said it couldn't detect an iPod but it said I needed "Unable to find locale data files. Please reinstall." I have no clue what to do!

  • matttaylor1 Level 1 Level 1

    HELP ME, as you seem to now your stuff you might be able to help me, when I plug in my 6th gen nano, on windows 8.1, it makes the noise and opens up my computer to show, as it normally does, but it does not contain my ipod in t, when itunes is open and i plug my ipod in it just says 'an ipod has been detected but it can not be identified properly'. I have tried uninstalling/reinstalling itunes, resetting my ipod, openingdevice manaager and reinstalling the USB driver that only appears when I connect my ipod (so i assume this is my ipod but is just called USB mass storage device). I do not know what else to do as i have tried everything else i have found on this thread and i am now getting extremely frustrated

  • John Gordon3 Level 1 Level 1

    Something I haven't seen listed here that solved my problem:  Turn off the device before plugging it in to sync.

Previous 1 2 3 4 Next