Previous 1 2 3 Next 41 Replies Latest reply: Feb 15, 2015 11:44 AM by Paul Boyer1
todd1010 Level 1 Level 1 (0 points)

Whenever I send a email thru Apple Mail using my Gmail account, it will put the email in the DRAFTS folder. How do I keep this from happening?

 

I have 3 email accounts that I use in Apple Mail and the Gmail one is the only one that does this.


iPad 2, iOS 5.0.1
  • Soto Level 3 Level 3 (655 points)

    If you are not connected to the internet it can do this so you can send it at a later time.  Maybe the password authentication for Gmail is not working.

  • todd1010 Level 1 Level 1 (0 points)

    I am connected to the internet when I just sent one.

  • Glenn Leblanc Level 5 Level 5 (6,920 points)

    Mail creates a temporary draft each time you compose a message. If you send the message while the IMAP account syncs, the draft doesn't get deleted and gets stored in gmail's draft folder.

    If you want to stop this, uncheck to store drafts on the server. It will put the draft folder back under the gmail folder and create a local draft folder for gmail. If you need to complete a draft on another device, simply move it to the IMAP draft folder.

  • todd1010 Level 1 Level 1 (0 points)

    @Glenn,

     

    This is what I do. I unchecked the store drafts on server.

  • Glenn Leblanc Level 5 Level 5 (6,920 points)

    Does the message show up at the gmail site in the drafts folder? If not, check the drafts folder of the other accounts and see if it shows in one of the other accounts.

     

    Do you have a drafts folder under the gmail folder in the bottom of the sidebar?

  • todd1010 Level 1 Level 1 (0 points)

    The message is NOT showing up in the gmaill DRAFTS folder on the gmail site.

     

    I checked my iCloud email and with the "Store draft messages on the server" is checked, everything seems to work correctly here. There is not a email in the DRAFTS folder on the site or in Apple Mail. So this seems to works like I think it should.

     

    In Apple Mail, I have do have a "Drafts" folder under the [Gmail] folder in the bottom of the sidebar.

  • Glenn Leblanc Level 5 Level 5 (6,920 points)

    OK. Just wanted to be sure it wasn't going to an IMAP draft folder.

     

    Try this. Highlight the Inbox and then quit Mail.

    In the FInder, select Go, then Go To Folder. Paste this in the box:

    ~/Library/Mail/V2/Mailboxes/

    This show open a Finder window in your Home Library folder to the Mailboxes folder. This is where local mailboxes are stored. Move all draft mailboxes within that folder to the trash.

     

    Restart Mail.

    In Mail's preferences, under the Accounts tab, select the GMail account and make sure the correct outgoing server for that account is shown in the box. If not, click on the server box and select the correct one and check the box to use only that server for that account.

     

    Try to send and see if the problem still occurs.

  • todd1010 Level 1 Level 1 (0 points)

    Once I pasted that into the finder box I am getting a icon named "Outbox.mbox".

     

    Am I supposed to open that icon (folder) and delete EVERYTHING that is inside that folder?

  • Glenn Leblanc Level 5 Level 5 (6,920 points)

    No, the folder should be Mailboxes.

     

    Paste just this in the Go To Folder box:

    ~/Library/Mail/V2/

     

    You should then see all your folders within Mail. Look for the Mailboxes folder. You should have at least one draft folder listed for the gmail account. If not, then it means you have none and could be part of the problem.

  • todd1010 Level 1 Level 1 (0 points)

    I see all of my folders in there. Inside the "Mailboxes" folder I have a "Outbox.mbox" icon (folder). And this is what's inside the "Outbox.mbox" folder.

     

    Screen Shot 2012-05-23 at 12.12.01 PM.png

  • Glenn Leblanc Level 5 Level 5 (6,920 points)

    Well if you have no draft mailbox list in the Mailbox folder, then it's obvious that it's not creating one for that account or any other, meaning it's putting the drafts in the IMAP draft folder. You may have some corruption within the Mail folder or preferences.

     

    Try this out:

    Select the draft folder under that gmail account in the sidebar, then go to Mailboxes in the menu and select Use This Mailbox for: drafts. That should move the draft folder from the gmail folder to Mail's main draft mailbox.

    Open Mail's preferences and check to see that the box to store messages on the server is checked.

     

    Create and save a test draft message. Verify that it's also saved at the gmail website (should also appear in the draft folder under gmail account at sidebar bottem). Once that's done, go back into Mail's preferences and uncheck to store drafts on the server. That should move the draft mailbox back under the gmail folder. Save the changes.

    Quit and restart Mail and verify Mail's preferences remain unchecked for storing drafts on the server.

    Create a new message and save as draft. Verify that it is not saved to the gmail draft folder in the sidebar bottem or gmail website.

     

    If all's OK from there, delete the test drafts you created. Once again highlight the Inbox and quit Mail. Restart Mail and the draft folder should not appear in the sidebar. It will still appear on the toolbar if you have it showing (to show, select Show Toolbar in Mail's menu under View).

    Create a test message and send. See if that works. Hopefully, it will fix whatever preference files is stuck.

  • todd1010 Level 1 Level 1 (0 points)

    Use this mailbox for Drafts is greyed out in the menu.

     

    However I created a test Draft email and saved it. It is correctly showing up in my DRAFTS Apple Mail and on Gmail's site online under DRAFTS.

  • Glenn Leblanc Level 5 Level 5 (6,920 points)

    If Use this Mailbox for: Drafts is greyed out, it means either you didn't have the IMAP draft folder highlighted, or it's already been synced and you have Store Drafts on Server selected.

    Did you have store drafts on server selected before you created the test email? If so, then that outcome is correct.

  • rajua Level 1 Level 1 (0 points)

    I also experience the same issue with my me.com email account.

    it is very uncertain situation as i don't know whether the receipient got my mail or not. Sometimes it gets back to drft box after 1 day. Please help me.

Previous 1 2 3 Next