Previous 1 2 Next 19 Replies Latest reply: Sep 11, 2014 6:48 PM by mreoch
tanyariko Level 1 Level 1

NEED HELP! Using the new iPad and when I open my library it was trying to download a book I'd previously purchased,read, and deleted. I tried to delete it before it fully downloaded but it would not allow it. Then, like the cascading windows error on PC's, more and more copies of this book appear in my library and it's growing exponentially (like the cascading windows tile analogy). It never fully downloads the book and will not allow me to delete. Now I've got 24 copies of Personal Foul trying to download and every time I close the program and reopen it has added more.


Can you help!?!?


-I'm running the most recent iOS and iBooks versions (5.1.1 and 2.1.1 respectively)

-The book that is attempting multiple copy downloads is a book I purchased a year ago on my first gen iPad. Upon upgrading to the 3rd gen iPad I did not sync that particular book and have set auto sync to the "off" position-- so it should not be attempting to download that book in the first place

-I've attempted to restart my iPad

-I've exited the application several times

-I've gone to the "purchased" section in the store and it does not show this book as "Installed".

-I have attempted to select and delete each copy but it will not delete once I've entered the command

iPad (3rd gen) Wi-Fi, iOS 5.1.1, iBooks 2.1.1 "multiple copy" bug?
  • StudioDhika Level 1 Level 1

    I also have this problem. Some books have multiple entries, and I can't even open them in iBooks. They're just there, and some also has "transfer in progress" icon. I'm using new iPad with 5.1.1 and 2.1.1 too.

  • j.frommontmorillon Level 1 Level 1



    Had the same thing happen here:

    I decided to sync my iTunes book library to the latest iBooks on my "New iPad" ™, over a thousand books. The operation went smoothly but then on the shelves of iBooks some books had multiple undeletable  copies (with an empty transfer bar acoss the cover). Most, if not all, of these problematic books were downloaded in 2010.


    One had over 60 such copies... In the iBooks app, deleting the complete copy of the said book and then downloading a new copy of the same from the online store caused the disappearance of most of the useless copies, only three remained. I then switched the iPad off (completely) and upon reopening iBooks after restarting the remaining bad copies disappeared along with almost every other uncomplete books, just a few remained.

    Don't forget to check for duplicate books in iTunes after syncing your device.


    I hope this will help solve your problem.

  • Maaikefest Level 1 Level 1

    I wanted to try your advice but I can't. I don't have a complete copy of the book. In my case it is Summer's Path by Scott Blum. Everytine I download a book or open iBooks it keeps duplicating, I have so many copies now that iBooks is completely unusable :(. Everytime I try to download a complete copy of the book so I can delete it afterwards it just won't download. I already tried to delete iBooks and reinstall it but the problem just came back, perhaps because my books were stored in iCloud. I really don't know what to do anymore :(

  • peterfrombath Level 1 Level 1

    I have the same problem.  For certain books there are over100 entries none of them usable.  This is a terrible bug and unacceptable. Theye are undeleteable.   Has anyone a solution. I have reinstalled Ibooks and reset the ipad deleting all files but no joy.  If this goes on I will get rid of my Ipad


    Peter Rowan

  • itux Level 1 Level 1

    Me too, but can't remove this books, only download.... Apple, add a feature to will remove content from purchased list....please ;(

  • owltash Level 1 Level 1

    I just had the same problem too. I have an iPad 2 and when I first downloaded three books that I had on my iPad before the last update it worked fine, but then I wanted to update the cover art, so I updated it in iTunes and just dragged them back to my iPad without removing them first. This is what I think did it. After that there were about 10 copies at least of each book, at first they all had progress in their little bars but after a while they just became empty and sat there like that. I tried restarting my iPad but that didn't work. I don't have my iTunes library synced because I used to use another computer for it, so I didn't want to check sync and have everything be deleted. Instead I went to iTunes and went to the "on this iPad" tab and selected the books that were being copied. Then I deleted them and when I did at least 7 of each of the copies disappeared. So then I navigated away from that library in iBooks and went to my purchased books. I renown loaded a completely different previous copies so when I returned to my original library the rest of the copies disappeared too. Miracle! So after that I just went back to iTunes and put the three books back on my iPad and now they work fine and still have all the notes I previously put in them. Hope this works for you too!

  • REDDEVIL52 Level 1 Level 1

    I had this problem. I was unable to delete the duplicate books. So I found the best way to remove duplicate books is as follows:----


    Just delete the ibook app from your device, and then download a new edition from Itunes. This will remove all duplicate books.


    You will then need to sync your device with your computer to restore all bought books..

  • widartoadi Level 1 Level 1

    Go to  settings, find ibooks, turn off  "show all purchases"

    This way if you want to download the book, you should go to the store and download from the purchased book section

  • MiPaSoDu Level 1 Level 1

    @widartoadi, cheers, this has solved my problem. I had multiple duplicates all waiting to download, most infuriating. Now I have exactly what I should.

  • philipfromspringfield Level 1 Level 1

    nice and easy - thanks

  • jvalera Level 1 Level 1

    This solved my problem too. Thanks.

  • BlueSnake Level 1 Level 1

    My wife had this problem on her iPad 3.  I deleted iBooks and then reinstalled it.  Synced purchases and the problem was solved.

  • Camtullos Level 1 Level 1

    Delete, reinstall, and sync worked for me.

  • CarolP1965 Level 1 Level 1

    Delete, reinstall and sync worked perfectly for me too.


    Although if this is a bug then it needs to be fixed - very distracting!

Previous 1 2 Next