Previous 1 2 3 Next 41 Replies Latest reply: Jun 6, 2014 10:17 AM by Scottish john
Dann from reading Level 1 Level 1 (0 points)

Hello could someone help me? I have had my iphone 4 for about 4 5 months as this was a replacement. But now i keep having this issue. I have had it for about a month. I connect to my internet and it works perfectly. Surfing the web facebook all works. But soon as i go on to youtube and click on a video every 4 - 5 minutes the wifi signal drops and to get it back i have to ecit to the home screen and wait for a couple of seconds. Then i go back onto the video and it happens again. This happens on alot of WIFI connections not just my one what could be the issue?

iPhone 4, Windows 7
  • diesel vdub Level 7 Level 7 (21,995 points)

    Settings > General > Reset > Reset Network Settings.

    Basic troubleshooting from the User's Guide is reset, restart, restore (first from backup then as new).  Have any of these steps been tried?

  • SDYankeeNY Level 1 Level 1 (0 points)

    I am having the same problems and have done all the above trouble shooting.  It basically disconnects from the wifi after the screen closes and you reunlock. 

  • diesel vdub Level 7 Level 7 (21,995 points)

    SDYankeeNY wrote:


    I am having the same problems and have done all the above trouble shooting.  It basically disconnects from the wifi after the screen closes and you reunlock. 

    No you are not.  The device is working exactly as designed.

    Unless something is actively using the Wi-Fi, like streaming audio, iOS is designed to shut down the Wi-Fi to save power when the screen goes dark to save power.


    Wi-Fi will auto reconnect when the device is unlocked, but it may take a second or two, during that brief time the user will notice the device is on the cellular connection.

  • karosurly Level 1 Level 1 (0 points)

    Does anyone have a fix for this? The exact same thing happens to me with my 4S, only when using YouTube. I didn't realize it was even happening until I received a throttling text message from AT&T.

  • jmscuderi Level 1 Level 1 (0 points)

    No, it won't auto-reconnect. That's the problem. I wiped my 4S, restored, same problem. Wiped then set up as new phone, same problem. Got a whole new 4s tonight from the apple store and set up as a new phone, so I don't get any possible corruption from my previous backup. Still, disconnects from WiFi and won't auto reconnect. Updated my router firmware. Tried with no security at all and with WPA2 with a password. Both ways I can connect if I tap the name of my router, but like my previous 4S with iOS 5.1.1, my NEW 4S will not auto-reconnect to my router. My router happens to be a linksys WRT120N, firmware 1.0.07, but I don't think that it is the problem. Tried two different frequencies to rule out interference. How many backflips and wasted hours does it take before a bug is accepted as a bug? As karosurly, this only became important for me because AT&T is now limiting, oh, excuse me, "throttling" our previously unlimited data accounts. Collusion between Apple and AT&T to get people frustrated with throttling so AT&T can break their unlimited contracts and sell their more expensive tiered plans?  If anyone does NOT have this problem who has an unlimited data plan and a linksys WRT120N, let me know.

  • jmscuderi Level 1 Level 1 (0 points)

    Diesel, yes, before any of this I reset network settings. That doesn't help either. WiFi does not auto reconnect when the device is unlocked. Not in a few seconds or a few minutes. Auto reconnect is a dead parot. It is not just pining for the fjords. Oh and my revision of iOS 5.1.1 is (9B206).

  • jmscuderi Level 1 Level 1 (0 points)

    If anyone has an unlimited data plan with AT.T and does not have this problem with WiFi failing to auto reconnect, let us know what router you have. I'll buy one.

  • LexSchellings Level 5 Level 5 (7,800 points)

    I am not near the USA, I have no experience with AT&T.

    But the WiFi connection has nothing to do with the data plan of a provider, nor a healthy router. And the issue is not a problem of 5.1.1 neither. It has also nothing to do with password or not (like WEP can have with ultramodern equipment). I cannot image that the "Modem Firmware" is set such by AT&T that the WiFi reconnect is blocked to prolongue the use of the cellular connection, that would be illegal, even when the phone is stil locked to AT&T.

    So it must be something else. It is a very uncommon issue with the tens of millions of iPhones sold.

  • diesel vdub Level 7 Level 7 (21,995 points)

    I'd have to agree with Lex, you're barking up the wrong tree here.


    I have a 3GS and 4 running iOS 5.1.1.  Neither has issues reconnecting to Wi-Fi automatically with either of the two Wi-Fi routers in my home, the router at my mom's, or at any public venue where I may be.

    I have an AT&T unlimited data plan on my 4 and the 200mb plan on the 3GS.


    Do you have issues with auto-reconnecting to Wi-Fi at other locations as well?  Have you actually tried this?

    Based on everything that you've posted so far, I'd honestly have to say the Wi-Fi router is your culprit.

  • jmscuderi Level 1 Level 1 (0 points)

    Oddly enough, I turned cellular data off and my WiFi stayed connected all night and was still connected in the morning. I pulled the power on the cable modem until my iphone locked, then plugged it back in, the iPhone stayed connected to WiFi. Pulled power on the router, waited for phone to lock, powered on the router, unlocked the phone, still connected.


    Switched WiFi off on the phone, then back on: disconnected, no auto reconnect.


    Turned cellular data on, but no 4G icon appears, just WiFi. Ah, turn WiFi off and the 4G icon is there. Let the phone sleep and bingo! Wifi is gone and won't reconnect.


    So, it seems there are two problems:


    1. With cellular data off or on, switching the WiFi on the phone off or powering off then back on results in no auto reconnect to WiFi.

    2. With cellular data on, 4G stops WiFi from auto reconnecting after you unlock the phone.

  • jmscuderi Level 1 Level 1 (0 points)

    I power cycled this new phone at the apple store last night and it did auto reconnect to the insecure wifi in the store, so it seems like a router problem with my linksys, right? But how can my router be the culprit when the problem goes away and the iPhone will auto reconnect to linksys WiFi after locking IF the 4G cellular data is turned off?

  • LexSchellings Level 5 Level 5 (7,800 points)

    Why do you want to know why and what? Solve it.

    Try another router, borrow one.

  • jmscuderi Level 1 Level 1 (0 points)

    FIXED. I wanted to know why and what so I could understand and solve the problem, not just for myself, but for everyone having this problem with what seems to be many different routers. As it turns out, my router was not bad. I did not need a new one, so I saved $100 or so. By asking questions and testing different results, I figured out that all I had to do was rename my SSID and change the standard channel on my Linksys WRT120N to 11-2.462GHz.


    Now my iPhone 4S with iOS 5.1.1 will re-connect every time, where it would not before: It re-connects after locking, after I turn WiFi off and then back on, and after the phone is powered off and then back on, and with Cellular Data turned on. This is true with one or several computers connected to my home router at the same time, with or without encryption on. 


    Nothing else Apple had me do solved the problem: Resetting network settings, wiping the phone and restoring, setting up as a new phone, getting a replacement phone and setting up as a new phone, none of it helped until I did the above. I hope this helps someone else. Try this first before you waste hours restoring your phone!

  • iS0krates Level 1 Level 1 (0 points)



    Could you possibly clarify why changing your iPhone's name worked? I'm having the same problem, but my iPhone just has a generic name ("Chris' iPhone"). Is it the apostrophe? It seems so silly!


    Cheers, and good work for solving the problem yourself... I've been trying unsuccessfully to do so for ages.



Previous 1 2 3 Next