Previous 1 3 4 5 6 7 Next 124 Replies Latest reply: Apr 29, 2013 2:49 PM by EcoGreg Go to original post
  • Shootist007 Level 6 (16,660 points)

    keg55 wrote:


    No argument there, Shootist007. There should be no need for workarounds. It should "just work" per Apple's moniker.

    Yeah that saying "It Just Works" went out many years ago. As is seen on the many Mac forums around the Net.

  • HeyRoe Level 1 (0 points)

    Just wanted to add that I think I may be experiencing a similar issue with my new MBP Retina:


    I have a western digital external drive, USB3, connected to my MBP. When I try to back it up via timne machine, the backup process will run for sometimes 30 minutes or more and then quit. It's as if, at some point, the drive just can't be found. I get the message "this drive was ejected improperly". When this happens: my machine won't shut down, disk utility won't run. I have to press and hold the power button to force a shut down. Any ideas what's going on here? A MBP Retina issue? A USB3 issue? A western digital issue (although this drive has been functioning fine on old MBP)?

  • Offcs Level 1 (5 points)

    Whatheck. you're a genius (nearly!). The mv command would not work, so I used the reliable mouse method, but I now see both my USB 3 drives as such. AJA reports the much greater speeds (>70MBs for a generic bus power 2.5" SATA, >95MBs for a GOFLEX DESK, both through a USB 3 hub with my keybaord plugged in). The GOFLEX reports >120MBs when directly plugged in.

    Unplugging the keyboard and then trying got >125GBs, and replugged the keyboard in, tried again and got >125GBs again (Disable file system cache was checked for all tests). Maybe AJA is not that reliable, or there is something odd with Apple's implementation.

    Anyway, thanks again. Now to find out how to increase battery life, and stop the rMBP from restarting (four times in four days). Oh, and running so hot!

  • charlesfromessex Level 1 (0 points)

    I had this problem on my new MBA so logged  call with apple and got this problem fixed by doing the following


    First potenial Fix

    Step 1:

    shutdown the mac

    restart the MBP or MBA by holding down the power key for 10 seconds


    attached drive

    you should see the drive


    if drive is not seen or is seen but then unmounts try Fix 2

    which is an SMC reset

    shutdown the Mac


    hold down the following keys shift ctl and alt keys then press the power key for a count of 3 and then release all keys

    power on and loging

    connect drive and it should be working fine


    this has worked for me i hope it works for everyone else

  • PRJ1227 Level 1 (0 points)

    My Retina MBP problem is the mounts USB 3 drives fine but won't mount any USB 2 ( even powered ones ! )

  • Grant Bennet-Alder Level 9 (56,471 points)

    One common problem seems to correlate with non-Apple extensions, possibly loaded long ago to support other external drives.


    Linc Davis suggests this as a way to find those non-Apple extensions:



    Please copy or drag -- *don't type* -- the following command into a Terminal window, press Return, and post the output (if any):

    kextstat -kl | awk ' !/apple/ { print $6 } '


  • Shootist007 Level 6 (16,660 points)

    Then return it. It is broken.

  • Csound1 Level 8 (46,880 points)

    changethursday wrote:


    Yeah ill have to check at the apple store. Theres only 2 USB ports on the retina, and they are on opposite sides, so the Y cable would have to stretch pretty far.


    I would love thunderbolt drives, if they were affordable. I can get a 1TB usb3 drive for $100 or less, and at most any electronics store. Cant say that for thunderbolt.

    You can get a 1tb Thunderbolt drive complete with a cable and a USB3 port in addition to the Thunderbolt connection for $230.

  • Roderick A. Santiano Level 1 (5 points)

    I just posted the following possible fix on a separate post but I thought I'd copy it here:


    So I have been having the same problem as everyone else who has issues with USB 3 external hard drives not mounting on their MBP Retinas. My friend told me to try unplugging the USB cord and plugging it back in instantly (like in half a second, so as to not let the power turn off on the drive).  I had my doubts but then I tried it just now, and MY DRIVE MOUNTED.



  • hunt4fun Level 1 (0 points)

    Well - I just bought a Lacie Rugged Mini 500GB 7200 RPM USB 3/2 hard drive to back up my Retina MBP. I have other USB 2.0 drives I used to migrate data to the Retina just fine. I plugged in the Lacie drive, it was recognized but wouldn't run the setup utility. So I tried opening a ticket with Lacie, but discovered that when the Lacie was plugged into the Retina MBP I dropped wi-fi, not only my current connection but all available networks disappeared. When I unplug the Lacie wi-fi connection returns immediately. This is hilarious, how does a external hard drive cause wi-fi to drop on Apple's Flagship laptop??? I'm going to return the drive and may return the Retina MBP - pending opening a ticket with apple. Note: Existing USB 2.0 external hard drives and new USB 3.0 thumb drive work great. I reformatted the Lacie and can move data to it, but cannot use wi-fi at the same time - what good is it.

    ****** Update ******


    After further research it appears USB 3.0 devices operate at 2.4ghz and can interfere with wi-fi & bluetooth connections. After reading about this I dropped by new Lacie (still attached to MBP over the edge of my desk and was able to reconnect to wi-fi network successfully. The more permanent remedy is shielding the HDD and cable and/or getting a longer shielded USB 3.0 cable compatible with the Lacie Drive.

  • Shootist007 Level 6 (16,660 points)

    No need to open any ticket with Apple, "IF" you MBP is less then 14 days old they will take it back for full refund. Apple has a 14 day No Questions Asked Return Policy.


    If older then 14 days then all you can do is have it repaired, if it can be repaired or they will give you a new one.

  • EcoGreg Level 2 (329 points)

    I have the rMBP and a NewTech voyager S3, quad I/O dock. Under USB3, each time I hook up, it hangs. Quitting and relaunching finder (option+command+escape) and then I can use USB3 for file transfers.  Once finder relaunches, I have 5GB drive status.

    Using a WDRaptor 74 I'm getting 64-82MBs transfers read/write. That's about the maximum that the WD74 will go at. 85MBs spec.

    Given all the different brands of USB3 devices having issues, I'd say it is definately an Apple (driver?) goof.

    Try refreshing finder, see if it works.

  • Grant Bennet-Alder Level 9 (56,471 points)

    The Software Update issued 18-July addresses USB issues. This should reduce the number of problems seen.

  • EcoGreg Level 2 (329 points)

    Nope! I'm up to date on software. USB3 triggers problems. If I use the Voyager via ethernet, no problem. Like I said for me, refreshing finder works, just a hassle. I also need to make sure to quit any applications prior to refresh, or finder will hang.

  • FatMac>MacPro Level 5 (4,420 points)

    keg55 wrote:


    I don't have a Toshiba USB drive. Instead I have a Western Digital My Passport Essential. Both ports on my Retina are 3.0 and recognize the drive as USB 3.0


    The ports both show like below under System Report (USB 3.0 SuperSpeed Bus).


    Screen Shot 2012-06-28 at 4.18.20 PM.png

    FWIW, though I don't have a rMBP, I do have a 2010 Mac Pro with a USB 3.0 PCI card. The USB Speed listed in System Information is "Up to 480 Mb/sec" with or without a WD My Book Essentials USB 3.0 3TB drive connected, which is USB 2.0 speed. However, actual transfer rates run about 110 MB/sec, which is way faster than when connected to an actual USB 2.0 port. So I have to question how reliable the System Information's reported speed really is.

Previous 1 3 4 5 6 7 Next