Previous 1 2 3 4 5 6 Next 81 Replies Latest reply: Dec 10, 2013 5:59 AM by SCM73 Go to original post Branched to a new discussion.
  • fullframesf Level 1 Level 1 (0 points)

    In my case (OWC enclosure), part of it may be a power issue but it's also a system software issue.  The drive works on USB 2 Macs.  If the Air cannot negotiate USB 3, it should switch to USB 2.  It's not even doing that in my case.  System Info shows the USB doesn't see anything connected.  So the fact that it works in normal USB 2 and I tried connecting external power to the enclosure tells me it's not a power issue.  I'm not going to rule anything out, but I think this is just bad firmware coding on Apple's part.

  • KarenLynx Level 1 Level 1 (0 points)

    MBA is using a non-standard 3.0 usb power specification. Apple had convinced certain companies (LaCie for one) to build a usb 3.0 drive that is compatible with the MBA's no-standard specs

  • bugboi Level 1 Level 1 (0 points)

    Yet it is not disclosed to the user base which is costing them a truckload of $$$ on the purchase of incompatible hardware.....

  • KarenLynx Level 1 Level 1 (0 points)

    True. I work for Rutgers, The State University of NJ. Our computer repair dept is an authorized Apple Center. They were able to get this information for me.

  • chelidon Level 1 Level 1 (0 points)

    Wow - that's a pretty big deal, and it sounds like something unlikely to be fixable via firmware upgrade. And it's surprising, if so -- Apple should have had to certify its implementation with the USB Implementers Forum in order to use the term USB3.

  • fullframesf Level 1 Level 1 (0 points)

    Well, I'm still debugging this with Apple and OWC.  However, I will say that even when I power this drive separately from the USB 3 port, the MBA still doesn't see it.  So, we can be talking about two separate things.  One is the power the port provides to power the drive.  The other is the power put out by the I/O signaling pins.  I don't know the USB specs so I am only assuming the power and data pins are separate.  There is still a software issue.  If it cannot start up in 3.0 mode, why doesn't it kick down to 2.0 mode?  This is logical programming.

  • KarenLynx Level 1 Level 1 (0 points)

    Well, maybe. Is the drive recognized when connected to a usb hub? My MBA so far only recognizes 2 usb 3.0 drives. One I can use even as a bootable drive, one I can just mount, read, & write. The other 3.0 drives are not recognized by the MBA unless it is connected to a 2.0 usb hub. It appears that the MBA will not kick it down to 2.0 on it's own and that may be a software problem?

  • fullframesf Level 1 Level 1 (0 points)

    It is recognized as a USB 2 device when connected to a powered USB 2 hub.  I should have known not to trust Apple's first rev of a standard port.  They can't seem to get industry standard ports right.  It's like all those years of underperforming USB 2 ports in their power pc computers.

  • DynamicCore2Duo Level 1 Level 1 (5 points)

    I have the mid-2012 Air.

     

    It sees USB 3 drives.

     

    It can write to and from USB 3 drives, nice and quick.

     

    It cannot BOOT from a USB drive. I went and spent a bunch of sheckles on a superfast Lexar USB 3 stick, which I want to use as a rescue disk, and it won't boot. I can use the stick just fine, as long as I don't try to boot from it.

     

    That means that I have to continue to use the unbearably slow Patriot stick, and I was a sucker for getting the Lexar.

     

    The latest EFI update does not mention addressing this, and I don't have time to test it.

  • KarenLynx Level 1 Level 1 (0 points)

    I have been able to boot from the following flash drive with no problems: Patriot Memory Supersonic Boost XT USB 3.0 8GB Flash Drive (PEF8GSBUSB)

  • Albertazzo Level 1 Level 1 (0 points)

    I have connected a Seagate 500 GB USB 3.0/2.0 and my MBA (mid 2012) reads it but when I try to write something on it (creating a new folder, copying/pasting files or folders) the message I get is always "not enough room" or "support is read-only".


    Quite weird I'd say.

  • DynamicCore2Duo Level 1 Level 1 (5 points)

    I'd say that Mac OS (or the hardware) has a pretty shaky implementation of USB 3.0 right now. Not sure if it is possible for them to fix it in a minor upgrade.

     

    On another note: I got a Matrox DS1 Thunderbolt hub.

     

    The USB connections on it are good for charging phones and keyboards, but no good for communicating.

     

    Matrox seems to be blaming Apple for the issue:

     

         http://forum.matrox.com/ds1/viewforum.php?f=5

  • Martin M. Level 1 Level 1 (55 points)

    I have the latest EFI update and I confirm the problem with that Lexar drive. I contacted Lexar support via chat. Below's the transcript.

     

    Their key argument (to not help in the matter) is:

     

    "The drives are Mac compatible as stated on packaging, however this is a Flash Storage Device and is not intended to be used as a bootable device, which have similar properties to a Hard Drive."

     

    Welcome to Lexar's Live Chat. A Live Chat agent will join you in a moment... Please do not begin typing until you have been connected to an agent.

    Hello, my name is Zach . How may I help you?

    Martin:  Hello, I'm Martin. I have a Lexar® JumpDrive® Triton USB 3.0 Flash Drive

    Martin:  32 GB version

    Martin:  I'm on a MacBook Air from 2012 that has USB 3

    Martin:  I cloned a system to the drive but my Mac won't start up from the drive. I cloned the system from another USB drive (Patriot USB 2) which worked fine. I formatted the Lexar drive correctly (GUID) exactly like the Patriot. -- The Patriot works, but the Lexar doesn't. I ran DiskWarrior to make sure all is right -- but I CANNOT BOOT. Is this a known problem?

    Zach :  I'm sorry to hear that. Unfortunately our drives were not tested for use as bootable devices. I cannot guarantee they will work for this task.

    Zach :  I apologize for the inconvenience you've encountered, however I do not have any information on how to make your Triton a bootable device.

    Martin:  Hm. Your page said "Mac compatible"

    Martin:  I bought 2 of the USB drives - it was a lot of money

    Zach :  That is correct, the drive will mount and allow file transfer on your Mac.

    Martin:  How can I find out more about the issue? May there be a fix soon? Should I return the items?

    Zach :  Unfortunately we do not design our products with this in mind, Lexar will have no fix for this as it is not an intended purpose of our drive.

    Zach :  Is there anything else I can help you with?

    Martin:  So since this limitation was unknown to me and in contrary I was led to believe that it works with a Mac -- I'd kindly request my money back. Can you help me with this?

    Zach :  Did you purchase these drives directly from us? If so, you will need to contact our Sales department to inquire of this. If not, we will not be able to issue a refund.

    Martin:  What about "Warranty" ?

    Zach :  The drives are Mac compatible as stated on packaging, however this is a Flash Storage Device and is not intended to be used as a bootable device, which have similar properties to a Hard Drive.

    Martin:  Just out of curiosity: Where is it stated (you can point me to an online document or page) that this drive "is not intended as a bootable drive for Mac"?

    Zach :  Did you purchase these drives directly from Lexar?

    Martin:  No.

    Zach :  I apologize, but we will not be able to issue a refund since the product was not purchased directly from us. This device is Mac compatible and is a personal storage device. The product page covers its uses at: http://www.lexar.com/products/lexar-jumpdrive-triton-usb-30-flash-drive?category =207

    Martin:  Thank you. Good bye.

    Zach :  You're most welcome. Is there anything else I can help you with?

    Martin:  No.

  • Martin M. Level 1 Level 1 (55 points)

    I'd like to add that the same Lexar USB 3.0 drive that would not boot on a mid 2012 Air (with USB 3.0 ports) will boot just fine on a 2011 Air (that has just USB 2.0 ports).

  • KarenLynx Level 1 Level 1 (0 points)

    This is not a Lexar problem, it is an Apple problem. The Patriot Memory Supersonic Boost XT USB 3.0 Flash Drive does work as a bootable drive on the mid 2012 MBA's. I have created 2. It is hit or miss whether these flash drives will work. I have posted several times that these drives work so I am not sure why people are continuing to buy other brands and are surprised when they do not work. The LaCie 500GB Porsche Design P'9223 USB 3.0 Mobile Hard Drive can also be used as a boot drive if you say need to make a bootable clone that will not fit on a flash drive.