Previous 1 2 3 Next 81 Replies Latest reply: Dec 10, 2013 5:59 AM by SCM73 Branched to a new discussion.
karthikfromcharlotte Level 1 Level 1 (0 points)

I just got my mac book air, my usb3 external HDD is not getting detected. It was working fine with my old mac book pro. Any solutions?


MacBook Air, Mac OS X (10.7.4)
  • RRFS Level 5 Level 5 (4,470 points)

    Take it to the ProDesk, have them sort it out.

  • Matilda35 Level 1 Level 1 (0 points)

    Try again later that is what I do I crashed my computer once and now it works.

     

    Or just go to the apple genius bar.

  • SP Forsythe Level 5 Level 5 (5,250 points)

    It doesn't happen to be a Toshiba Canvio, does it?

  • karthikfromcharlotte Level 1 Level 1 (0 points)

    it is Toshiba ! booked appointment today at genius bar, will keep you posted

  • EJW Tas Level 1 Level 1 (0 points)

    I have a mid-2012 Air (120gb SSD/8gb RAM) and have had mixed experiences with USB 3 external HDDs.

     

    I am using a WD 750GB external HDD partitioned for Time Machine and "mobile" backups of files, software etc = all good, no problems on USB 3 port on Air.

     

    I also have a WD 3TB Caviar Green HDD in a mains-powered enclosure - sweet drive, quiet etc but the USB 3 port on the Air doesn't have the power to drive the WD drive (even with main supply). To access/use the 3TB drive, I have to connect it through a mains-powered USB hub.

     

    Without the hub, I can hear the drive spinning up/spinning down and am unable to copy files to/from Air. Connected through powered USB hub, all is good.

     

    any thoughts? anyone else with similar experiences?

  • charlesfromessex Level 1 Level 1 (0 points)

    I have a similar issue in that the external drives mount but them unmount themselves when in use and it driving me mad I think the issue is with the driver provided in OSx 10.7 since the drives work fine on an older MBA or Mbps so Apple need to fix this driver issue

  • EJW Tas Level 1 Level 1 (0 points)

    I have done some more trialling and it is clear the USB 3 port on the mid-2012 MBA can not support external HDs except through a powered USB hub. I have tried a number of enclosures with other macs and the story is consistent. Clearly there is a problem with the USB 3 port on the MBA.

  • RT11 guru Level 2 Level 2 (175 points)

    This is not universally true. I have a brand new MBA and it mounts and backs up fine to an external USB hard drive (a WD Passport Essential). It may be true that the MBA has problems with some external drives, perhaps having to do with current limitations. I had a similar issue with my 2010 MBA; I had to use a powered USB hub if I wanted to use BOTH an external drive and the ethernet adapter (unpowered wouldn't work).

    Also, there are lots of reports about problems with the Toshiba drives long before the new MBA was announced.

  • cq_ Level 1 Level 1 (0 points)

    Went to a client's today and tried to grab a 48GB database file from an external Toshiba USB 3 drive.

    My brand-new macbook air couldn't read it. I don't want to point fingers at Apple,but when a harddrive works on any other machine but the MBAir, it's NOT the drive's problem it's my problem because I have an Apple

     

    It's really embarassing to have this happen directly in front of a client with a brand new machine. Of course they all use PC's and I can see why...

     

    Screen Shot 2012-07-09 at 3.04.39 PM.png

  • karthikfromcharlotte Level 1 Level 1 (0 points)

    I went to the apple store for genius appointment, And you know what, I tried my drive in all of the Macs available there, Macbook air, pro and also the iMacs, none of them detected my usb3 , and the worst part is apple dint have a USB3 available to test out and rule out that its problem with my USB3,

     

    Mine usb3 is working fine with my OLD Mac PRO 2010. :-( I love my new Air , hope apple would come out with a solution,

     

    Will this be a legal issue for apple -  Apple advertised that the new MBA has usb 3 ports

  • jordanfromallyn Level 1 Level 1 (50 points)

    Does your old Mac Pro have the same OS as your MacBook Air? If not, it's possible that Lion just doesn't support your specific device.

  • karthikfromcharlotte Level 1 Level 1 (0 points)

    yes both are upto date ! I guess its something to do with the power. the old Macbook pro might be giving the Drive the power it needs, with the MBA my USB 3 drive's light is on but its not detected.

  • jordanfromallyn Level 1 Level 1 (50 points)

    That's weird, have you called AppleCare for help?

  • djdan23323 Level 1 Level 1 (15 points)

    Had same issue with MBA 11' 128GB.  Have reported to Apple Care.  Gone all the way up to engineers.  No resolution yet. My issue was with a Verbatim 64GB USB 3.0 flash drive.  Verbatim pointing at Apple.  And yes, this same flash drive worked in 2010 MBP.  Waiting and waiting... gotta be a firmware upgrade coming at some point.

Previous 1 2 3 Next