Previous 1 2 3 Next 222 Replies Latest reply: Feb 8, 2016 2:25 AM by erewwrwe
fieldsnyc Level 1 (0 points)

On the new Retina MBP (using the highest res setting), I'm noticing that there are significant visual glitches (ghosting, persistent blocks, lack of redraw, etc...) upon returning from sleep.

 

Is anyone else seeing this problem?


MacBook Pro (Retina, Mid 2012), Mac OS X (10.7.4)
  • n8rand Level 1 (0 points)

    I'm noticing this as well when returning from sleep - specifically it seems to happen (only?) when using the nvidia graphics card. I haven't noticed it when it is using the Intel card.

  • RealEyes Level 1 (0 points)

    From what I've read, Lion isn't optimized for this machine yet. Things like this should be fixed with Mountain Lion (10.8). Try getting your hands on the developer preview of OSX 10.8 and see what happens.

     

    I noticed in the store while testing the base model that things were glitchy/slow. Did some reading and found this to be fairly common. However, I've seen some videos of the same machine running 10.8 (DP4) and things are smooth as butter.

  • fieldsnyc Level 1 (0 points)

    Switching the resolution down and back up again seems to resolve it temporarily.

  • fieldsnyc Level 1 (0 points)

    But not always.

  • fieldsnyc Level 1 (0 points)

    How does one ensure that the intel card is used? I only see settings for locking the nvidia card.

  • aut0maticdan Level 1 (45 points)

    noticing the same thing.  I didn't see this before I posted.  I have some pics in mine, does it looks like this?

     

    https://discussions.apple.com/message/18683484#18683484

     

    Since I can take screen shots of it, I don't think its a hardware-level output issue.

  • fieldsnyc Level 1 (0 points)

    Yes. That's a bit more extreme than what I'm seeing, but basically the same thing.

  • aut0maticdan Level 1 (45 points)

    I ran hardware test twice (once thorough) and it detected no issues.

     

     

    http://support.apple.com/kb/HT1509

  • fieldsnyc Level 1 (0 points)

    Also, as another data point, when I brought the machine back from sleep this morning, there were no glitches at all (yet).

  • aut0maticdan Level 1 (45 points)

    I haven't had an issue since running the hardware test.  I've let it sleep and woken it up several times.  I am seeing significant burning/ghosting in one area of the screen though.. ugh

  • roar08 Level 1 (0 points)

    Confirmed. Seeing the exact same thing and fairly dramatic on my retina.

     

    2.7/3.7, 16GB, 512GB. The artifacts are bad enough to make it unusable when it wakes.

  • Joshua Brown1 Level 1 (20 points)

    Yup, I'm having the same problem, except that my machine keeps crashing over and over again.  I've gone through the console, and it seems like different processes keep crashing (crash reporter, MDS (Spotlight), kernel_task, etc.)  I can safely boot into Safe Mode, but if I restart my machine, almost as soon as I get past the login screen, I get screen glitches and the machine either restarts itself or hangs.  NOT HAPPY.

     

    MBP Retina 2.7 GHz, 16 GB RAM, 512 GB hard drive.  I installed all of the latest software updates (Thunderbolt, MBP Retina update, MBP mid-2012 OS X version, etc.) 

     

    I transferred over all files and apps from my mid-2011 MBP overnight.  I thought it was some incompatibility with installed software on my old machine (from which I'm typing this), so I started uninstalling things as soon as I could get logged in.  Little Snitch, gone.  EyeTV, gone.  SMCFanControl, gone.  Going through the Console, I saw that an old ATI program was trying to launch, so I pulled that and all of its associated .kext files out.  Nothing worked.  So, I'm reinstalling Lion on that machine right now, and we'll see how it goes.

     

    I've spent my entire morning working on this *&(%^ thing.  I am NOT pleased.  I don't have time to be a beta tester for Apple.

  • .dark Level 1 (65 points)

    Reading this thread has me worried now, I ordered a retina macbook just the other day -_- hopefully its not a hardware problem.

  • fieldsnyc Level 1 (0 points)

    I ran the hardware test and it returned an obscure error with no useful information about what was causing the error. I called support and they advised me to reset the SMC:

     

    http://support.apple.com/kb/HT3964?viewlocale=en_US

     

    After doing that, the hardware test ran clean and the visual glitches went away for a short while, but then they returned.

Previous 1 2 3 Next