Skip navigation
This discussion is archived

apple software update in windows help!!!!

18753 Views 43 Replies Latest reply: Oct 8, 2012 9:09 PM by SombraGuerrero RSS
  • b noir Level 9 Level 9 (71,990 points)
    Currently Being Moderated
    Jun 21, 2012 8:19 PM (in response to markarich159)

    The reason I chose to raise the ASU.lnk file to administrative privilege rather than the SoftwareUpdate.exe file was that(at least on my system) the "Run as Administrator" tick box was alrady checked under the properties/compatibility tab for the SoftwareUpdate.exe file. Right clicking on the software update.exe file and choosing run as administrator was not successful.


    That's interesting ... by default, ASU is set to not run as an administrator. (The box is unchecked.)


    Had you changed that yourself at some stage?


    (It's quite plausible that you hadn't ... peculiar things can happen in the Compatibility tab without any user intervention.)

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 22, 2012 10:58 AM (in response to b noir)

    To my knowledge it was always checked for the SU.exe file( I haven't changed it myself at any stage - I would have never before had any need to). It is also that way on the windows 7 32 bit system at my work(I didn't check my Win Vista 32 Laptop to see the status of the privliges on that file as of yet). I'm always logged in as adminstrator and was at the time of the initial itunes/quicktime/safari installs - possibly the status of the user at the time of install dictaes whether the ultimate exe file has admin priviliges???? Just a guess.

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 26, 2012 3:32 PM (in response to ClearNexus)

    Apple Support Communities is having "scheduled maintenance" done at 10PM tonight. Who knows, maybe they will use this maintenance down time to set a few things straight and the ASU will be magically working tomorrow. I know it's a long shot, but one can always hope.

  • kacord Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2012 10:23 AM (in response to markarich159)

    I have been reading these communities for a few days now, because I have had problems with my apple software update showing up blank, yet telling me I could select select an update from a list to download.  Yesterday, I noticed that iTunes wasn't available for download anymore, but today it was back up. 


    I just redownloaded itunes, without uninstalling, and had it repair my version.  After that was done my software updater worked on the first pass telling me there was no new updates.  I am fairly confident that it worked correctly becuase this time, there was actual movement on the status bar.  I have also manually downloaded all of the updates for all of my software for my apple products working on my Win 7 x64 system.


    If anything changes I will report back, but so far so good.

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 29, 2012 11:49 AM (in response to ClearNexus)

    ASU is still not working for me

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 30, 2012 4:57 PM (in response to markarich159)

    Good news,  the ASU seems to be working again(starting today for me and for the past few days I've seen positive reports from other places on planet earth). I've only been able to see this on my computer at work(running Win 7 32) but it definitely IS working as it should. It loads, starts the appropriate green bar search progress, and then finds anything on my computer that needs to be either updated or installed - I know this because I do not have Safari installed on my work computer and it is now 10 for 10 in loading and finding and telling me that I should download and install Safari 5.1.7(everything else on my work computer from Apple is already installed and fully updated). Hopefully, when I get home, I will find that my desktop and laptop are also working as they should.  It appears it was a problem from Apple's end this entire time. As others have speculated in other similar threads; Apple most likely "fixed" this on their end about 3 days ago, but has been slowly dispersing the "fix" throughout their worldwide update servers. Some people were lucky enough to have the servers in their neck of the woods fixed earlier then others. Hopefully, as Apple finally matriculates the fix to ALL their update servers, everyone will be back up and running smoothly with their Apple Software Updater. If the ASU on your machine is still wonky, just hold out for a bit longer; It should be up and working any day now.

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 2, 2012 9:55 AM (in response to markarich159)

    When I went home on Saturday 6/30/12, I found that both my Desktop(Windows 7 64bit) and my laptop(Windows Vista 32bit) were back up with the Apple Software Updater and running perfectly. So in my neck of the woods(Eastern Pennsylvania in the USA), everything seems to have been "fixed" by Apple. I know how frustrating it is waiting but it should, hopefully, be up and running for everyone quite soon.

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 7, 2012 11:11 AM (in response to markarich159)

    I don't know what is going on now. It was working perfectly for 4 days. Now it's back to doing the same old dysfunctional idiocy. Apple BETTER get its act together or make an announcement that they are having an issue. This is absolutely intolerable!!!!! it looks like a Windows Tablet or Google tablet for me in the future.

  • bbolling Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 16, 2012 2:35 PM (in response to ClearNexus)

    Looks like it may be an issue with their CDN not having proper catalog (or not giving out proper catalog?) on all service points. By luck i found one that worked, Update your hosts file to include



    For those of you rightly paranoid by adding an IP to your hosts file from a forum post on the internet, will show it is Akamai (valid CDN).


    After updating this locally, SoftwareUpdate.exe was able to work without issue every time i closed and reopened.


    To udpate your hosts file in windows:

    1. Open command prompt (if windows 7/vista, right click and open as administrator).

    2. Type in  "notepad c:\windows\system32\drivers\etc\hosts" (without the quotes).

    3. Enter in a new line on the bottom of the file with "" (again, no quotes).

    4. Save. -- If you get an error about it being open already or you not having permission to save, you likely did not run as admin.

    5. Run software updater.


    Hope this helps others out there!

  • IsmoL Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2012 10:19 PM (in response to bbolling)

    The above workaround by bbolling solved the issue for me! Thanks!

  • janeh1967 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2012 3:56 AM (in response to bbolling)

    this worked perfectly!


    after all this hassle its ridiculous that apple are slacking in their support.




More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.