Previous 1 2 3 Next 43 Replies Latest reply: Oct 8, 2012 9:09 PM by SombraGuerrero Go to original post
  • Apfelkacke Level 1 (10 points)

    Great find, bbolling! Still (one and half months later!) Apple hasn't fixed this simple DNS thing! Unbelievable...

  • dowlingm Level 1 (0 points)

    kudos bbolling, that worked for me!

  • Faffe Level 1 (0 points)

    At least it checks for software now, but it still doesn't find any updates for me. It should at least offer me Safari, shouldn't it?

  • MiamiC70 Level 1 (10 points)

    Not working for me either.

    What is the point of offering Windows bootcamp and compatability if they purposly cripple it by not updateing drivers and now even thier own software?

  • BlueBlood1978 Level 1 (0 points)



    1. Right click on Apple Software Update in the Start Menu
    2. Click on the Security Tab
    3. Find YOUR username (not the Administrators name) in the list, click on edit (this will open up a new window with a list of user names, then a smaller part that has check boxes)
    4. Change your rights to Full control. Click on OK
    5. Click on Apply then OK to apply the new settings then to close the Properties Window.


    After you do these steps, you will be able to check for the updates AND see them.


    I do not know why (I do not work for Apple is probably why I don't know! LOL), but for some reason the priviledges listed for the username for the Apple Software Update is different from the Administrators. Once you change the Rights, you will notice that things are back to normal (pre-whatever-Apple-did).

  • SombraGuerrero Level 1 (0 points)

    Just tossing this out there in case anything ever happens to host you found, sir. Another one that appears to work is

    I believe I also know the address of the one that primarily does not work, but I will not post that here unless people are curious, so as not to confuse.

    The interesting thing is that the host that seems to be the troublemaker does resolve and ping from, so it's online, and the updater does appear to try and use it. I feel like this means there may be a problem with the actual catalog itself on that particular server.

  • iMitch781 Level 1 (0 points)

       I had the same problem. I tried the other fixes like changes like right clicking and changing the permissions and had no luck. The fix from bboling worked for me. I am running Windows 7 Home Premium 64 bit. Thanks.

  • TiloApfel Level 1 (0 points)

    thanks, that IP worked for me:

    OrganizationAkamai Technologies, Inc

  • SombraGuerrero Level 1 (0 points)

    As of the last iTunes update to 10.7, this issue seems to have gotten resolved, at least for me. I commented out the changes to my hosts file and the updater has been running fine on its own ever since. I believe they may be using some different servers on their domain now. Simply by pinging multiple times, I've found several new IP addresses. I haven't tested all of these, but just for the heck of it, here are all the ones I've found (minus the one that I still think is the main troublemaker). (This one pings slowly from where I am. I *suspect* it might be an international mirror).

  • lucid green Level 1 (0 points) seems to have stopped working for me.

    When I ping it after flushing the DNS, I get I'm thinking this one is a bad one, too.


    And like everyone else, it appears that uninstalling and reinstalling doesn't fix anything. It also started working around the time of the iPhone 5 release. How convenient for them.

    In another thread it looks like Apple's server are rejecting requests from x64 Windows computers. Can we say that everyone here with this problem is using a 64-bit Windows 7 or Vista computer? All mine are. I can't think of a reason to use anything 32-bit anymore.

  • SombraGuerrero Level 1 (0 points)

    Yeah, I think that's a reasonable assumption. It seems to be the trend in this thread and any other one about this problem that I've skimmed through. I also agree that there is definitely more than one "bad" server in the mix. I would be curious to hear people sound off as to whether or not anyone is still having this issue having not applied any fixes since the last iTunes update. I think another reason why bbolling's fix is the right one is because of the fact that every other fix has "appeared to work" temporarily, and then stopped working. This, to me, is clearly because is mapped to more than one server (probably on a domain), and you can potentially get a different server almost every time you run the updater, some working, some not. That's what creates the illusion of other fixes sometimes working.

  • BradKY Level 1 (20 points)

    This workaround worked for me up until yesterday. All of the sudden, it stopped working, and I started getting an error message saying that the apple server could not be reached. I went back into the notepad file and deleted the changes I made to use the workaround, and it's now working properly again. I assume this means that Apple has fixed the issue on their end, and that the updates server is now located at a different IP address.

  • chcn Level 1 (50 points)

    Adding that entry to my hosts file did change the behaviour, but not for the better. Now there is a long wait, a timeout, and then this message: "The Apple Software Update server could not be found. Check your internet settings and try again."


    Update: using did work! It found a QuickTime update and installed it. Since it now says that all software is up to date and then closes right after I hit OK, I can't tell if the other issue I mentioned above (old entries about currently-installed updates) is still the case, but the proper behvaiour seems to be restored anyway.


    Message was edited by: chcn

  • SombraGuerrero Level 1 (0 points)

    Yeah, that's the reason why a couple other people including myself posted other IPs as we came across them, because we know that the same servers don't work for all locations. I would check to make sure you've updated to iTunes 10.7 though, because for most of us, it does seem like the issues have finally been resolved without having to edit the hosts file anymore.

Previous 1 2 3 Next