8 Replies Latest reply: Jul 29, 2012 7:12 AM by saugaking
sd2102 Level 1 (0 points)

I'm not sure how long I've had this problem, but when I click on Places, the view as map screen is just gray. It works fine if I view as list. Does anyone have any suggestions to troubleshoot this problem?

 

Thanks!


iPhone 4, iOS 5, Mac OS X 10.6.8
  • Old Toad Level 10 (135,334 points)

    Make sure you have all of the necessary iPhoto preferences relatated to places set properly, i.e. in the iPhoto/Advanced pane where the Look up Places should be set to Automatically.

    iPhoto001.jpg

    Next, if needed,  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists. If it doesn't then the problem is limited to your current library.  If the problem persists it's system wide and may require the reinstallation of iPhoto.

     

    OT

  • sd2102 Level 1 (0 points)

    Places had worked correctly before, and it appears that none of the settings were accidentally changed. Also, I'm able to view places as a list, just not as a map.

     

    I did as you suggested and tried using a different library, but it still did not work. I guess a reinstall of iPhoto is my only option at this point?

  • LarryHN Level 9 (76,842 points)

    See this thread for a fix that has help several people - https://discussions.apple.com/thread/3997428?tstart=0

     

    LN

  • sd2102 Level 1 (0 points)

    Thanks!

     

    Here is what I did to trouble shoot:

     

    Checked to make sure my iPhoto was current

    Checked settings to make sure they had not changed

    Tested a second library (opened iPhoto while pressing Library) and saw the problem is with iPhoto, not my library

    Removed receipts per this article: http://support.apple.com/kb/TS3249

    Uninstalled and reinstalled iPhoto

    Deleted the iPhoto cache in my Library

     

    None of these worked

     

    I looked at the post linked to above that said that Safari might be the problem, even though I never use Safari I first emptied the cache and deleted all cookies (though I think all you need to do is delete Google related cookies). This is working for now, hopefully it will continue to work.

  • Old Toad Level 10 (135,334 points)

    Larry:

     

    I'm having the same issue and tried Richard Liu's fix.  It does work BUT it's only temporary. When the library is closed and then reopened the problem comes back and will require another application of the "fix".

     

    Richard reports that he's reported it to Apple and it's at tier 2 (?).  So Apple knows about it and is working on a fix.

     

    OT

  • LarryHN Level 9 (76,842 points)

    good

     

    LN

  • sd2102 Level 1 (0 points)

    I haven't had the problem recur, though I rarely use Safari so I guess that might be the reason?

  • saugaking Level 1 (0 points)

    Deleting the Cookies associated with Google also resolved this issue for me.

     

    Safari -> Preferences -> Privacy -> Details

     

    Then search for cookies with Google.

     

    Then remove those cookies.