Previous 1 2 3 4 Next 58 Replies Latest reply: Oct 15, 2015 4:07 AM by WilsonLaidlaw
realtorjosh Level 1 (0 points)

When attempting to purchase/download apps from my Macbook w/Lion OS using App Store I am asked to log in where I get "Connection failed." message.  Also I cannot sign in to my account from the App Store.  I can access everything else on the internet and even log in to Everything was fine up until a few days ago when I upgraded to Lion.


How can I fix this?

MacBook Pro, Mac OS X (10.7.4)
  • Carolyn Samit Level 10 (103,360 points)



    Try resetting your Apple ID password >  Apple - My Apple ID


    If that doesn't help, quit the App Store if it's open.


    Open the Finder. From the Finder menu bar click Go > Go to Folder


    Type this exactly as you see it here:




    Click Go


    Move these files from the Preferences folder to the Trash.






    Now do the same for:   ~/Library/Caches/


    Click Go

    Move the Cache.db to the Trash.


    Try the App Store.


    And if you have anti virus software installed, you may need to disable that before accessing the App Store.


    Apps such as Little Snitch can also prevent access to the App Store.

  • alfredo87 Level 1 (5 points)


    I did all that but it still does not connect:

    error is always connection failed

    Password works with all other places the AppleID is needed.

    Have stopped anti virus (Sophos) and have not got Little Snitch.


    Cannot understand what is happening.

    Pls help me if you can!!

  • mrkite Level 1 (0 points)

    Hi unlucky people,


    The same here. Everything is fine on all our Macs, but on my wife's MBP, though I can use it to connect to the App Store in iTunes using my/our Apple ID. This drives me crazy.


    I tried all the possible for a regular geek, after consulting many discussion sites. I even reinstalled the 10.7.4 Combo update and iTunes.


    Maybe the next step would be a voodoo ceremony... We are about 10:30 pm French time, will wait 24 hours before to set an appointment to a Genius Bar...




  • sharma.k.arvind Level 1 (0 points)

    Guys I did what was didn't work. Suggest some better tips

  • alfredo87 Level 1 (5 points)

    Hi all of you worried people,



    here is something that worked for me:


    Re: "Connection Failed." when signing in to Mac App Store

    Oct 26, 2011 3:45 AM (in response to call-151)

    This worked... Signing out and in did nothing... for me I could download standard type apps but when trying to get OS X Lion it just sat all day trying to connect and never went beyond the get app status.


    None of my certificates had a red X beside them but I applied allow always to the top class 3 paublc one and it worked.


    OS X Lion on it's way down now.



    from another thread in this forum.

    Now to do this follow this:


    1. Open Key chain access in the Utilities folder
    2. Search for "class 3 public" without quotes
    3. select all the certificates on the list by clicking and holding the cmd key (apple key)
    4. right click selection and choose get info
    5. in the windows that open go one-by-one and click on Trust at the top of the list
    6. From the drop down menu choose "Always trust"
    7. Close window and enter your password if asked
    8. Repeat for all certificates
    9. Close Key Chain Access

    Try App Store and let this forum know if it worked or not:

    it did for me and I just updated iPhoto like that!


    Bon courage from Central France!

  • alfredo87 Level 1 (5 points)

    This is a bug in Lion 10.7.4 and to get more info look at this post:


    I have tried what I posted above and it got rid of the AppStore issue for me, but there may be other issues that are related to certificates:

    I had many error messages saying invalid certificate on websites like hotmail and others since updating to Lion 10.4.7

    Also my bank site and others gave same error while before it never did so!


    Come on, Apple solve the bug in Lion without forcing us to buy Mountain Lion because of a bug!!

    Here is the message that solves the issues so far from above thread:




    Thank you quickSti! This finally solved the problem for me.

    quickSti wrote:


    I solved this on my wife's computer by resetting the security certificate settings.  This might help others:

    Close all windows.


    Keychain Access ->  click on System Roots on the left, and then click on Certifcates on the bottom left.


    Check to see if any of the certificates on the right have the blue "+" symbol - this means they have custom trust settings.


    There is a bug in changing the policies, so you'll have to change them via the method below.  Changing them just by changing the access to "system defaults" doesn't seem to save.  The method below worked for me.


    Double-click on each certificate with the custom setting (blue "+"), expand the section labled "trust".  Change the "Secure Sockets Layer (SSL)" setting to "no value specified".  Close window - you should be prompted for the password.  Double-click on the certificate again, expand trust, change the "When using this certificate" setting to "Use System Defaults".  Close window, and re-enter password.


    If you didn't re-enter your password upon closing the window, the setting didn't take.  The blue "+" should disappear after a few seconds when it's set back to default.  Once all of the certificates are changed back to default, restart Safari.


    This solved all of the problems for my wife's computer with these issues and OSX 10.7.4


    Thank you to everybody who helped with this bug...

  • lindensmith Level 1 (0 points)

    cross posting this from another thread, because it seems more appropriate to this than where I originally posted (couldn't find this thread again at first):


    I had a similar problem, but wasn't related to going through a proxy (and its cause is still unknown).


    Using a new (refurb) i7 quad core 15" from oct 2011, I can get into the app store fine from 10.7.3.  After upgrading to 10.7.4 I get "connection failed" when logging in to the app store.  I can log into my apple account from every other possible interface imaginable (itunes on the same machine,, from app store on another machine running 10.6.8, from another machine in the Apple Store running 10.7.4, etc).


    I tried the various things in this thread (and a few other) including changing a ton of certificates to Always Trust, with no effect.  Tried creating a new keychain (no effect).  Changing those certificates to always trust (no effect).  I also tried installing the 10.7.4 combined system install over the top of the existing system.


    I went to the apple store, demonstrated the problem there for the genius, and it was his first time seeing that problem.  We rolled my system back to 10.7.3 and the app store works fine.  The genius bar was closing down for the night by the time it finished, so we didn't update it to 10.7.4.  I updated to 10.7.4 this morning, and the problem returns, exactly as previously manifested...


    Time to roll back to 10.7.3


    UPDATE: When rolling back to 10.7.3 it again wouldn't do it from the internal.  I booted with the option key pressed and selected the internal restore drive to boot from.  It then only showed me the restore drive (locked) and my still connected external (for time machine).  I tried again from  USB stick that I'd put a restore drive on last night, and that restore seems to be working.

  • arthurlockman Level 1 (0 points)

    I do believe that I've found a solution! I was having the exact same problem, and I think I've fixed it. I outlined what I did in a blog post, over here. Hopefully this helps!

  • lindensmith Level 1 (0 points)

    It Worked!!


    Thanks!  It was driving me a bit nuts, and was quite reproducible on the one machine. I wasn't having trouble with anything other than with the App Store, but since the whole point of upgrading to Lion was to be able to do iBooks Author, it was a bit of a problem.  Neither of the two guys I dealt with at the Apple Store had ever heard of it either.


    I didn't have a "/var/db/crls/ocspcache.db"


    It's definitely a reproducible bug in 10.7.4, as I described above-- hopefully they'll sort it out and issue a patch.  I'll probably be updating to Mountain Lion in a few weeks anyway, as the machine is only a couple days old.

  • Pierre Bédat Level 1 (15 points)


    I applied this preocedure and it solevd my problem




  • Noble27 Level 1 (0 points)

    Thank you. this solved the issue for me as well. I have been through several threads and potential  "solutions" for weeks with no success until now.

  • arne501 Level 1 (0 points)

    I had the same problem from one day to another on my MB Pro with 10.7.4. Remarkably I had no problems on my Mac Pro also running with 10.7.4. and no problem on my MacBook with any other services including iTunes Store, iCloud etc. - ONLY Mac AppStore was unable to connect.


    Finally your procedure helped - eventhough I wonder what it does to the general security of my MacBook.


    Thanx a lot for your post!

  • arthurlockman Level 1 (0 points)

    It shouldn't do anything to your mac's security. If anything, it'll be more secure, because SSL will function properly now on all sites, where it might have defaulted to non-secure connections before because the certificates were improperly configured. Your mac should be more secure having applied this fix.

  • DjCarpenter Level 1 (0 points)

    I'm having the same issue but I don't have any blue crosses for me to fix.

    So, I'm pretty much stuck at this point.

Previous 1 2 3 4 Next