Previous 1 2 3 4 5 Next 64 Replies Latest reply: Mar 11, 2014 2:14 AM by appleisnewtome Go to original post
  • John Galloway Level 1 Level 1

    Yea I think I'm going to go the "new user" route myself.  So I'm going to

    * make new admin account

    * use that to delete my current account (with the keep all files option)

    * make a new account

    * make a copy of this new account's /Users/<name> dir for easy reset

    * start moving things in from my old account (still in /Users due to the "keep files" option)


    Here is a somewhat old, but still useful article on this activity

  • jkk4_1998 Level 1 Level 1

    Wow John, let meknow how it goes. I'm traveling and will work on it this weekend. Once you have a "Step by Step" process, please send it. Please keep it as "novice" as possible.

    Thanks very much.



  • John Galloway Level 1 Level 1

    Will do.  I might not get around to it till next week.

  • jkk4_1998 Level 1 Level 1

    OK, Apple support was unable to find any problems, so I added a new User with Admin. I backed up all my data and moved it into my new user account. I then tried everything out and it all works! I deleted my old user and deleted it's settings.

    Then, I went back into my hard drive and deleted my Old User folder and FINALLY, all is well again.

    Whole process took about one hour.

    Finally. did a full backup with Carbon Copy Clone and hope to not run into this problem again.





  • John Galloway Level 1 Level 1

    Exactly how did you do the move of old data to your new user?   I ask as one would have suspected that something in /Users/<you>/Library or preferences or something was what was causing this.  If you moved everything and overwrote the corresponding files in the new users dir, then I guess that blows that theory.  It also makes it easy to do.  I was thinking I'd have to do it in pieces and keep testing to see if it was working or not.


    Glad to hear you got it working.  Must be a relief.

  • jkk4_1998 Level 1 Level 1

    Simply get a USB stick and go into your hard drive. Click on your hard drive, then users and then click on your folder. Copy all this, which is all your Data, onto the USB memory.

    Go into System, Preferences, users and unlock. Add a new User and give it Admin rights. It will ask if you want to keep and folders. Click the last option to not save any folders.  Add password and stuff, then log out. Now log in with your new user. Go into Finder and find your new User Name. Copy your Data, which includes, Docs, Music, Pics, etc. into your new user account name from your USB stick.

    Go back out and restart on your new user name and you should find out that all your Data will now be there. All your applications will also be there, but some third party apps, you may need to re-type in your serial numbers for those programs.

    Like I said, everything should now work perfectly.

    NOW, go back into your hard drive from Finder and drag your Old User Folder into the trash. This will give you all that space back after you delete from your trash. It may say that part of your old folder you are looking to delete is locked. Click OK to delete it all.

    Now shut down and restart your new account and everything should work perfectly with the same amount of free space as you had before.

    Let me know if you have any problem. Should take an hour or so.



  • John Galloway Level 1 Level 1

    Thanks jkk.  A couple more questions:


    "Add a new User and give it Admin rights. It will ask if you want to keep and folders. Click the last option to not save any folders."  These choiices (save home folder to a disk archive, do not chnage home folder, and delete home folder) are shown (for me anyway) when you are deleting a user, not when you are adding one.  So there should not have been anything to remove in your step of dragging your old user to the traash.  So I don't quite understand that. 


    It also will not let you delete the user you are logged in as, (the - is grayed out) so you must have done this after logging in as the new user.


    But the key question is that when you did the copy back from USB, did it warn about files (e.g. in ~/Library) being newer then the ones you are coyping and did you say to overwrite? 

  • John Galloway Level 1 Level 1

    I just did a little experiment.  I created a new admin account, used it to delete my normal user with the "leave home dir alone" option so no files are lost.  This renames your user dir (my user is "jrg") to:


    /Users/jrg (deleted)


    Then I created a new user of the same name (thus rebuilding all internal user databses that are NOT stored in your home dir.  Then just renamed the dirs via the terminal running as my admin user ala the following (note the single quotes are used to get the space and ()'s to be accepted as the filenames by the shell that normall would not do so).


    cd /Users

    sudo mv jrg 'jrg (new)'

    sudo mv 'jrg (deleted)' jrg


    Then logged out as admin and back in as "jrg", and everything is as it was.... unfortunately including flash not working.  So this IS for sure something in your user dir and thus jkk there must have been some data you did not copy from your saved version, or did not copy to your saved version.

  • jkk4_1998 Level 1 Level 1

    yeah, when I deleted the old user, I did not keep anything. Get rid of that old home directory. The problem most definately is somewhere in my old settings. so, simply creating a new Admin User and having backed up only my Data and no settings, worked. Very easy to do.



  • John Galloway Level 1 Level 1

    Right when you drag a user's dir via the finder, I think the one thing it does NOT copy is ~/Library (just like when you list your dir in the finder it doesn't show Library).

  • jkk4_1998 Level 1 Level 1

    yeah, what I did exactly is in Finder, on the left, click on your HD. On the right, click on User Folder. Here, you should see your "personal" folder and probably "Public" Folder. I insert my USB stick and when it's recognized, I drag my "personal" folder into the USB on the left. It will then start to copy everything and yes, Library is not in that folder. Only your data and no settings.



  • JayCanale Level 1 Level 1

    Has anyone discovered how to fix this? I can only view flash files in some websites in a Standard account and not a Admin account. It's really weird. I can live without it but it's killing me on why all of a sudden it doesn't work.




  • jkk4_1998 Level 1 Level 1

    OK, hears my final post. Hope everyone understands. It's very easy to do.

    1. Create new User and give that new User name Admin Rights. Add Password. ( This in in your System Preferences).

    2. Go into your current User Folder and backup your Docs, music, movies, pics etc.... with a USB memory stick.

    I had about 15GB of Data. Do not copy any libraries, preferences, etc. Just the folders in your Old User Account.

    3. Sign out and restart in your new User Account.

    4. Go into Finder, Click on User Folder and go to your new User Account. Copy all your Data from the USB into your new user account.

    5. Go back into System Preferences, then Users, and delete your old User Account. Click the last option to NOT save anything!

    6. Mine ended up in my Trash. Delete your trash, 15GB worth for me.

    7. Shut Down then Restart in your new User Account.

    8. Everything should be there, ready to go. Some 3rd Party apps may ask for the serial number again, for you to register. I only had that on two apps. No big Deal.

    9. Do one final check. Go into Finder, click on Users and make sure only your New User Account folder is there, along with, I think, a Shared folder. If your old folder is still there( it was in my case) I deleted to trash then got rid of it for good.

    All should be good

  • kingmohd Level 1 Level 1

    The scroll bar indicator of the video stops working for me on youtube. The video continues to play but you can move forward or back in timeline. It does not show where it is on the time line, the pointer/indicator just sits and the beggening of it. Also hitting spacebar does not seem to pause or start to play the video, the video just keeps going on. Any one knows how to fix this? This never used to happen.


    This problem does not seem to happen on Chrome. Just checked, vidoes are working fine



    Latest Safari

    Latest Adobe Flash

  • jbland Level 1 Level 1

    I have been having this problem and was doing the same thing everyone else here has tried. Just now, I uninstalled some Safari extentions I had downloaded like Do Not Track, Ad Blocker, and a couple that kept Google and facebook from tracking me. Now the videos are working!