Previous 1 2 3 4 5 6 7 Next 97 Replies Latest reply: Jan 31, 2016 10:14 PM by skanjo Go to original post Branched to a new discussion.
  • vilfredp Level 1 (0 points)

    I had this problem on my i7 8gb Lenovo X1 Carbon Touch and it was impossible to watch anything on iTunes. When I changed the battery settings from 'Power Saver' to 'Balanced' it plays much better.

  •  Mr.mactastic Level 1 (95 points)

    thankyou I have trying to find a solution to this problem forever and it worked

  • Goodhikers Level 1 (0 points)

    Majikthize, you said "It would seem the choppy video issue is a complex problem then, with multiple issues and what works for one may not for another.

    For what it's worth I have solved the issue on my PC. None of the above worked but the solution was actually very simple - so basic it's easy to overlook. Complete epithany moment for me."


    Then--after receiving all kinds of advice from this site--you don't even share your solution. I would would have to agree with what someone else wrote about you: you need decency 101. Thanks Tybod for at least trying to help this ungrateful person.


    Now back to the thread.  Tybod mentioned that I would need to separate my HDMI video and audio.  Not easy to do for me since I have an internal 25ft HDMI cable in a home theater.  Video and audio worked fine up until a few months ago, so wondering if anyone has found the ROOT cause for this particular problem on the HDMI side.  I'd rather try a software fix than put a separate 25ft audio cable through the wall.

  • Goodhikers Level 1 (0 points)

    This solution seemed to work for me--I haven't had a problem since I changed my speaker output settings. 


    One thing to add though--I was changing only one group of speaker settings to DVD/CD quality.  That didn't work.  Make sure--if you are using the HDMI output function--that you also  change your sound card's HDMI output to DVD/CD.  For me, I had to change BOTH while each was playing.  Don't know why, but once I did that--problem solved. 


    Interestingly, I turned the wireless syncing back on in itunes and it didn't have an effect, e.g. it now works as advertised and no stuttering playback.


    So truly, several different issues and on different computers produce the same output "stuttering" problem in itunes .


    Thanks guys for all the help here--you were a much better resource than Apple tech non-support.

  • Chris_57 Level 1 (0 points)

    Tout et une question de paramètres audio-vidéo: ordinateur+lecteur vidéo utilisé+type de fichier en cour de lecture (Fichiers différents = réglages différents autant de foi qu'il le faut). Il faut impérativement que tous ces paramètres soit compatible entre eux sinon rien d'étonnant que cela bug. Pour ce qui est du visionnage sur écran plat ,idem modifier les paramètres de sortie audio-vidéo POUR CE PERIFERIQUE. Pour résumer voir 1:format du fichier 2:réglage carte son 3:réglages carte vidéo 4:éventuellement réglages écran plat.Lent et laborieux mais qui ne cherche rien n'a rien. Bon courage,on est tous dans la même galère!

    Ne pas esiter à rechercher sur le web pour plus d'infos sur tous ces paramètres.

  • Chris_57 Level 1 (0 points)

    And any issue of audio and video parameters: video player + computer + file type used in court reading (different = different settings files much faith it takes. It is imperative that all these parameters are compatible with each other if surprising that this bug. Regarding viewed on flat screen, same change output parameters AV fOR periferique. 1 to summarize see: file format 2: Setting sound card 3: 4 video card settings : possibly plat.Lent settings screen and laborious but who seeks nothing gained. Good luck, we're all in the same boat!

    Esiter not to search the web for more info

  • johnfromtega cay Level 1 (0 points)

    I've also had this problem on my Win 7 64 bit machine, with the iTunes library on my Macmini over a wired network. I'm trying to take some iTunesU classes, and gave up on a clean and good solution; I just wanted to be able to watch the stupid thing without carting the Macmini back and forth.

    I copied the mp4 file to the PC harddrive, it came up in Quicktime, and works perfectly. This certainly isn't the solution that I, or anyone else is looking for, but at least it works after a fashion.

    I too amazed that Apple hasn't addressed this.

  • BigGeekUK Level 1 (0 points)

    Having the same issues - movies play fine on Apple TV 3 from iTunes 11 running on a mini pc server but if I use another Windows machine and Home Sharing to try and play HD content it stutters and stalls.


    If I choose to 'import' the file so it copies into the local iTunes 11 library it will then play back without issue - the same files can be played directly from a Windows network share using Quicktime or VLC - again without issue.


    This only affects HD files and they all play fine on iPad / iPhone / Apple TV.


    Something I have noticed is whilst monitoring network activity during playback, the Apple TV 3 pulls so much more data across the network than the PC's using iTunes do.


    There is clearly something wrong with Home Sharing from iTunes > iTunes - this happens on my main PC, and both of my laptops.  I’m just grateful that the Apple TV 3 playback is fine considering that’s the main reason I use iTunes.

  • ButteredSoul Level 1 (0 points)

    I'm trying to play a video from iTunesU.  Sound plays but video freezes, fires off some frames, freezes, and so on.


    My situation:

    • Windows 7 64-bit - Windows Update is uptodate
    • Intel Core i7 920
    • 24 GB RAM
    • GeForce GTX 460 - nvidia drivers version 314.07 (latest release)
    • Creative Soundblaster X-Fi - so audio is separate from video.
    • iTunes - 64 bit (latest release)
    • QuickTime 7.7.3 (1680.64)


    Video GetInfo:

    • MPEG-4
    • 123 kbps
    • Stereo
    • Encoded with HandBrake 0.9.8 2012071800
    • Video Dimensions: 1280x720
    • Total Bit Rate: 1106 kbps
    • Video Codec: H.264


    What I tried:

    1. Everything in this article:  Problem persisted.  Note, that there is no DMA setting for any of my controllers, so I couldn't modify that.  Also, I have no flash based drives.
    2. Plugged in my iPhone.  The Sync with this iPhone over Wi-Fi box was already unchecked.
    3. Tried Preferences->Playback->Preferred Video Version: High Definition (720p).  Problem persisted.
    4. Set Speaker Properties->Advanced->Default Format: 16 bit, 44100 Hz (CD Quality) and iTunes Preferences->Playback->Bitrate for Audio Playback/Bits Per Sample For Audio to 44.1 kHz and 16 respectively.  Restarted iTunes.  Made sure QuickTime settings matched as well.  Problem persisted.
    5. Retried step 6 by setting everything to the sound card defaults: 24 bit, 48kHz.  The problem persisted.


    At this point I used a work around similar to johnfromtega cay's:  I loaded the video using Windows Media Player.  It runs perfectly.


    It runs in QuickTime as well, but not as smoothly as Windows Media Player.

  • Mad_Ranga Level 1 (0 points)

    I subscribed to Game of Thrones as my first tv show download from iTunes.  I subscribed to the HD version thinking my system is well up to playing this as I have no issues with HD quality playback through VLC or Windows Media Player.  I noted on playing the first episode however, that although I don't have audio sync issues, the playback is not smooth and the frame rates were poor.  I had a good look through this forum's postings but I was reluctant to tweak a number of settings for one playback program when I am not experiencing issues elsewhere. I decided to tackle just iTunes and changed settings under preferences within iTunes only as well as disable wifi syncing in case that was having any effect. I was able to increase the quality of playback simply by lowering the format - firstly back to 720p which produced an acceptable result and then completely smooth frame rates on SD.  Yes its annoying that I've bought HD quality only to have to drop back to SD to obtain smooth playback but it has resolved the problem without tweaking numerous other settings within my pc.  Good for a temporary workaround and possibly needed for older setups. (I'm running an ageing Vista 64 bit system with 8gb RAM, Radeon 6800 series video card and intel E7400 processor)

  • MetAlexandr Level 1 (10 points)

    After a lot of experiments I found that this problem leaves if you set a compatibility mode for iTunes shortcut. Compatibility with XP or Vista, both work. The only inconvenience that iTunes Store doesn't allow you to buy or rent HD video, so you have to turn compatibility mode off when buy movie and the turn it back on to watch it.


    But finaly here i've found another issue - set 24 bit 48000 Hz in Windows audio settings for my playback device. It works without compatibility mode. Thanks to this forum so much!

  • nrjohnson Level 1 (0 points)

    I've read all posts on this topic and tried most of them.  All of my choppy video/audio problems were solved when i plugged my laptop into ac power.  It seems like its some sort of power issue

  • jnbworks Level 1 (5 points)

    I've got the same problem. Win 7 64. Latest drivers. intel i7 Quad core, plenty of power.  But only HD 1080p videos are choppy in itunes.


    If I play the same video in quicktime or windows media player, all is fine. It's just itunes and HD files.

    I've followed all the advice on this thread so far.  I'm lost as to what could be going on.

  • Katayanagi Level 1 (5 points)

    I've same problem on Win 7 SP1 64bit i7 3.6GHz PC. iTunes 1080p video playback is too choppy.

    I guess the issue caused by not supporting hardware acceleration. It seems like a legacy app.


    When I play a movie, iTunes 11.0.4 is always higher cpu usage (about 10-20 percent) than other movie player supports h.264 hardware acceleration (Windows Media Player needs only 1-2 percent or so).


    How much longer do we have to wait for smooth playback?


    I don't want to buy no more HD video from iTunes Store.