Previous 1 2 3 Next 64 Replies Latest reply: Jan 13, 2015 7:56 AM by ashcj
ArielLuque94 Level 1 (0 points)

I just got a brand new Macbook pro, and when I try to update iMovie or iPhoto on the app store, I get this error.

 

You have updates available for other accounts

To update this application, sign in to the account you used to purchase it.

 

The problem is I only have one iTunes account, and these apps came with the mac.

 

Is there any way to fix this problem? I tries searching but all that comes up is pirated apps, which is impossible because this mac is brand new and I have only installed flash and sophos anti virus.

 

All help is appreciated. Thank you.

  • ArielLuque94 Level 1 (0 points)

    Please help, this is getting ridiculous. It's a new computer and it already has a major problem.

  • bandit Level 3 (870 points)

    Like you, I have a new macbook pro. Got it yesterday. Today I saw the updates in the App store. Same thing about i need to sign in to the account I used to purchase it. I sent a email to apple. They replied and are in the process of helping me. Unfortunatly, it is after hours for them, so I will be getting another email in the morning. Hopefully they can help me resolve this. I will keep you posted of the results.

  • ArielLuque94 Level 1 (0 points)

    Thank you, I'll make sure to check back here. I sent an email and will be calling aupport tomorrow. If nothing works I'll have to pay a visit to the apple store.

  • Cory1970 Level 1 (0 points)

    Any update on this?  I am having the exact same problem on my brand new Macbook Pro Retina Display model.  I get the same error for iMove and iPhoto.

     

    This is really annoying.  I hope someone at Apple realized people are having the exact same problem.

  • bandit Level 3 (870 points)

    I am getting no where with the app store support. You would think that after 8 emails back and forth they would know what message I am getting, and what my apple ID is. This is a waste of my time. I keep giving them the same information and getting now where.  I am done with them and will try to figure this problem out myself.

     

    Good Luck to you. If you find a solution please share. I will do the same

  • Ducman Level 1 (105 points)

    try this. click on the apple logo and click software update. when done try updating iphoto/ imovie again, it should work by then.

  • bandit Level 3 (870 points)

    I have tried that about 3 times. Problem is, I never purchased the apps through the app store. I have iLife on idisk. Which I was just able to use to install iDvd on my new macbook pro.

  • ArielLuque94 Level 1 (0 points)

    I tried all these things and nothing has worked. The only thing I have not tried is a fresh install of lion, but I don't see how that would help the problem. I'll try support tomorrow.

  • ArielLuque94 Level 1 (0 points)

    Okay I managed to fix it by completely logging out of the mac app store. Going into iTunes, authorizing the computer, opening the mac app store and updating the apps without logging in. It asked me for my username and password about 7 times before it finally went through and started updating the apps. All is fine now.

  • bandit Level 3 (870 points)

    Update:

    I went back to emailing the app store support. After many emails, my case was moved up to a senior advisor who issued me codes to redeem for the iLife apps. Problem fixed!

  • SARyan Level 1 (0 points)

    Suffering the same problem, I tried the Spotlight index fix described and it worked for me.

  • zit Level 1 (30 points)

    The "account", to which the message refers, is NOT your APPLEID account.

    [If you used the wrong applid, you would have no apps to update.]

     

    It is your USERID on your computer.

    I have 2 userids - ADMIN, and PEON which I normally use.

     

    Some of my apps were purchased with the admin account.

    These showed up as "update" rather than "installed"

     

    I logged out of peon, and logged in to admin.

    Now most purchased apps showed up as "install"

    [some were "installed" but none were "update"]

     

    Install all of them, and Bob's your uncle :-)

  • thedave3000 Level 1 (0 points)

    I have a brand new Macbook Pro and I am having the same exact problem in the App Store with iPhoto and iMovie.  I have tried all of the fixes I can find including reindexing Spotlight, logging out of the App Store and authorizing iTunes and then logging back in to the App store and nothing works.  I only have one user account on the laptop so it has nothing to do with a UserID as one other person had mentioned.  I do have two Apple ID accounts and I tried logging into both of those and that doesn't work either.  Does anyone have any other suggestions.  Thanks.

Previous 1 2 3 Next