Previous 1 2 3 4 5 Next 64 Replies Latest reply: Jan 13, 2015 7:56 AM by ashcj Go to original post
  • bandit Level 3 (870 points)

    Email the "app store" support. They ended up sending me codes to redeem. That solved the problem.

  • Buett Level 1 (0 points)

    Many Thx.

    The way with reindexing by terminal had solved my problem.

  • BocaBoy Level 1 (25 points)

    The solution posted by MarkRosewood worked for me. Go to he-other-accounts-bug/ to see if this solution will work for you, but read the paragraph below before you download FindAnyFile. In my case, the app that had the problem was Fantastical. I believe I originally downloaded and evaluated the program from the developer's website, then bought it from the App Store. I'm not sure why that would have caused a problem, especially since this app has been updated before, but deleting the _MASReceipt folder did the trick.


    BTW, for anyone who trips across this post, you don't need FindAnyFile. _MASReceipt is part of the package contents of the application. You can right-click on any application, including those that you purchased from the App Store, and choose to Show Package Contents. Open the Contents folder and you'll find the _MASReceipt folder. Deleting it for Fantastical solved my problem. Therefore, if you know the applications name that's causing the problem, close the Mac App Store, right-click on the application icon, e.g., Angry Birds, choose Show Package Contents, expand the Contents folder and delete the one labeled _MASReceipt. When you restart the Mac App Store, the Update button will have changed to Install and you'll then be able to complete the update.

  • Mike Thornbury Level 1 (0 points)

    This worked for me - thanks.


    I'm sitting on a beach in Borneo, my daughter (and the computer) is at University in Wales, UK.


    Teamviewer > create new account > log out > log in (smart app, TeamViewer - didn't lose the connection!!!) > download!


    You're a star!

  • bgeemac Level 1 (0 points)

    Had the same message when trying to download Lion again after a full recovery on a macbook air.  None of the posted fixes worked.  Found messages in Console referring to missing bitmaps.  Finally took the windows user solution, and formated the harddrive, and reloaded from the original factory Leapord disks, performing software updates as I passed through Leapord and Snow Leapord, and finally was able to download and install Lion.  Only took three times doing the entire process.

  • Steve Cash Level 1 (0 points)

    My problem is updating iMovie to 9.0.8. Now I've tried all tips in this thread I think: I have autorized my iMac in iTunes, i have restarted, I have loged out and in againg, I have re-indexed according to this thread, he-other-accounts-bug/. I have also deleted iMovie and tried to reintall it, according to an idea in another forum, but then I had to buy it again, so I stopped.


    The only thing I have not tried is to e-mail support for codes to redeem, but do I need to when I have only one Apple account?. I also have only one user acoount on my iMac (in addition to guest). I still get that "other account" problem. I then log out of app store and try to update, I get asked for my password two times, and finally I get a dialog telling med that I have to buy iMovie first, but I have, it came with my iMac. I will be thankfull for any ideas.


    (I'm well aware that my English is not perfect, it's not my first language, please bear over with the spelling.)

  • Steve Cash Level 1 (0 points)

    Edit: I should have written that i use Mountain Lion. And now I see that this thread belongs to Macbook Pro, and I have an iMac. Well, still it is OS X, I guess the same problem and solution apply to both.

  • absamdb Level 1 (5 points)
  • ovizii Level 1 (0 points)

    I have tried the solution with removing my entire HD from the spotlight index, then adding it back but that didn't work.

    I tried resetting permissions, no luck.

    I then tried removing the _MASReceipt folder but after I did that and tried visiting the App's page in the App Store I am told that item is not available in the German App Store, so ***?from teh App store I can't update!


    How come I could isntall it in the first place?


    Any other solutions? I've got plenty of apps

  • zit Level 1 (30 points)

    >   I only have one user account on the laptop ... 


    Is that account number 501?

  • lexvo Level 1 (70 points)

    I have exacy the same problem. iPhoto and iMovie won't update because they apearrantly "belong to a different account". I tried all solutions mentioned hear to no avail.

  • Conrad Capalbo Level 1 (0 points)

    So far, I've tried everything in this discussion but iPhoto and iMovie are still not updating properly. I'm running OSX 10.8.2 on a new Retina MacBook Pro.


    Can someone from Apple please comment?

  • Shannon Routley Level 1 (0 points)

    Having the same issue as well. Had problems updating iMovie HD, so I thought, I'll just delete it, and then I'll be able to reinstall. Nope, says I need to buy it.


    I tried deleting the MAS receipt for iPhoto when an update notice came through and couldn't update it. Deleting the receipt now shows that there are no updates, plus looking up iPhoto on the app store shows that I would have to buy it (doesn't show as installed).


    Not sure what is going on, but I have a new MacBook Retina, did a clean install on this computer. I have a support ticket, but that looks like its going to be a long wait.


    Happy with the machine otherwise though!

  • garz75 Level 1 (0 points)

    Hello zit,


    I have the same problem, with a brand new MBP retina bought at the end of August. It was pre-loaded with Mountain Lion. During the inital setup, I created my user account (userid=501), and had to change its user id to 1010 with dscl on the CLI (I connect at work to an NFS share and needed the same user id). Do you think that this App Store error is related to me changing the account's user id ? Should I change back my userid ?



  • zit Level 1 (30 points)

    > Do you think that this App Store error is related to me changing the account's user id ?



    > Should I change back my userid ?

    First try creating a new account 501 and try that.


    How does one find out which userid purchaced the software?