Previous 1 2 3 4 Next 59 Replies Latest reply: Mar 13, 2013 10:59 AM by Old Toad
jtberry87 Level 1 Level 1 (0 points)

my iphoto is currently stuck on updating thumbnails.  An alert pops up for EVERY image saying the image cannot be found.  There is no way to skip this process.  My Iphoto currently is not fuctional until I can resolve this issue.


MacBook Pro
  • Old Toad Level 10 Level 10 (128,865 points)

    Are you running a "managed" or "referenced" library?

    iP7advpref.PNG

     

     

    OT

  • jtberry87 Level 1 Level 1 (0 points)

    Managed....default

  • Old Toad Level 10 Level 10 (128,865 points)

    Select one of the thumbnails and use the  File ➙ Reveal in Finder ➙ Original File menu option. You will be taken to the folder in the library that contains the original file and that file will be selected. 

     

    Report back what happens when you try the above.

  • jtberry87 Level 1 Level 1 (0 points)

    I am not able to select any thumbnail.  iPhoto wants to update them however it pops up an alert saying

     

    The photo "IMG_****.JPG" could not be opened, because the original item cannot be found.

     

    It gives me two choices.  Cancel and find photo.  If I click cancel it moves on to the next photo and gives the same alert.  If I choose to find the photo it takes me to finder and if I click on the iPhoto folder every photo is available.

  • jtberry87 Level 1 Level 1 (0 points)

    I just went through the process of holding option and command while iPhoto opens.  I rebuilt the database. Upon completing this process iPhoto began to function normally.  I closed iPhoto and reopened it and the same issue occurred trying to update thumbnails.

  • Old Toad Level 10 Level 10 (128,865 points)

    Repeat the Option+Command launchy and rebuild the thumbnails.

  • ERR Level 1 Level 1 (55 points)

    Have same issue, pictures are there but no thumbs.  Have rebuilt db, library, etc.  Also iphoto wont quit.  I'm a 20 year Mac user and never ran into such a mess.  All occurred after last update.

  • Old Toad Level 10 Level 10 (128,865 points)

    Have same issue, pictures are there but no thumbs.  Have rebuilt db, library, etc. 

    I take it that includes rebuilding the thumbnails?  If so try it a again as it somethimes takes 2 or 3 goes at rebuilding the thumbnails to take.

  • ERR Level 1 Level 1 (55 points)

    unfortunately I've done that too.  Close to 10 times, as well as the rebuild. 

     

    Do you think copying my most recent backup prior to that will work?

     

    Also, iphoto wont import any more photos and tells me there isnt enough memory on the volume.  ??

    Actually there is 500gb of free space  on that drive as we speak.

  • Old Toad Level 10 Level 10 (128,865 points)

    Do you think copying my most recent backup prior to that will work?

    I would certainly give it a try.  Keep your current librarhy (if you have the space) just in case you need to go into the library via the Finder and get any original files that are not in the backup.

    Also, iphoto wont import any more photos and tells me there isnt enough memory on the volume.  ??

    That's an indication of a damaged library.  The fix for that is to rebuild the library.  What version of iPhoto and system are you using?

  • ERR Level 1 Level 1 (55 points)

    running 9.1.3 or 9.3.1....whatever the most recent update was a few weeks ago.

     

    I have rebuilt the  library 4 times - twice each from iphoto and ip lib mgr. already - to no avail.

     

    I have backups in time machine and "Backup".  Never had to restore from TM though.  Backup may be easier.

  • ERR Level 1 Level 1 (55 points)

    10.7.4 and 9.3.1.

     

    any other ideas??

  • Old Toad Level 10 Level 10 (128,865 points)

    Restoring from TM is pretty much a snap.  Go to you Pictures folder and then enter Time Machine.

    Safari001.jpg

    Once in TM go to the date you want, select your library and use the Restore button.  If you have enought room you can select to keep both versions of the library just in case.

    ip11TMlibrestore.PNG

  • buckeyegolfer Level 1 Level 1 (0 points)

    Mine is doing the same thing.  This is unreal.  I have to just keep hitting "cancel"

     

    my iphoto is also not functional until I get through this.

     

    If you quit, it starts over at the first photo.

     

    Also new since the last update. 

     

    Am I losing photos?

     

    How do I resolve this? 

Previous 1 2 3 4 Next