Previous 1 2 3 Next 85 Replies Latest reply: Sep 8, 2015 7:55 PM by giorauda
ashhhbee Level 1 (0 points)

I can connect my tv to my macbook pro through a HDMI cable and the picture shows up perfectly. However, the sound goes through my laptop speakers and not through the tv. When I go into Preferences --> sound --> output, there is not option to select for the hdmi, just the internal speakers. How can I get the sound to go through the tv instead?

MacBook Pro
  • onarock Level 1 (0 points)

    i have this same problem, however i downloaded sound flower lion, and now the hdmi option shows up, but i get a message in the window telling me "the selected device has no output controls".


    i am using a rocketfish adapter and a dynex hdmi cable as suggested to me by a future shop employee


    any help would b appreciated thanx



  • Zyriab Level 4 (3,300 points)

    If you're MacBook Pro is older than the mid-2010 model then it does not support audio through the Mini-DisplayPort.

  • onarock Level 1 (0 points)

    no, it is not, but after searching these boards even more i discovered this gem, and now all is good, except that u have to change the audio each time......i i mite get an audio cable to make it easier for my hon to hook is the gem



    DisplayPort to HDMI Sound is actually set up by using the MIDI setup utility found in :


    Applications > Utilities > Audio MIDI Setup.


    If you purchased an iWires cable direct from Apple the instructions are in the printed booklet that comes in the packaging. Most people don't read this as it's normally the case that when you plug a cable in to anything it just works (VCR, TiVo, Xbox, video camera etc). In this instance Apple are failing to live up to their catch-phrase as final setup is NOT intuitive; "it just DOESN'T work".


    The booklet instructions basically say do the following,




    System Preferences > Displays. There are 3 tabs in the window; Displays, Arrangement and Color. Be sure you are on the Displays tab. Bottom left of the window tick "Show displays in menu bar" and then bottom right click "Detect Displays".


    Now click on the tab named Arrangement. Bottom left of the window tick "Mirror Displays".


    You should now only see 2 tabs, Display and Color. Be sure you are on the Displays tab. Select the desired resolution for your TV (probably 1080i). leave all other settings at their default values.




    System Preferences > Sound. There are 3 tabs in the window; Sound Effects, Output and Input. Be sure you are on the Sound Effects tab. Middle of the window select your TV where it says "Play sound effects through:".


    Select the middle tab named Output.


    Select your TV from the drop-down list next to HDMI, below where it says "Select a device for sound output".


    Using either Finder or Launchpad go to Applications > Utilities > Audio MIDI Setup.


    On the left-hand side of the window you should now see HDMI. In the middle of the window, on the Output tab, where it says "Source:" select your TV from the drop-down list.


    This last action below is NOT described in the iWires notes but was required in my case, it may also be required in yours. If you CANNOT see a speaker icon next to HDMI in the list on the left, do the following:


    Bottom left of the window select the wheel icon with the down-pointing triangle. Make sure that sound output is selected and that you can now see a speaker icon next to HDMI in the list of devices.


    If you still cannot hear sound, log out of your account and then log back in.


    You will now have sound coming out of your TV from your computer


    You may have to do some or all of the above to get sound out of your TV from your computer using the DisplayPort to HDMI cable. On my Aug 2011 MacbookPro I had to do ALL of the above.  If you take your laptop to a different TV you will have to do it all again so be warned.


    Hope this helps. "



  • JasonRay307 Level 1 (5 points)

    I was having the same issue with my macbook pro.


    The solution is to hold the option key as you click the speaker icon in the menu bar, a drop down list appears and you can select your tv.



  • Imitation Level 1 (0 points)

    JasonRay307's response solved the issue for me.


    I'm using an external Microsoft keyboard, and the equivalent button I pressed, instead of the option key, was ALT.

  • Tris MacBook Pro Retina Level 1 (0 points)

    It also works if you press Option key with the volume button on the keyboard or you can go into the System Prefs and change the sound output preference. Disconnecting the HDMI cable returns the setting to default.

  • JTeitelbaum Level 1 (0 points)

    Hurray for JasonRay307. This works perfectly. Thanks. Saved major aggravation.

  • ajl129 Level 1 (0 points)

    @onarcok that was the only solution for my situation. Thanks for posting it.

  • MaxFS Level 1 (70 points)

    I juat bought a 13" MacBookPro with retina display.  I followed all your suggestions but still no sound coming out of the TV.  I'm planning to call an apple adviser, as I'm still within the 3 months full support timeframe. My sound system on my HDTV TV can come directly from the TV or from a hooked up stereo system.  I tried it either way with no success. I probably will have to get a senior advisor and even then I'm not sure  they'll be up to solving my problem.  If you have any other suggestions let me know. 

  • MaxFS Level 1 (70 points)

    Well, a regular Apple support advisor and a seniror advisor could not solve my problem, as I suspected.  They were nice enough and even offered to have my computer checked at an authorized Apple store.  Don't think I'll do it.  I will just have to live with it.

  • onarock Level 1 (0 points)

    hi maxfs, try doing all of the steps again....i was helping a friend with her laptop (vista) and tv, and she had few aha moments.....she had sound but no pic....we figured it out tho


    also, do u leopord or lion?




    and don't give support was not all that great when they tried to help me about something and i had to call 3 times before i got someone who understood the problem and helped me resolve it......these things cost enuff, they should perform the way they r supposed to, and support people r more than compensated for their time

  • mteston1 Level 1 (0 points)

    Thanks a bundle, got my HDMI playing as it should!

  • Ito21905 Level 1 (0 points)

    My macbook is connected through a mini port, it is currently connected and on "mirroring" however when I press and hold option and click on my voum button, it does not give me the option for HDMI or TV..... running Mountain Lion.

  • Tris MacBook Pro Retina Level 1 (0 points)

    The most reliable way to do it is:


    Go into the System Prefs -> Sound -> click the Output tab and click the speakers you want to use.

Previous 1 2 3 Next