Previous 1 2 3 4 Next 58 Replies Latest reply: May 22, 2015 9:31 AM by Januka_Mac Go to original post
  • karlfromhaymarket Level 1 Level 1

    I downloaded the updated directly from the Apple support site:

     

    http://support.apple.com/kb/DL1515

     

    Seems safer than using the macupdate.com site!

  • eineleipzigerin Level 1 Level 1

    hey, I ran into the same issue, the mentioned link fromm macupdate.com helped me.

    thanks for posting!

  • dywang Level 1 Level 1

    It's work for me.

  • jmn111 Level 1 Level 1

    I was just able to successfully download the Java SE 6 runtime - it's now 5:20 on the Canadian east coast - I'm guessing the servers are less busy at the moment.

  • JonnyMTC Level 1 Level 1

    This fixed my problem

  • Waltrutgers Level 1 Level 1

    Hi Rick,

     

    Thanks for the solution this definitely helped me get round this problem, its the first time I have had a Mac system update fail me. I think they need to be a little more responsive considering the number of peopel who had posted on this forum.

     

    Regards

     

    Walt

  • Jo Wace Level 1 Level 1

    Really helpful - thank you. Was just starting to get fed up!

  • nieten7642 Level 1 Level 1

    So... I am having the same problem and I would love to use the link to the Apple support site indicated above, but it seems to no longer work. Why? Is there an updated version of this link? I would prefer not to use the macupdate.com download, but I suppose if I have to... Help??

  • TStam Level 1 Level 1

    Sometime after 10.8.1 ML update, my java preference panel would no longer load. It would show on the dock but the panel would not load. Programs requiring java stopped working. No terminal commands for java would work including java -version.

     

    How this happened, no idea.

     

    I tried reinstalling the 10.8.1 update, no good. I reinstalled 10.8.0 from my thumb drive installer and that fixed it. First time I ran the java preferences ML downloaded it, installed it, and the preference panel and programs are working. Software update reinstalled 10.8.1. All still working.

  • Equus Level 1 Level 1

    I am having a terrible time with Java on 10.8. I recently bought the new Mac Mini with 10.8.0 installed and moved everything over with Migration Assistant. For some reason, there was no Java on the new Mini. I've been trying and trying to install Java SE Runtime 6 from the Apple website. It runs, says it installs, but I still get "missing plugin" in both Chrome and Safari. I have no Java preference pane, and no JavaPreferences.app in the utilities folder that people keep talking about. It's like it installs and goes nowhere. I've tried deleting the entire Java folder from /Library and reinstalling...still nothing. This is crazy!

     

    I'm trying to avoid upgrading to Java 7 because of the security issues and wanting to keep using Chrome. Can any give me some guidance to actually make this install work?

     

    Thanks!

     

    Equus

  • Rigorous Dude Level 1 Level 1

    I updated my MacBook Pro to OS X 10.8.2 and Java 7 Update 9.  Then I found that I use web-based software that will not work with Java 7 and need to go back to Java 6.  I followed the instructions on the Java website (http://www.java.com/en/download/help/mac_uninstall_java) to remove Java 7 and return to Java 6.  However, when I check the Java version after completing the instructions, I get an error message saying that the Java applet is missing.  Is there a fix for this?  It sounds like the same issue others on this thread have had, but I don't see a solution.


    RD

  • roadrashman Level 1 Level 1

    Please Apple or Oracle, get going on this! I need Java 6!

  • D. Rackerby Level 1 Level 1

    I got Java 6 update 37 working on 10.7 and 10.8.

     

    After you do all the Apple updates, you have to place JavaAppletPlugin.plugin version 14.4.0 in the Internet Plug-ins folder.  On 10.7 and 10.8, Apple will install version 14.5.0.  That version does not work.  If you need version 14.4.0, look on a 10.6 machine.

     

    Dan

  • D. Rackerby Level 1 Level 1

    This is probably a better workaround:

     

    After you do all the Apple updates...

     

    1) Remove the the existing symbolic link:

     

    sudo rm /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin

     

    2) Create a new symbolic link:

     

    sudo ln -s /System/Library/Java/Support/Deploy.bundle/Contents/Resources/JavaPlugin2_NPAPI .plugin /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin

     

    Dan