Previous 1 2 3 4 Next 358 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz Go to original post Branched to a new discussion.
  • digitalwhite Level 1 Level 1

    I have the same exact issue.

    Please help. I tried everything. I found these but to no avail. still cant connect.


    Fix #1: Add a New Network Location & Renew DHCP

    This may work best for those who upgraded from a previous version of OS X to Mountain Lion but if you’re having the wifi drop issue go ahead and do it anyway because it is consistently successful with addressing wireless issues:

    • Open System Preferences from the  Apple menu and choose “Network”
    • Pull down the “Location” menu and choose “Edit Locations…”
    • Click the [+] button to add a new location, name it whatever you want then click Done
    • Back at the “Network” screen, click the “Network Name” menu and join the wireless network

    Your wireless connection may now be active and working fine, but renew the DHCP lease anyway:

    • From the Network panel, click on the “Advanced” button in the lower right corner, then click the “TCP/IP” tab
    • Make sure “Configure IPv4:” is set to “Using DHCP” and then click the “Renew DHCP Lease” button, click “Apply” when prompted
    • The appropriate DHCP settings should be renewed from the connected router, click “OK” and exit out of System Prefs

    Renew a DHCP lease in Mac OS XThe network location and DHCP renewal tip resolved similar wifi problems in Lion, and it seems to work in Mountain Lion too for many users.

    Fix #2: Change MTU Size to Prevent Dropped Connections

    This is a bit geeky but bare with us: MTU stands for Maximum Transmission Unit and controls the largest packet size allowed for transmission over the network. If this setting is greater than network capacity, the computer will experience packet loss and dropped connections. The default setting of 1500 is somewhat aggressive and some networks reject packets of that size, but it turns out that 1453 is just small enough to maintain a consistent connection with most networks but just large enough to not cause any slowdowns, it’s the magic number and an old cisco networking secret.

    • Open System Preferences from the  Apple menu and select “Network”
    • Click the “Advanced” button in the lower corner, followed by the “Hardware” tab
    • Pull down the “Configure” menu and set to “Manually”
    • Change “MTU” to “Custom” and set the field to “1453″
    • Change MTU size in Mac OS X
    • Click “OK” and close out of Network preferences

    Be sure you’re joined on a wireless network, close out of System Preferences, and enjoy the internet as usual.

  • shcherbakov Level 1 Level 1

    Any solutions dont' fix the problem.

  • jawt Level 1 Level 1

    Seems to be flash related issue at least in my case. My wlan freezes during flash video f.ex. ping on background or other pages stops working. And I have this problem only with my 2nd access point (TP-link) .

  • smkidsap Level 1 Level 1

    Having same problem - called Apple and no fix worked - heading to the Apple Store with the desktop

    this afternoon. Ethernet does not work for connection either. Can't reload and install ML cause can't get on the

    net. Frustrating.

    Tried getting rid of network and setting up anew, new location, renewing DCHP, and all the online fixes listed

    above - nothing even comes close. New hard drive on this computer so know it is not that either. Hope APPLE comes

    up with a solution - all the lap tops work just fine.

  • carbarn_1401 Level 1 Level 1

    I am running into problems when my summer 2011 iMac wakes up.  Even when it reconnects to the wifi signal, webpages will not load and get a DNS error.  If I go through and renew the DNS and then use the connection assistant to reconnect I am able to get on the Internet again, but that is the only way.  This problem is directly related to Mountain Lion as it only begain occuring once I applied the update. 

  • Lukas Hauser Level 1 Level 1

    I am having the same problem... None of these solutions are working on a vanilla 2010 iMac with ML and an airport express that feeds Internet fine to all other devices. It was working for several days but now (with no changes to computer) it has stopped, exactly as the others have described. Occasionally I can get a connection for 5-10 seconds by renewing dhcp lease but the IP address goes away shortly thereafter... Using my phone to post this. Never should have installed ML and will advise all clients not to. Argh.

  • smkidsap26 Level 1 Level 1

    Try updating firmware on your router - that was my problem. Needed two updates and then

    everything worked on the wireless network, phone, ipad, lap tops, desktops and printer.

    Apparently the tech in ML is more than the old router could handle in translation so was kicking me

    off after 30 seconds. Did all the other suggestions and even called Apple but it was the router after

    all that. Hope this helps.

  • digitalwhite Level 1 Level 1

    After so much monitoring I have came to the conlcusion that it's a signal issue. I run a digital agency and have been using mac since 1984, I know them inside out. I am also the guine pig in the agency trying out first new things and have my own tech team working out solutions.


    Boils down to:

    The problem obvisouly is Mountain Lion and how it react to the signal of the Wi-fi.

    Ethernet always works and most of the time I am on ethernet.

    Using a USB dongle works well


    Sometimes it connectes to wi-fi sometimes it doesn't. If I try to wi-fi first in my lounge (3mt from router)  it does't work, then I walk to my bedroom and it connects, then go back to the lounge and it works and stays connected but then sometimes it drops out. There is really no explanation or reason I think it's how ML interprets the signal from the wi-fi.


    The trick of renewing the DHCP doesnt always work, sometimes it does. If you delete the whole WI-WFi and re-create it sometimes it fixes it sometimes it doesnt. Again it's a bit of a russian roulette. But from my bedroom (6mt from rotuer + wall) it never drops out and always connects.


    I found ways to position my mac so it works, so it's not an issue as much although Apple needs to fix it, so I am checking everyday when 1.8.1 is ready.


    So I hope I am being helpful.


    Mac is: MacBook Pro, 2.2 i7, 16GB Ram, 1TB Hardrive.


    Mountain Lion was an upgrade although I normally would just do a clean install.


    PR - Another issue I have with ML is that the Empty trash is Very Very and I mean Very slow. But this is another issue. All in all ML purrs quite well and better than Lion.

  • Kekernan Level 1 Level 1

    The renew DHCP trick works for maybe 36 hours. To all of you who think you solved your problem, you're wrong. It will be back.


    Here's what I notice:

    1. The more apps I have open that pass data in the background (mail, itunes, iphoto, etc), the quicker it fails. Rarely are either any Office apps or Adobe CS6 apps affected.
    2. When WiFi won't connect, the clock stops. This means that this is far larger problem than WiFi. It is causing a partial system freeze.
    3. Whatever apps I have open that pass data must be force quit when WiFi won't connect so that I can restart. They do not appear to notifying Apple as usual so the engineers are likely missing thousands, if not millions, of bug reports.
    4. Windows 7 under Parallels and its apps usually continue to work and use WiFi unless I was passing data between OSX and W7. Therefore, we can conclude that is not hardware, it is Mountain Lion.
    5. While it does lose it occaisionally while working, it is most likely to loss it when it wakes from sleep (with or without the lid closed). I now close all apps before shutting the lid. I live in fear if I walk away from the computer and when I return the screen is black and white light is pulsing.

    Because of cloud integration, this is unacceptable. Mountain Lion has crippled my 2yo MacBook Pro. Mountain Lion is Apple's Windows Vista. It has clearly not been tested on relevant hardware. I have told everyone that UNDER NO CIRCUMSTANCES should they install this upgrade. I have several friends who are long time Mac users, as am I, who say the same. By not fixing this, you are risking your reputation. If this is not fixed soon, I will be forced to buy a new laptop. It won't be a Mac, largely because it would have to be a mountain lion device and I don't trust it, even on a new machine.


    PS, my family owns 2 imacs, 4 macbook pros, 3 iphones, 3 ipads (and assorted devices in the "archive"). Fortunately, I only upgraded my laptop. The only Windows we own runs in parallels. Are you really going to make me buy a Windows PC?

  • David Neale1 Level 1 Level 1

    Upgraded to ML thus morning. Now, each time I wake my iMac from sleep, it fails to make a WiFi connection. Approaching the WiFi fan in the menu-bar causes the pointer to turn into the spinning beachball. I can open System Preferences, but trying to open the Network panel again causes the cursor to turn into the spinning beachball. The only way out of this, it seems, is to Restart (and this often first involves force quitting applications).

  • J.D.S. Level 1 Level 1

    Sam issue - upgrade to Mountain Lion is the only change I made. I show connected to the Wi-fi network from which I am writing this post on my iPad, so clearly working. From my upgraded iMac on ML, anytime I launch a browser it attempts to load, but simply stays frozen during the load.  If I go to command line and ping a site (as suggested earlier with ping' I am successful at getting consistent responses with no packet loss. Therefore I clearly have a working Internet connection on my upgraded computer, but ML is not able to leverage it in my browser or any other web enabled application.


    Apple, this is a major issue. Help!!!

  • Kauai Guy Level 1 Level 1

    UPDATE: I tried a great many of the suggestions listed in the forums to no avail, until I logged into my router (Netgear N750 dual-band) and upgraded the firmware.  I then made sure that I was connected to the 5Ghz band, and my connection has now been back to normal for a full day so far, where until now it would freeze several times an hour.  Even though the signal showed up strong the whole time, apparently the router's firmware didn't 'like' my ML install, and needed to be upgraded in order for the two to play nice.

  • J.D.S. Level 1 Level 1

    Ok, for my particular issue I found a solution unrelated to the operating system.  This may not impact everyone, but sharing since I was originally convinced the only issue was the new OS.


    Right before upgrading, I moved my iMac to the first floor of my townhome, and the router is still on the 3rd floor.  This worked fine for days, and I was still able to work fairly seamlessly on my non-upgraded macbook pro when my iMac stopped working on wireless.  However, after doing a lot of troubleshooting I found that the signal strength on my AT&T provided 802.11g router was relatively weak at that distance, and there are A LOT of other routers that are likely 802.11g in close proximity that likely are causing interference.  I carried my iMac upstairs again, and it instantly worked like a charm once it was close to the router.


    Since I still want the computer downstairs, I purchased an Airport Extreme this morning and setup a dedicated 5ghz 802.11n network, and now I'm typing from my Mountain Lion iMac 2 floors away from my Airport Extreme, and everything is working seamlessly.  While I would like to say this is wholly a hardware/interference issue, what I can't explain is why my non-upgraded macbook pro, iPads, and iPhones all work perfectly fine on the old 802.11g 2.4ghz network from the same place.  All things being equal, it suggests that Mountain Lion makes browsers/applications more sensitive to poor wi-fi signals, since as I indicated before I did have some connectivity prior to upgrading the router since I was able to ping sites from the command site, but wasn't able to pull them up in a browser or use any web enabled applications.  This also corresponds with an earlier post where I believe someone solved their issue by switching channels (maybe from 1 to 6, but not recalling at the moment):  They likely had interference problems that weren't an issue under an earlier version of OS X, but was an issue under Mountain Lion.


    Hopefully this solves the issue for me for the long term - good to luck to everyone else.

  • Quinsy Level 1 Level 1

    nothing work for me,, so i disabled the iMac wifi and bought a new USB wifi dongle.. and now everything works perfect. thank you apple 

  • digitalwhite Level 1 Level 1

    I found a solution that works very very well. Log into your router and if you have amodern router, switch it to work on 5gz. Then no more drops All working back to normal again.


    But now I cannot connect my iPhone 4s to the 5Ghz wireless.


    Apple please update your signal issue

Previous 1 2 3 4 Next