Skip navigation

Mountain lion wifi problems

123881 Views 371 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz RSS Branched to a new discussion.
  • Senhor-Ron Calculating status...
    Currently Being Moderated
    Dec 18, 2012 3:31 AM (in response to henrijacobs)

    Having the same problems a couple of times a day. Like everybody else, noticed that none of the ´solutions´ really work. It´s not only Mountain Lion, it also has to do with the current hardware. I´m running ML on two different iMacs, one recent and an older one. The older one doesn´t disconnect while the newer one does.

     

    So... Apple... watchagonnadoaboutit?

  • preludio Level 2 Level 2 (190 points)
    Currently Being Moderated
    Dec 20, 2012 8:25 AM (in response to irtriskit)

    If you can ping an IP address but not a domain name, then it sounds like you have a DNS problem. Since you probably connect to a different DNS server when you're on a different network, that explains why your network connection works other places.

     

    (Also, identical routers can have different settings. Just because the hardware is the same doesn't mean that the networking is the same.)

     

    I would try the two fixes described here:

     

    http://osxdaily.com/2012/08/02/fix-os-x-mountain-lion-wireless-connection-proble ms/

     

    Good luck!

  • till213 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2012 3:25 AM (in response to preludio)

    Hi folks,

     

    I am writing this message on an Ubuntu 12.04 system - on the VERY same iMac 27" 2011 hardware which reliably fails me to even get a valid WiFi connection running under a FRESHLY installed Mountain Lion 10.8.2!

     

    Here are my findings so far:

     

    I got this iMac from a colleague and the harddisk was formatted. The iMac was then booted (from the "rescue partition", I guess) until the option menu "Install new Mountain Lion" (or so, can't remember) appeared.

     

    EVEN AT THAT POINT I could not connect to my WiFi Router, a FritzBox 7340 (not uncommon brand, at least here in Europe), so I went on via Ethernet cable and made a FRESH INSTALL of latest Mountain Lion 10.8.2.

     

    After installing a few applications from Apple Store and also applying the latest updates (yes, there were still some updates pending, such as iTunes 11, RAW compatibility, ... nothing ground-breaking however) I tried the WiFi connection: still did not work! The "connection bar" had an exclamation mark , but turned into a "full reception bar" later on (in fact, my new 27" is located in the very same room currently as the router, not too close to the router however, about 2.5 metres).

     

    It turns out that the DHCP lease does not work, my machine always (self-)assings an address of 169.x.x.x ("invalid address").

     

    My router settings at this point:

     

    * 801.11 n+g

    * Band: 2.4 GHz, manual channel selection (channel 4, with least noise from other networks)

    * WPA2 (only, no WPA support), private password key

     

    Off course I also tried "Automatic channel selection" in the router settings, re-started the router, dropped the WiFi connection in Mountain Lion, tried re-newing the DHCP lease, rebooted the iMac several times, to no avail!

     

     

    BUT THE FOLLOWING WORKED!

     

    * 801.11 n+a (or so, not sure, but the crucial point is...)

    * Band: 5 GHz

     

    At those settings the iMac 27" 2011 is perfectly able to connect to my router!

     

    Now since every other device, including a MacBook 11" 2010 running Mountain Lion 10.8.2 as well (1), an older 2008 iMac running Snow Leopard, an iPhone 3GS, 4 and an iPad 3 (all latest iOS) etc. connects perfectly with the 2.4 GHz settings, this must be a software driver issue on Mountain Lion! Especially since when running Ubuntu 12.04 on that VERY SAME HARDWARE the connection with the VERY SAME ROUTER SETTINGS (2.4 GHz, WPA2, ...) DOES work! Go figure!

     

    I even tried putting Ubuntu into "standby" (sleep) mode. And guess what, after waking up a "notification" message was there saying that the WiFi had been disconnected, the WiFi connection bars immediatelly started blinking ("scanning")... and the connection was succesfully RE-ESTABLISHED!

     

     

    So currently I am running my iMac/Mountain Lion with Ethernet cable, BUT EVEN THERE CONNECTION drops after a few hours of work (I am encoding DVDs currently...). No DHCP renewal seems to work, the connection stays dead, and the network status says either "invalid address" (169.x.x.x) or even "unknown status" (go figure!). A reboot then re-establishes the Ethernet connection. Or maybe when you wait another (couple of) hours - this morning my iMac did have a valid connection again, after it was dropped yesterday evening.

     

    First I thought that Ethernet disconnect was related to "sleep" mode (which I now turned off for the time being), but yesterday the Ethernet connection was interrupted "right before my eyes", while I was updating/downloading another application! Bang!

     

     

    SO THERE IS DEFINITIVELY SOMETHING VERY FISHY going on with network connections in general in Mountain Lion! It might be that changing the MTU settings or who knows what may make Mountaion Lion work (for a while), but given the FACT that EVERY other device is able to cope with my router settings - INCLUDING the iMac 27" itself running Ubuntu (so no hardware issue either!) - is a clear indication that the FAULT IS (still) WITHIN MOUNTAIN LION 10.8.2!

     

    So I urge everyone to send feedback to Apple here: http://www.apple.com/feedback/

     

    I will also try to re-send some more information ("it does work on Ubuntu", my "5 GHz finding", router settings....) to Apple.

     

     

     

     

    (1) but the MacBook Pro went from 10.6 to 10.7 to 10.8, so there could be those "crucial settings" left which make it work there - or it simply is a different network card and 10.8 works "by chance" there. However connection speed is rather slow, especially when transferring large files connection drops evey 5 seconds to a few KBytes/sec - but different story).

  • kx2 Calculating status...
    Currently Being Moderated
    Dec 27, 2012 6:29 AM (in response to henrijacobs)

    I changed to wired and had the same problems I had with wireless.  I changed everything to manual, manual IP and router.  Had trouble with the DNS server not being recognised.  I changed it to only 1 DNS and it appears to work, the dual DNS servers seams to confuse mountain lion, still takes a couple of minutes to find the DNS server but does it eventually and then works..  Changed MTU to manual as well.  problem seams to be related to samba and DNS servers, samba doesn't like long network names 12 and over kills the connection.

  • DaveRoberts Calculating status...
    Currently Being Moderated
    Dec 27, 2012 6:43 AM (in response to till213)

    till213,

     

    That's good info. I was starting to suspect the same thing with respect to the frequency band in use. For the record, I have a MacBook Pro that worked fine with Snow Leopard and Lion, but now fails miserably after the Mt. Lion upgrade. I also just bought a *NEW* iMac for my kids for Christmas and it's suffering the exact same problems. When I ordered the iMac, I also got a new Time Capsule for backup and was using the 5 GHz signal for a while and things seemed to work better. I wasn't sure whether that was my imagination or not. Good to have that confirmed. I might try some more tests to see if that works. Unfortunately, my wife's PC laptop is limited to 2.4 GHz, I think (802.11g/n, not a/n).

     

    Note that I don't think this is a hardware issue at all. My MacBook Pro hardware was working great until the upgrade.

     

    kx2, I don't see any issues with wired networking. I'm typing this right now while connected to an Ethernet cable string across my office and I don't see any drops.

     

    And again, if you start a ping command in a terminal window, just pinging your local router's IP, your wireless will continue to work. That's the only workaround I have encountered. Network activity seems to keep it from experiencing the problem.

     

    BTW, based on my experience trying to fix this and the fact that the brand spankin' new iMac has the exact same problem, I don't think this is a configuration or upgrade problem. This has to be a driver problem, as till213 says, which means we need to force Apple to deal with it and get a patch released.

     

    So I urge everyone to send feedback to Apple here: http://www.apple.com/feedback/

  • till213 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2012 8:13 AM (in response to DaveRoberts)

    To repeat my most important findings:

     

    • Fresh install of OS X 10.8.2 on an iMac 27", 2011, Intel Core i7 3.4 GHz, 8 GB RAM
    • From the very beginning NO WiFi connection at all (even from the "Install OS X" "boot menu")
    • Router: FritzBox 7340, personal WPA2, 801.11 n/g, 2.4 GHz, manual channel selection (channel 4)
    • When running OS X 10.8.2: Connection to my router fails, self-assigned IP address 169.x.x.x ("invalid address")
    • Re-newing DHCP lease, deleting PRAM (when booting), setting MTU to 1453 (other than default 1500), re-starting the router, changing channel to "auto" etc. did not help
    • Wi-Fi diagnosis comfirms (not unexpected) that network settings could not have been established (hint: press Option key while clicking on WiFi symbol in menu bar above right)
    • Changing my router to use the 5 GHz band (801.11 n/a) DOES WORK! (I did not test the reliability of the connection extensively, though)
    • When using 2.4 GHz: the "WiFi info" (Option key + WiFi symbol in menu bar) says: RSSI: -40, Send rate: 0, MCS-Index: 0 whereas
    • When using 5 GHz: the "WiFi info" says: RSSI: -40, Send rate: 300, MCS-Index: 15
    • Bluetooth is enabled (as to make use of the Apple Bluetooth mouse)
    • Running Ubuntu 12.04 from a DVD on the very same machine and the same "non-working" router settings (2.4 GHz) does work, even with Bluetooth enabled (which I read that it might interfere with other devices in the 2.4 GHz band - which does not seem to be the case here) - connection is properly re-established after wakeup from sleep (standby).
    • The successful test with Ubuntu on the same machine also shows that a) the hardware is not faulty and b) the router settings do work (in fact: every other device is able to connect - funnily even another MacBook Pro 11" 2010 with OS X 10.8.2 - but the later went through an upgrade from 10.6 to 10.7 to 10.8 - and even on 10.8 connection is shaky, especially when transferring large files in the order of Gigabytes
    • During all Wi-Fi tests Ethernet cable was physically disconnected
    • Ethernet connection is also very shaky: it completely drops after some usage time (sometimes even after minutes), most observable while transfering large files (in the middle thereof). A reboot then restores the connection, or it seems that after hours (during the night) the connection is also somehow restored - renewing the DHCP lease not not help in these cases, re-connecting the cable does also not help (it might or might not be related to the WiFi issues we're discussing, and I'd like to keep that discussion elsewhere)

     

     

    The fact that Wi-Fi does work on my MacBook Pro 2010 probably means that the issue is  hardware dependent, or it might also be that some "settings", still enabled from Snow Leopard (or Lion) times, make it work.

     

    However I remember right after upgrading to OS X 10.8.0 the connection initially also did not work at all, but at that time I could work around that my "dropping" the connection (removing it from the "remembered connections" list) and re-establishing it (by re-entering the password etc.). I think a renewal of the IP address (as assigned from my provider) inside the router settings did also a trick.

     

    However all this does not help with my current iMac 2011. And I should not be doing all this mess in the first place, since all other devices (most notably my older iMac 27" 2008 running Snow Leopard) adapt to all router setting changes (changing from 2.4 GHz to 5 GHz, changing channels, changing from WPA to WPA2 etc.) without the need of ANY manual intervention (as expected) - they simply see that the WiFi network is gone, they see it again with different settings - and they cope with it (except the iPhone 3GS and 4, off course, which do not support 5 GHz).

     

    So hints like "you have to renew the DHCP lease, delete the PRAM, disable Bluetooth, change the MTU to any value below the standard 1500, drop the connection, restart the router etc. etc." might make OS X 10.8 seem to work (or trigger something which correctly initialises the connection or whatever) - but they are simply crude hacks which should not be necessary in any case!

     

    An yes, I will provide all my findings to Apple, and so should you:  http://www.apple.com/feedback/

  • lara_g72 Calculating status...
    Currently Being Moderated
    Dec 27, 2012 10:59 AM (in response to till213)

    New MacBook Air purchased Oct 2012, had the intermittent wi-fi issue to a Motorola SBGsurfboard 6580.  Tried all the "fixes" posted on various tech sites, and none worked.  The fix that seems to finally have solved the problem is restricting to wi-fi to "g" mode only (i.e.,  do not allow "n" connection).  so far so stable...

  • till213 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2012 12:59 PM (in response to lara_g72)

    @lara: Interesting: so - in some combinations - limiting the WiFi network to 801.11 g also seems to work.

     

    Be aware however that you limit your entire WiFi network - all devices in your household connected to that router - to 54 MBit/sec, whereas with 801.11 n you get up to 450 MBit/sec (when your router has 3 distinct antennas - I think recent iMacs and probably even MacBook (Pros) support 450 MBit/sec).

     

    (The above numers are theoretical numbers, off course, but even the net bandwidth is reduced considerably when refraining to the 'g' standard)!

     

    So what you have is a crude "workaround", which might just do fine in practise for you, but if you have many devices  - like me - connected to that WiFi network, then this would be a terrible drawback!

     

    Or in other words: that definitively is a bug somewhere in OS X when your OS X 10.8 device cannot connect (reliably!) with the 'n' standard (or any defined and officially supported standard, for that matter).

     

    For details about all these standards and supported bandwidth https://en.wikipedia.org/wiki/IEEE_802.11#802.11g is a good starting point. Also note that the next standard, 'ac' is already lingering in front of our door (first routers runnning the "draft" of this upcoming standard are already available since several months). That standard supports up to 1300 MBit/sec, closing in to Gigabit Ethernet But I am drifting off somewhat...

     

    Still, Lara, so I'd recommend you also send in feedback to Apple, using https://www.apple.com/feedback/, and tell Apple that your machine/OS X 10.8 is not able to connect to an industry standard router, using 801.11 n on the 2.4 GHz. The more data Apple has available - and the more "pressure" - the more likely and quicker it becomes that the may be able to fix it.

     

    I mean, it's not like they never had it running before...(Snow Leopard hooooray!)

     

    Cheers

  • johnboyuk Calculating status...
    Currently Being Moderated
    Jan 7, 2013 1:39 PM (in response to johnboyuk)

    We'll... despite my initial success (see earlier post)... lasted about a week and now back to contantly dropping wifi connection again! This is unbearable...

  • wclyffe Calculating status...
    Currently Being Moderated
    Jan 7, 2013 2:56 PM (in response to wclyffe)

    For anyone this might help....

     

    My post from 12/10 is below, and today I pushed the IT department to double check my actual access point. Well, they did and found there was a firmware update available that they were unaware of. They did the update and as far as I can tell the problem is fixed. This was the first time I used my computer for 3 hours straight and didn't get disconnected from the Internet. I'll have to use it more, but so far I'm optimistic!

     

    wclyffe

    Re: Mountain lion wifi problems

    Dec 10, 2012 5:19 PM (in response to henrijacobs)

    As I mentioned in an earlier post, I have a brand new MacBookPro with the same terrible wifi performance dropping out on a Cisco WAP 4410N at work, but no problem whatsoever on my AirPort Extreme at home. I have tried literally everything on this thread except for a clean install, but there are already many individuals who have done that and it still did not solve the problem. I've even tried johnboyuk's plan of doing several steps all at once, but I still have the problem. The router is configured with WPA2 and no one else is having a problem. Anyone happen to be dealing with this unit by Cisco?

  • mbpro2012 Calculating status...
    Currently Being Moderated
    Jan 8, 2013 11:43 AM (in response to henrijacobs)

    My solution to the problem was a dirty and painful one.  i went and spent money on an airport express, installed it and have had almost no wifi problems on my late 2011 mbp running latest ML since then.  once a week maybe, but certainly nothing like before.  Setting up a ping command to run eternally probably would have done the same thing.  but it also seems to improve my connection between apple tv2 and other mac shared libraries.  my router is an airties RT-204v3, the provider only supports v1. something of bios so no update possible(this is in Istanbul).

  • mbpro2012 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2013 12:26 PM (in response to mbpro2012)

    let me clarify the "painful" comment above.  It wasn't about configuring the airport extreme.  It was about the fact that there is absolutely no good reason I should have had to go and spend another red cent with a company I am extremely frustrated with because of problems like this ridiculous wifi issue, which seem to be more and more common.

  • pdbowers Calculating status...
    Currently Being Moderated
    Jan 18, 2013 2:41 PM (in response to henrijacobs)

    Here is what worked for me. Called Apple Support.  My iMac was not connecting to my wireless network, or would sporadically.  The kind agent told me that if I were to change the security settings in my router to WPA2 that more than likely would solve my problem. Prior to this I was simply using WEP encryption.  I thought he was nuts, but did as he suggested.  Well.  Its working absolutely flawlessly now. For those still using WEP, change your security settings and see if this works. I am happy again and not ready to use my Mac for scrap.

  • kx2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 18, 2013 3:47 PM (in response to pdbowers)

    Solved the problem - re-installed Lion - no network problems at all, why did I pay for an update.

  • dedge.guarim Calculating status...
    Currently Being Moderated
    Jan 19, 2013 4:57 AM (in response to kx2)

    Hi Folks,

     

    I'm using a MBP13 Late 2011 OSX 10.8.2.

    I upgraded some months ago but the problem only appeared recently. The connection is extremely slow and sometimes drop the connection, even if the wifi icon on the bar is "full".

    On the same room of the router, connection is fine, but distant is too slow. I have noticed also that when a wireless phone working on 2.4 band rings and some answers it, the wifi drops, and it will be restored when the person hangs up.

     

    I have run tests changing MTU 1400, Channel 11, New DNS, none of this worked.

    But the Bluetooth ON with the Magic Mouse after 20 minutes begin to cause interference.

    What i notice with iStumbler and with the Diagnostic Wifi Tool buil in on ML is that:

    Router is set on a specifc channel, for example, channel 11.

    When Bluetooth is OFF, the speed of my connection is normal and MBP reconizes as the channel 11.

    When Bluetooh in ON with Magic Mouse, the computer does not recognize which channel is, and shows that is connected on Channel 1. I think this is because of the interferences Bluetooh causes.

    I will not buy another router, this is wrong, everything worked fine some months ago. But i'm think of buying a wired mouse, but the speed of my work will decrease significantly.

     

    Hope this helps.

     

    Bruno Redondo

1 ... 12 13 14 15 16 ... 25 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.