Previous 1 3 4 5 6 7 Next 358 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz Go to original post Branched to a new discussion.
  • roxan Level 1 Level 1

    Hi J1H,




    - Many users had reported in forums that WPA2 was not "per se" resolving the issue: it is probably a reminiscent set of parameters that were reset as a side effect of your upgrade.


    - Moreover, it is very difficult to admit that my iMAC would not support WEP "de facto": upgrading to WA2 would mean in my case to throw to the bin at least three of my 16 devices (an ipcam, a Hifi extender to stream music, an old win98 PC)


    - My mine deception is that by moving to a "one supplier for all stack" paradigm such as Apple, I didn't solve my "father=home system manager" issue to handle the park of machines a home.... :( Back to PCs at the end? Very very disappointed in any case.



  • Kekernan Level 1 Level 1

    Well, I may have fixed my problem. I have gone 48 hours without a failure. It looks a like a software incompatibility issue. Since the menu bar froze when Wifi failed. I started there. I looked at two things in particular: growl and transmit (an ftp client). For me, it looks Transmit was the culprit. Although some think it is actually an interaction between growl and transmit. I have deleted it and the other Panic application I use, Coda 2. Problems (cross fingers) seem to be gone.


    I believe there are multiple problems with the wifi communication stack on Mountain Lion. If your problems sound like mine, start with growl because it does notifications which is a new feature of Mountain Lion. If you have the 1.2.2 version, you will see it in the bottom row of your system preferences. There is an application tab that will tell you the programs it interfaces with (Adobe Updater, Dropbox, Evernote, Cyberduck, Coda, Transmit, and Firefox for me). Turn it off. You will need to do so on several tabs. See if you see an improvement. Mine was dramatic. I did a little more research and found that Transmit, while technically compatiable with Mountain Lion, had issues with growl. As I said, I deleted it and its sibling. I also updated growl to the 1.4 version. I have gradually turned the remaining programs back on and have had no problems. If you don't have a known bad actor like transmit, you'll have to do it until you find the problem child.


    My Mac is back! Good luck and I hope this helps.

  • russmcc Level 1 Level 1

    Short term fixes.... REFUND the costs and give me back the lion OS

  • rangepig Level 1 Level 1

    After reading Kekernan's post I turned off Growl (and Hiss, which is a helper app that puts Growl notifications in the ML notification center) and I've had my first full day since I upgraded to ML without a wifi disconnect!


    Maybe Kekernan is on to something...

  • David Neale1 Level 1 Level 1

    You should still have Lion if you made a backup.

  • eflaten Level 1 Level 1

    I have exactly the same problem.


    1. After wake up. Wifi is lost.
    2. Apps starting to hang and doesent respond showing up as red in the cmd-alt-esc tool.
    3. Must press force restart.


    If of any interest. Here is a wifi-report:


    This happens on at least 3 diferent wlans i usualy connect to.


    My mac is like this:

      Modellnavn:          MacBook Pro

      Modellidentifikator:          MacBookPro8,2

      Prosessornavn:          Intel Core i7

      Prosessorhastighet:          2 GHz

      Antall prosessorer:          1

      Totalt antall kjerner:          4

      Nivå 2-buffer (per kjerne):          256 kB

      Nivå 3-buffer:          6 MB

      Hukommelse:          4 GB

      Start-ROM-versjon:          MBP81.0047.B27

      SMC-versjon (system):          1.69f3



    Some wifi-info from my macbook under:


      CoreWLAN:          3.0 (300.9)

      CoreWLANKit:          2.0 (200.10)

      Menytillegg:          8.0 (800.7)

      configd-programtillegg:          8.0 (800.15)

      Systeminformasjon:          8.0 (800.1)

      IO80211-familie:          5.0 (500.15)

      Wi-Fi-diagnostikk:          1.1 (110.26)

      AirPort-verktøy:          6.1 (610.31)



      Korttype:          AirPort Extreme  (0x14E4, 0xD6)

      Firmwareversjon:          Broadcom BCM43xx 1.0 (

      MAC-adresse:          28:cf:da:f3:01:70

      Lokalitet:          ETSI

      Landskode:          NO

      Støttede PHY-moduser:          802.11 a/b/g/n

      Støttede kanaler:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140

      Våkne ved trådløs:          Støttet

      AirDrop:          Støttet

      Status:          Tilkoblet

      Gjeldende nettverksinformasjon:


      PHY-modus:          802.11n

      BSSID:          00:24:36:ab:59:28

      Kanal:          108,1

      Landskode:          NO

      Nettverkstype:          Infrastruktur

      Sikkerhet:          WPA2 Personal

      Signal/støy :          -50 dBm / -88 dBm

      Overføringshastighet:          216

      MCS-indeks:          13

      Andre lokale Wi-Fi-nettverk:


      PHY-modus:          802.11n

      BSSID:          00:24:36:ab:59:27

      Kanal:          11

      Landskode:          NO

      Nettverkstype:          Infrastruktur

      Sikkerhet:          WPA2 Personal

      Signal/støy :          -57 dBm / -78 dBm

  • Luke8400 Level 1 Level 1

    I'm quite disappointed in Apple. I bought a brand new MacBook Pro last weekend, and I'm also having this issue with no fix in sight. The wifi drops after a few minutes, and I have to turn it off and back on to get it working for another couple of minutes. I performed the latest software update, I tried all the fixes I could find, and nothing is solving this issue. I can't go back to Lion, and I can't do anything on my router because I don't have access to it.


    The only thing that does work? Installing Windows 7 and using that. Come on, Apple. This is no minor issue.

  • btgarret84 Level 1 Level 1

    Have you tried updating your wifi firmware? Worked for me.

  • roxan Level 1 Level 1

    Btgarret84, can you be a bit more specific: isit your router that you upgrade or something in your Mac? What model of router is it?



  • Bubarrak Level 1 Level 1

    I had problem with the wifi after I upgraded my iMac to mountain lion, and I tried several propsed solution to solve the problem, however, non of them had worked!


    Now check this out.... I have changed my router, which was old for a certain degree, and get a new one,,, Now,,, the wifi just works perfectly, and maybe even better!


    If your router is old,,, think about getting a new one...

  • neale121 Level 1 Level 1

    This is an Apple software problem without a doubt and hopefully a fix in a software update will be in the near future.

    I am using a Macbook pro mid 2010 and Airport Extreme 4th generation and never had a problem in Snow Leopard

    Wireless connection issues started after installing Lion and got progressively worse with Mountain Lion

    I have tried every suggested fix to no avail and my wireless connection will drop every time my Mac sleeps and when woken I always have to wait and enter my closed network manually which is highly annoying.

    To others out there with the same problem don't rely on help from Apple telephone support as they seem to be a clueless bunch these days with very limited technical expertise.

    Come on Apple get it together and own up officially to this major flaw and get it fixed pronto!

  • roxan Level 1 Level 1

    Hi Neale121, I am fully inline with you: this is ML sw issue, n doubt. his given said, there is no much chance to get it solve by complaining I te forums. I am quite surprised by the extended time the Engineers of apple are actuall tring to help over the AppleCare phone lines ...but they apparently are 100% disconnected from Apple forums that are getting that reputation of "complaining place only".


    The main issue  is that AppleCare is moving to denial mode and just tell customers "WEP is finished for OS X,  move to WPA". I have a difficulty to admit this and to throw to the bing quite a flew devices that are WEP-dependent., ,



    I am currentely doing a new attempt by fixe DHCP address and move away from DHCP.

  • neale121 Level 1 Level 1

    Finally I have my Wi-Fi working again in Mountain Lion

    I had posted before that I had tried various fixes without success but the following steps worked for me when I did them in the order below.Hope this may be of help to others.


    1. Make sure Wi-Fi is turned on but with no current connection to any Network

    2. Delete all Airport/Router Network Passwords that are stored in Keychain that are associated with your  wireless device

    Do a search for Keychain with Apple 'Spotlight

    Open Keychain Access and delete all Network Password certificates that are related to your wireless account

    You may have to enter your administrator password to unlock and delete files then exit


    3. Add a New Network Location

    • Open System Preferences from the  Apple menu and choose “Network”
    • Pull down the “Location” menu and choose “Edit Locations
    • Delete all locations listed except Automatic
    • Click the [+] button to add a new location, name it whatever you want (I used my chosen network name) then click Done



    4. Join Other Network

    • Back in Network System Preferences screen make sure Wi-Fi is selected
    • Click the “Network Name” menu and select 'Join other Network' enter your Network name and enter your password (if needed) in  the Security bar.

        (I  picked 'WPA personal' for my security setting)

    • Make sure Remember this Network is checked and click join


    At this point my wireless network was active 


    5. Renew DHCP

    • From the Network panel, click on the “Advanced” button in the lower right corner, then click the “TCP/IP” tab
    • Make sure “Configure IPv4:” is set to “Using DHCP” and then click the “Renew DHCP Lease” button, click “Apply” when prompted
    • The appropriate DHCP settings should be renewed from the connected router, click 'OK' and exit out of System Preferences.


    I also had read that the program Growl may cause issues so I have this turned off


    After completing these steps in this order I now have my Wireless back and reconnects automatically after sleep and after 24 hours no dropped connections.

  • btgarret84 Level 1 Level 1



    the wifi router.


    I've a tp-link TL-941ND wifi router, after I update the firmware the problem stoped.

  • paulduv Level 1 Level 1

    Router: D-Link DIR-615


    I've just resolved my Mountain Lion wifi problem. My problem was of the disconnect-every-few-minutes-particularly-while-streaming variety.


    What didn't work: every solution under the sun: changing the MTU setting in Network preferences, setting router to wireless-g, resetting stuff, restarting stuff...


    What worked was updating the router's firmware. The router's "check for updates" button doesn't report any updates available, but the D-Link website does.

Previous 1 3 4 5 6 7 Next