Previous 1 2 3 4 5 6 Next 75 Replies Latest reply: Apr 19, 2013 7:00 AM by cmalka92 Go to original post
  • john.23 Level 1 (0 points)



    same problem here. I identified the process "prl_disp_service" causing the delay in shutdown. When I quit that process in Activity Monitor, my Mac (retina MBP) shuts down immediately.

    Reported the problem already to Parallels, they are working on it.


    See also: 

  • mattgzx Level 1 (0 points)

    Thanks for sharing this, I deleted those Parallels-related files and now my MBP i7 quad late 2011 with ssd shuts down in 2 seconds, it was taking like almost 1 minute which was driving me crazy. I even deleted Parallels a long time ago.

  • ALV-AR-O Level 1 (0 points)

    I had the same issue, I cleaned up the LaunchDaemons folder, uninstalled and installed again parallels with the latest version and the problem persisted. I did a modification to the following file:




    Look at the <key>ExitTimeOut</key>, I reduced the value of <integer>150</integer> to <integer>10</integer>.


    I restarted the OS, and after the next boot the shutdown was normally (~1-2 seconds).


    I hope this help you.

  • Kaostheory7 Level 1 (20 points)

    This did not appear to work for me. After applying the amend - the system shut down was a lot better - but Parallels will no longer start until I reinstate the original Plist file.


    ... the search continues...

  • john.23 Level 1 (0 points)



    same here, changing the .plist is not recommend if you need a working Parallels.



    For all other:


    Can someone proof my solution mentioned above (quitting the process "prl_disp_service" in activity monitor before shut down)

    See also screenshot for the process.

    When I quit that process immediately before shut down, the system shuts down normal.process.jpg

  • ALV-AR-O Level 1 (0 points)

    I forgot something, do not copy/paste or replace the original .plist file, instead use nano in a terminal. If you replace the file, the permissions are replaced and the launchd deamon can't read the file.


    Try again, that worked for me.

  • leebros Level 1 (0 points)

    I'd tried your recommendation of "I reduced the value of <integer>150</integer> to <integer>10</integer>."


    It works only one time, which is the time when I shut down my MBA after making this change.

    Subsequence shut downs are still slow (15-20secs), though i felt that it is not as long as before (30-50secs) the change was made.


    However, my last shut down was back to the very slow state.


    Having said the above, changing the integer from 150 to 10 in the .plist file didn't seem to have caused any problem to my Parallel Desktops. Meaning, I can still run PD as per normal.

  • Scott Newman Level 2 (220 points)

    My shutdown time has increased on my 2011 MBAir from about 3 seconds to between 12 and 15 seconds. 


    For what it's worth, in my case, it's caused by several launch daemons from Carbon Copy Cloner.  Actually, I think it's caused by Mountain Lion, but I can temporarily stop the shutdown delay by deleting all of these launch daemons; however, as soon as I restore them, the shutdown delay returns.


    I had no problems in Lion, so I put this on Apple's shoulders, not CCC.

  • apple bytes77 Level 1 (5 points)

    Seems this thread has been hijacked by you parrallel users.  I also do not use parralels.  Not only has my shutdown gone from 8 seconds to 25, but my start up from off to opening a web page have gone from 45 seconds to 1:30.  I've checked all the popular remedies, but no dice.  Not sure what to do, as I dont think the update for ML will address this.  My boot and shutdown are scary close to my work PC (thinkpad piece of garbage)

  • Kaostheory7 Level 1 (20 points)

    @Apple Bytes77


    Try the Terminal fix "system-prelinked-kernel" trick posted by TEVillegas (page 2 of this forum) and do an SMC / PRAM reset. I had slow shut down and this solved the problem for me on both Snow Leopard and Lion installs.


    The Terminal commands I followed where:

    sudo chown root:admin /

    sudo kextcache -system-prelinked-kernel

    sudo kextcache -system-caches


    Unfortunately I am now one of the "Parallels Hijackers" so I'm waiting for a fix from Parallels


    Good luck

  • Scott Newman Level 2 (220 points)

    Here's another story and another fix:  I have two, mid2011, MacBook Airs (an 11" and a 13").  With the change to Mtn. Lion, my shutdown times went from 2-3 seconds to 12-15 seconds.


    When I examined my system log during the shutdown process, I noticed that a couple of different background apps related to printing to a Canon Advanced ImageRunner copier were trying to shut down.  I had completely forgotten that I had installed printing and faxing software a year ago in an experiment.  This  high-end machine is used by my workgroup at the college I work for and and I also have access to three different laser printers.  As it turned out, I didn't ever print to this copy machine.  Also, this software is of the the type where I don't get automatic update notifications.  And, the software was out of date.


    To make a long story short, I used FindAnyFile (my favorite search software) to locate all the Canon software on my two computers (I don't use any other Canon products) and then I deleted it.  Problem solved.  Since doing this, my shutdown times are now back in the 2-3 second range.


    What was particularly odd about this was that my system log was showing the shutdown process was finishing in about one second when the actual time for the screen to go black was 12-15 seconds.  In hindsight it seems apparent that the system was trying to shutdown the two Canon background apps but that they weren't quitting like they should.


    While I doubt that many users have Canon ImageRunner software installed, perhaps examine your system logs for apps (particularly backgroup apps) that are being quit in the shutdown sequence.  Then, do some investigating as to the source of these backgroud apps and whether the software sources are Mtn. Lion compatible.


    You can examine your system log by using the Console app in your Utilities folder (which is in your Applications folder).  To focus on the shutdown process, change your system clock to show seconds.  Do a shutdown while noting the exact time (with seconds) when you do the actual shutdown. (There's another more sophisticated way to accomplish this, but this works if you aren't familiar with Console.)  When you shutdown, have Console open and click the box to reopen windows when you reboot.  Wait a minute so that the shutdown time is significantly different from the bootup time.  Then, reboot.  Console will open again and begin examining the system log at the time you shutdown. 

  • softwater Level 5 (5,370 points)

    Yes, but there's a proper procedure for dealing with the prl_disp_service issue. See here:



    (ToU Disclaimer: this link to my site contains other links which promote my services as a technical writer)

  • john.23 Level 1 (0 points)

    Thanks for the advice softwater,


    but that didn't actually solve my problem. I tried those Terminal commands, but the shut down was still slow as before (40-50 sec).

    The process "prl_disp_service" works normal, I have no issues when working with my Mac. It just slows down the shutdown, and I don't know why. Just quitting it in activity monitor helps in my case... waiting for an update of Parallels.

  • Dave Drake Level 1 (0 points)

    I force quite the process you mentioned and my 2010 Macbook PRO with SSD shutsdown very fast. Hope Parallels fixes this with next update

  • apple bytes77 Level 1 (5 points)

    Hey Kaostheory7,


    No worries, understand, though some day someone needs to explain why you would want to run Windows on a Mac.  Isnt it the point have having an apple to get away from PC Windows?  I digress, that is another thread i'm sure.  Anyway, I have tried the terminal listed, and unless I did it incorrectly (1st time terminal user), it did not seem to work.  Anymore ideas are welcome.  I may have to hope the update fixes this, as I do not want to vist a strore to see the G bar