Previous 1 2 3 Next 102 Replies Latest reply: Sep 26, 2013 12:25 PM by manomuse
jbwhitehurst Level 1 (0 points)

I've got a late 2007 iMac.  I downloaded Mountain lion and the installer began, but then abrubtly quit with the message "Installation Failed".  It mentioned there was a disk failure and that I should run the disk utility.  I ran verify disk and it failed, so I then ran Repair disk and it also failed with the following error message:

 

Incorrect number of file hard links

Bad hard link creation date

(It should be 3273005659 instead of 3314922810)

Hard link record has data extents (id = 33147751)

Error: Disk Utility can't repair this disk...disk, and restore your backed-up files

 

Now any time I reboot the installers appears like it is going to start, but immediately pops up the message "There was a problem installing Mac OS X.  Try reinstalling."   Its an endless cycle.

 

Any ideas on how to fix this?  If it is going to require reformatting the drive, is there any way to copy all my existing files off onto an external hard drive?

 

Any help would be much appreciated!!


imac, Mac OS X (10.5.2)
  • mah dew Level 1 (5 points)

    Sounds like your hard drive may be experiencing failure.  If your iMac came with recovery CDs you may want to run the hardware diagnostics on it.  If you don't have those CDs, I'd recommend taking it to an Apple store to have them run a hard drive test.  IMO, you will need to replace that hard drive.  Data recovery can be iffy on a drive with hardware issues, but not impossible.

  • jbwhitehurst Level 1 (0 points)

    Thanks for the reponse.  My hard drive has been working fine up until the mountain lion installation last night.  Do you  have any links to articles describing data recovery options?  If I could just boot back to Lion I could move everything off and then reformat.

  • joelohr Level 1 (0 points)

    I am having the same issue, I can't imagine it being a bad hard drive. I just bought a new hard drive not even a week ago and successfully installed Lion on it with no problems.  I need a fix to this as well, I can't get out of the installer!

  • a_m_b Level 1 (0 points)

    Same problem, too.  Working just fine beforehand.  Hope to get some answers.

  • hamijoh Level 1 (0 points)

    Same problem. Worked fine prior...

  • jerikofox Level 1 (0 points)

    Same thing here.  I was unable to run the disk repair (the button was inactive), so I tried to boot from DVD and now my iMac won't start up at all anymore.

  • elsa perez Level 1 (0 points)

    I had the same problem. I'm taking it in saturday to see what the genuis bar can do. Everything has always worked perfectly on my 3.5 year old MacBook up until this point.

  • noblewb Level 1 (0 points)

    Mountain has sidelined my MacBook pro December 2008 pre unibody. The same condition as everyone responding.... APPLE HELP

  • jerikofox Level 1 (0 points)

    Okay, I googled and googled and ended up doing this with my (still working) MacBook Pro:

    http://osxdaily.com/2011/08/08/lion-recovery-disk-assistant-tool-makes-external- lion-boot-recovery-drives/

     

    I succeeded to start up my iMac and then tried to do disk repair for my HD.  I ended up with red warnings telling me that my HD cannot be repaired and must be erased.  I kept on praying the ghost of Steve Jobs to make sure my Time Machine clone would be unharmed.  Before erasing I decided just give it a try and clicked one more time the repair button.  And suddenly I got all green and disk was successfully repaired.  Just to be sure I did that one more time and then scanned the HD.  Still all green.

     

    Now I'm trying to upgrade to Mountain Lion once again...

  • jackfrombeaverton Level 1 (0 points)

    I was having the exact same trouble and resetting PRAM resolved the issue for me.  Hope it works for you guys.

  • jerikofox Level 1 (0 points)

    I'm starting to be pretty sure that the root of all evil is the ML-upgrade file.  I repair my HD, all fine, I try to install ML, it fails, I repair my HD again...  I've jumped these hoops quite a few times now and no matter how many times I repair my HD I'm unable to install ML.  But now I'm able to use my iMac (with Lion) again and I guess that's good enough for today.  I guess next I'll try to download ML again and see if this file was corrupted.

  • jerikofox Level 1 (0 points)

    I finally succeeded after resetting PRAM too.  Thanks Jack!

  • a_m_b Level 1 (0 points)

    I'm still looking for that Steve Job's magic.  Still not working.  Each time the DU says ..."can't repair this disk.  Back up as many of your files as possible, reformat the disk,..."

     

    Besides erasing the disk, any suggestions?

  • hamijoh Level 1 (0 points)

    Same issue for me a second time through. I managed to get snow back and access to my computer by putting in the old OS x install disc, stopping the install and shutting down, then restarting. Worked twice. Apple has an issue here...

Previous 1 2 3 Next