Previous 1 3 4 5 6 7 Next 102 Replies Latest reply: Sep 26, 2013 12:25 PM by manomuse Go to original post
  • Jnanesh Level 1 Level 1

    adarjo0422 wrote:


    I had the same problem that has been described through out this thread, and I have solved the problem, and the HDD did not fail as stated by Apple to many people.  The HDD was corrupted by the Mountain Lion installer.  I will describe how I got the information off my HDD on a fresh installation of ML.


    1. After the original install, I got the installation error and the bad HDD messages.  I do not need to go into that here as it has been described by many.
    2. The macbook pro was stuck in the installation / error loop every time I restarted the computer.
    3. I attached an external drive to a USB port and rebooted.
    4. The installation window came up again.  I went to disk utilities, picked the external drive and partioned for new ML OS installation.
    5. Once the partitioning was complete, I exited disk utilites and started the ML install process again.  Once it gave me the HDD choice, I chose the external HDD attached to USB
    6. Once the installation was complete, ML installer gives you the choice of migrating information from time machine or and old system.  My internal HDD was the corrupted drive and still in the computer.  This HDD showed up in the migration assistant.  I chose it, and after 2.5 hours all the data was migrated to the new drive.
    7. I then removed the corrupted drive from the MB Pro and installed the new HDD with the fresh installation.
    8. Booted up and all data, applications and settings were as is running in ML


    If you are not familiar with changing the HDD in your model, go to and enter your mac specs, and it will give you a step by step guide.


    5th point says that the installer gives you the choice of selecting the hard drive. But unfortunately I am unable to see such option. Everytime the machine is restarted, it is going by default to internal hard drive of my mac. Can anybody please flash some light on this?


    Also as I am facing this issue just now. and this discussion is 2 months old. Does anybody know if apple has come up with a 'proper' solution to this problem?




  • Engender Level 1 Level 1

    I was having this problem during my initial install of Mountain Lion from Lion on my Mac Pro, and here is what I did:


    1. Used Carbon Copy Cloner to copy my internal Macintosh HD to an external drive, connected by Firewire.

    2. Made sure to create a "Recovery Partition" following the Carbon Copy Cloner instructions, on my external drive.

    3. Booted into the Recovery Partition on my external drive.

    4. Used Disk Utility to erase my interal Macintosh HD, using the "Security" options on a "Single Pass" (this will get rid of any bad sectors on your disk).

    5. Used Carbon Copy Cloner to copy my system from the external HD to the internal Macintosh HD.

    6. Installed Mountain Lion.


    It takes some time, but you'll get all of your data on your new ML system. Plus, everyone should have a "clone" of thier system disk handy for situations like this!

  • macfrombrampton Level 1 Level 1
    Mac OS X

    Did the App Store recoginize the download was not successfull? and If so How can you be sure the downloaded application Mountain Lion is not corrupted?


    i have not downloaded M.L. because no media disk have been provided. Are you able to produce Media disks for reinstallation?

  • rugbyhubby Level 1 Level 1

    Dutchboy - followed your directions to the tee and everything worked fine.  I'm surprised at the number of people that had the problem with this upgrade as I've grown to expect this from pc but not Mac (I'm only on my third Mac OS). I've since created a recovery disk!


    Thanks for the clear and concise directions.

  • pjmail64 Level 1 Level 1

    Hi - Thanks for the posts - I had a similar problem.  I downloaded Mountain Lion installer to Macbook running Snow Leopard (OS 10.6.8, fully updated).  The install failed within 5 minutes at the 32 or 34 minute remaining mark stating the Harddrive was corrupt and must be repaired.  When you accept this message, it throws you in an infinite loop re-starting the installer and failing everytime with the same haddrive error roughly at the same spot (yep, i tried it many times).  Regardless what Apple says, I believe the installer was causing the harddrive to "appear" corrupt but is not actually corrupt.  After reading all the posts, I was able to us Disk Utility to fix it and get around the issue using these steps:


    1.  I had time machine backup (just in case).

    2. Using Snow Leopard install disc (SL), booted my MacBook from disc (insert disc, start computer and hold down 'C' key until it starts from disk).

    3.  From the SL disc, used disk utility to first verify disc (from Apple Menu, choose disk utility) - yes it came back and reported and error.  Then using the same disk utility, use the "repair disc" option.  This took a while, but was successful.

    4.  Shutdown and rebooted machine from internal harddrive (just as you would do normally).

    5.  Ejected SL disk.

    6.  Next, rather than just try the install again from my harddrive.  I used the disk utility to reformat a new USB jumpdrive to Mac OS Extended (journaled) format.  Once finished, I dragged the Mountain Lion instaler onto the new USB jumpdrive.

    7.   From the USB jumpdrive, doubleclick to begin the Mountail Lion installer.

    8..  It will ask where you want to install - choose your MacDrive (your internal harddrive).

    10.  Installer ran a little over 30 minutes (note it will count down, and sometimes go back up, but eventually finishing).

    11.  Mountain Lion installed successfully, restart and begin configuring the new features (icloud, mail,messagin, etc.)


    So far seems to have worked.  thanks.

  • landerosv Level 1 Level 1

    How did you reinstall snow back

  • Poiesis Level 1 Level 1



    First of all I'd like to thank all the people that posted on this thread as it helped me a lot finding a solution to this problem : installing Mountain Lion and getting lost the internal hard drive.


    My internal hard drive had two partitions: one for the system and the other for my data (iTunes and iPhoto library).


    Here's what happened to me and how I recovered my lost data.

    2 days after installing Mountain Lion, my iMac 2007 went so slow that I had to reboot few times. After 4-5 reboots it fall down and could not start properly: extremely slow, rebooting itself, etc.


    I tried many of the well known procedures at system start up with no results.


    Finally I made a recovery using Time machine, which achieved succesfully. But I couldn't get back my datas on my internal hard drive wich had permanent errors using the Disk utility. I tried Disk warriors, Disk drill and many others. The only utility that could see my lost files was Disk rescue 3. But the problem is that it was saying it would need more then 6000 hours to revover my files (160go).


    I tried then to boot form a Mountain Lion disk because the disk utility is version 13 vs 12.1 in Lion, believing it could repair my drive. It didn't solve anything.


    So I unmounted my Data partition and boot on my Time machine backup (Lion).


    Started Disk recue 3 again with a quick scan which went really fast and then recovered all my files.


    It could have worked with other utilities but I didn't tried. You know when it starts recovering the files I just get my hands off and wait until it's finished.


    So unmounting the corrupted drives may be an option for those how got the same problem with internal hard drive.


    Of course, my personnal data will now get a backup in Time machine.


    Hope this could help.

  • InspiredLife Level 1 Level 1
    Mac App Store

    Well, I hate to say it, but I am glad to see so many other people had this issue, and that some have resolved it. I'll start trying the proposed solutions shortly.


    I have two computers. 2010 MBP 17", and a 2011 MBAir.

    Install the ML onto the MBP with no issues (well, except that the new Apple Notes has made it impossible to see nearly all the notes I had stored in Mail... they don't show up on the new Notes app. But that's another issue, with another workaround, despite lack of support from Apple on the issue).


    I then installed on the MB Air... and the computer restarted and launched into the OS X installer. That failed... and the rest is history. Same issue as the original posted. OS reports the HD is dead and needs to be erased. Disk repair shows the following

    Incorrect number of file hard links

    Bad hard link creation date

    Hard link record has data extents (id = 5828272)

    The volume Machintosh HD could not be verified completely.

    Error: Disk utility can't repair this disk... blah blah blah... Back up what you can... reformat and restore your backed-up files


    It fails to realise I can't back up anything because the drive is dead.


    Shall report here which, if any, of the workarounds work for this computer. Basically the Mountain Lion killed my  Lion.

  • InspiredLife Level 1 Level 1
    Mac App Store
    • Tried the PRAM reset. No luck... no change.


    Here is what worked:

    • I installed OS X 10.8 to an external drive, from another Mac (the MBP which the Mountain Lion fortunately decided not to eat for lunch during its so-called "upgrade").
    • Booted the dead MBAir from the external HDD over USB.
    • Used the migration assistant to recover all user data from the internal HDD. That took a couple of hours.
    • Erased the internal HDD
    • Installed OS X ML onto the internal HDD
    • Did a repair permissions on both drives (both OS X installations)
    • Used Carbon Copy Cloner to clone the external OS X drive to the internal one


    Wasted a good day of my time, but glad to have got around this hideous bug in the Mountain Lion installer.

  • macfrombrampton Level 1 Level 1
    Mac OS X

    Because you got a number of hard link errors on your drive, how do you know the downloaded ML was not corrupted? Does Apple provide ainstallation check or MD5 hash?

  • apps2012 Level 1 Level 1

    Apple needs to stop this madness. I had the same problem after the upgrade and Apple just replaced the hard drive. I met another customer at Apple store and he had the same problem after the Mountain Lion upgrade. This cannot be coincident. Apple needs to do something about this. Where is the QUALITY product that Apple use to be?.......

  • mongmuncher Level 1 Level 1

    Installed the latest 10.8.2 software update on my early 2011 mbp on 12th october


    install came up with the message 'installation failed'


    mac restarted to show a glitchy desktop, in grey with blacked out icons. I had to force shut down the laptop.


    laptop wouldnt start up


    then got into the disk verify/repair disk red text saying I should back up my data and wipe the drive.


    genious bar said all they could do is format the drive. utterly useless.


    mac specialist installed a new harddrive and tried to migrate the data across, this was unsucsessful. managed to transfer my important files (1gb took 8 hours to transfer)


    it seems to me that this update has completly fried my hard drive.


    its cost me £60 for the data, £90 for a hard drive and now £100 to send my hard drive to a data recovery centre. all for 1 months worth of files that were not backed up.


    I feel like sending Apple a bill, not to mention the stress its caused me and now im left with a laptop that isnt even running mountain lion and I never got a OS cd with my £2000 laptop!


    apple is not what it used to be

  • Pejvan Level 1 Level 1

    After a whole week of struggling; and buying a new hard drive and another more week of struggling, it appears that the xar_verify failed on Essials.pkg was resolved when I removed my 2x8Gig RAM DIMMs and replaced them with the original, apple provided 2x2 Gig RAM DIMMs.


    Do you by any chance have any other RAM than the Apple provided ones? You are most likely facing the same issue...


    Hope this helps!

  • InspiredLife Level 1 Level 1
    Mac App Store

    I have 2x 4GB DIMMS in my MBP.

    I've had them in there since I got the MBP in May 2010. Never had an issue with them. They are high quality ones (I forget the brand, but not cheapies), and classed as 100% capatible (Apple use the same ones, from what I recall). On the MBP I had NO DRIVE issues updating to ML.


    On the MacBook Air there is just the standard memory that Apple sell it with. That computer was eaten up by the Mountain Lion. See my earlier post.


    So at least in my case, this issue was not due to third party memory.





  • Pejvan Level 1 Level 1

    Well, I also have high quality Crucial RAM; it did not install nonetheless.

    I would recommend you run the Apple Hardware Test if you can (see: and share the results to help investigate further?

Previous 1 3 4 5 6 7 Next