Previous 1 11 12 13 14 15 16 Next 235 Replies Latest reply: Jul 25, 2013 1:42 AM by stevefromorpington Go to original post
  • dedge.guarim Level 1 (0 points)

    Hi Folks,


    I'm using a MBP13 Late 2011 OSX 10.8.2.

    I upgraded some months ago but the problem only appeared recently. The connection is extremely slow and sometimes drop the connection, even if the wifi icon on the bar is "full".

    On the same room of the router, connection is fine, but distant is too slow. I have noticed also that when a wireless phone working on 2.4 band rings and some answers it, the wifi drops, and it will be restored when the person hangs up.


    I have run tests changing MTU 1400, Channel 11, New DNS, none of this worked.

    But the Bluetooth ON with the Magic Mouse after 20 minutes begin to cause interference.

    What i notice with iStumbler and with the Diagnostic Wifi Tool buil in on ML is that:

    Router is set on a specifc channel, for example, channel 11.

    When Bluetooth is OFF, the speed of my connection is normal and MBP reconizes as the channel 11.

    When Bluetooh in ON with Magic Mouse, the computer does not recognize which channel is, and shows that is connected on Channel 1. I think this is because of the interferences Bluetooh causes.

    I will not buy another router, this is wrong, everything worked fine some months ago. But i'm think of buying a wired mouse, but the speed of my work will decrease significantly.


    Hope this helps.


    Bruno Redondo

  • stevefromorpington Level 1 (0 points)

    OK, I have done as you suggest and reported the problem through and suggested they look at this thread from Jan 15th 2013 entries onwards.


    Let's hope they start taking it seriously.

  • Yaann Level 1 (10 points)

    Like everyone, WiFi connection on ML have been hugely frustrating for me, unusual for apple to screw up like this.


    I found this post and have to say 1. has worked (so far), and the disturbance really improved



    Maybe something worth trying (you  may loose settings for various connections so note them done, but it seem some old Lion network settings files do not work well in ML, so trash+reboot helped!)


    Good luck all, let;s hope ML will be soon fixed once and for all!

  • GVR53 Level 1 (0 points)



    I first posted my issues about dropping wifi after ML upgrade late last year.

    I had a Seimens Gigaset SE551 router. Never had problems dropping wifi before the ML upgrade.

    My solution has been to plug directly to wired ethernet connection while at home.

    I have been watching posts on this subject waiting for solutions, or news that Apple has released a fix.

    I noticed that after recent OS upgrades on my iphone and wife's iphone, they too started dropping the wifi. The signal strength always looks fine. They were perfectly fine with older OS.

    Only solution in past to re-establishing wifi connection has been to unplug the router from power source, and plug in again.

    On Tuesday this week I bought a new ipad with retina display etc. Got it home, set up, and it immediately starts dropping wifi. Needless to say i was rather annoyed.

    I have refused to go out and by a new router before. Why should I when it has always worked perfectly fine until recent Apple OS upgrades?!

    After issues with new ipad, i went into town 2 days ago, vented my frustration in an Apple store, and then bought the airport express router. Since installing 2 days ago MacBook pro and all other devices have maintained wifi connection without fault.

    Conclusion: Happy that i have reliable wifi again, very upset that i had to go and buy an apple router. Feeling like something smells about this. There was nothing wrong with my Seimens router until recent Apple OS upgrades. Convinced this has always been, and continues to be an Apple problem.

  • Zacharias Beckman Level 1 (100 points)

    I will be surprised if buying the Apple router fixes your problem permanently. If you still haven't had any problems after two weeks, I'd love to hear about it.


    We have four different wifi Apple routers (two Airport's and two Extreme's). They cover the entire office area. People with newer/fully upgraded Apple computers still experience intermittent wifi problems... but none of our Windows and non-Apple users have the problem. Our VOIP system and other devices stay online. It is only the poor folks with newer MacBook Pros or recent model/fully upgraded Macs that have the problem. At the same time we have some older Macs that do not exhibit the problem ever. Based on these observations we have come to conclude it is 100% a problem the either 1) recent O/S updates, 2) recent Apple hardware or possibly, 3) the combination of both of these.


    The really frustrating thing is, once my own MacBook Pro Retina loses its wifi connection, it's very hard to get it back. Even after a reboot it often does not come back. Recently I've takent to doing a reboot along with PRAM reset, and that seems to solve the problem -- but OMG what a bloody pain. I can't believe Apple is still ignoring this issue after so many people have reported it, and so much time has gone by. I'm just hoping it can be fixed. My fear is that it's a permanent hardware issue that would require a new chip (or something like that)... and who knows if Apple would bother with a hardware recall. Bah.

  • RoxyAngel7 Level 1 (10 points)

    I was having the same issues as everyone else after I upgraded to ML on my iMac. After months of trying to troubleshoot it, I went out and bought a new Apple router and haven't had any issues since.

  • 3gs LS Level 1 (0 points)

    Amazing how buying more Apple hardware "fixes" the problem.

  • trainengine Level 1 (0 points)

    Wifi drop out started a couple days ago on my 4 week old retina macbook pro. Rebooting the macbook and recycling the wifi adapter did nothing to solve the problem. The others devices (new Mac Mini, a Windows 7 lenovo x220i, an XP Pro lenovo x200, 2 iPhone 4Ss and an iPad, two game wardens and a cow ) did not experience any connection drop outs. A couple of days ago Apple updated the firmware on my 1 year old 2TB Time Caplsule to V7.6.3 so I decided to restart it. The problem disappeared (so far).

  • mikewest Level 1 (0 points)

    Same problem with mid-2009 MBP.  Tried replacing network kext with Snow Leopard versions.  Eventually resorted to wiping and re-installing Mountain Lion from scratch. This seemed to work for about 1 day before we got the 'WiFi appears to be on, but is actually off" situation. 


    Apple's really not leaving us with an option other than not buying Apple products.


    I have not seen this issue with my Mount Lion or Snow Leopard mid-2012 MBP's; only with the mid-2009 laptop running Mountain Lion.

  • este.el.paz Level 1 (90 points)



    Interesting, seemed like there were some "solutions" posted on this thread that seemed to fix the problem . . . the thread has been dormant for awhile.  One of them involved problems with bluetooth mouse signal interfering with the wifi signal.  But, I have a early-mid-MBPro 2009 as well, and at the time I thought 4GB RAM would cover everything I would ever need, but following some threads about making the decision to move from SL to ML, it seems like the wisdom is that 8GB or more is needed to really run ML at optimum . . . I've decided that I'm leaving the MBPro with SL, until possibly I get a bank loan to upgrade the RAM; and wait until I procure a newer desktop with 16 GB RAM . . . before moving to ML.  Actually SL is perfectly fine OS, it runs the computer very well, and it's very stable.  To handle falling behind the technological wave in terms of the OSs, I have a dual boot OSX and Linux MInt system, soon to possibly be Xubuntu 12.04 64 bit system--and over in the Linux side there are long term support system updates . . . free . . . .



  • gsspike Level 1 (0 points)

    It's coming on 2 years I've had this problem and it started with Lion.  I spent hours on the phone with Apple engineers.  Six months ago it started to only act up every few days.  Well in the last month or so sometimes it doesn't work right at start up.   Most days I reboot every few minutes to get anything done again. 


    The amount of time this issue has gone is a disgraceful.  Why is the press letting them get away with this!!!


    I Had to vent.



  • mikewest Level 1 (0 points)

    The system I'm using has 8GB of RAM.  Some one asked why I'm bring this up now.  It's because I upgraded about a month ago (to ML) and it took me a while to conclude something is wrong with the OS.

  • este.el.paz Level 1 (90 points)

    If you mean me, no I wasn't asking why you bring it up, just that it seemed some people posting here had found solutions, like even on this page at the top is the person talking about bluetooth signal interference and "Yanaan" posting a link to where he found solutions . . . .  I was looking recently to see if the 10.8.3 upgrade addressed this issue, but it appears that it might not . . . .  I personally am opting to not do ML in my MBPro, specifically because wifi capability is important to my workflow using the laptop . . . and now not having enough RAM to properly run ML . . . even if the wifi problem passed over my particular mid-2009 laptop--because it has the special symbol, etc.  But, if Linux is too steep a learning curve, you can always downgrade to SL . . . maybe there should be a "Downgrade your OS" movement . . . a retro-technology movement from within . . . .  Go back Apple users, back, back, back to SL . . . . : - ))

  • mikewest Level 1 (0 points)

    I have many computers, and am an experienced Linux developer.   My wife upgraded to Aperture 3.3 which requires Mountain Lion.  So I can't simply switch to Linux or SL, without migrating a 11,000 photo database to a new system. 

  • este.el.paz Level 1 (90 points)

    I understand that the purchase of the OS provides some tech support, so it might be worth calling them just to jangle the corporate chain; but it doesn't seem like Apple is doing the heavy lifting on this problem . . . so you probably going to have to find the solution.  I've mentioned a couple times that this thread might have some answers for you, but haven't heard any reply on that . . . have you read through at least the last several pages here and tried out the various options mentioned?  If none of that works, there is always hard-wired connection . . . or probably any of the phone company USB dongles . . . it's "not right" but if you're stuck with the OS then you're going to have to work something out.  It's not like in the old days when we shelled out $130 for an upgrade and then it broke . . . $19 is . . . much more "affordable" . . . .