Previous 1 16 17 18 19 20 Next 1,489 Replies Latest reply: Nov 18, 2015 3:46 PM by cmcqueen Go to original post Branched to a new discussion.
  • MacConv Level 1 (10 points)

    I was unable to boot into Win 7 on my MacBook Air. Having followed Christopher Murphy's instructions exactly, my problem was solved. Hooray for Chris!! But having fixed one problem, another one popped up. I am now unable to see nor access my HFS+ Mac side from the Windows side, whereas before I could access my files seamlessly (using MacDrive). Windows says that the partition is GPT protected (healthy).


    Chris, how can I recover my access to the Mac partition from windows? This is what it looks like:


    Disk: /dev/disk0geometry: 30515/255/63 [490234752 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]


    1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>

    2: AF 1023 254  63 - 1023 254  63 [    409640 -  371005688] HFS+       

    3: AB 1023 254  63 - 1023 254  63 [ 371415328 -    1269536] Darwin Boot

    4: 0C 1023 254  63 - 1023 254  63 [ 372686848 -    9852928] Win95 FAT32L


    #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *251.0 GB   disk0

       1:                        EFI                         209.7 MB   disk0s1

       2:                  Apple_HFS Macintosh HD            190.0 GB   disk0s2

       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

       4:       Microsoft Basic Data WIN FILES               5.0 GB     disk0s4

       5:       Microsoft Basic Data Windows 7               55.1 GB    disk0s5




    To get 100 points, I have a third partition (called Win Files) which I created with Mac's Disk Utility. I want to be able to access it from the Windows side... no need to have it be a boot drive. Can you help me with that too? An answer today would be most appreciated.



  • Christopher Murphy Level 3 (555 points)

    You can't do what you want to do safely, so to make it work you'll have to take a risk that one day your Recovery HD will become corrupt and unusable. The reason is MBR can only contain four entries, and one must be used for the EE entry and one must be used for the bootable Windows entry. This only leaves two entries, and in between them is Recovery HD. So while you can add Mac OS X and WIN FILES entries, you no longer have room to protect Recovery HD. Those sectors will effectively be Free Space in the MBR, so anything that honors the MBR will see the Recovery HD as free space and can do anything to it it wants.


    Using gdisk you need to make a new hybrid MBR and add partitions 2 4 5 marking 5 as bootable.


    BTW saying that an answer today would be appreciated I find rather rude.

  • MacConv Level 1 (10 points)

    Hi Christopher,


    Thanks very much for your advice. It was right on. I'm sorry you took offense to my requesting an urgent answer, if possible! I just wanted you to know that it was a mission critical issue for me so thanks again for your timely help. I am always grateful to people like yourself who have the knowledge and are willing to put in the time to help out community members facing technical problems.


    This solved my question - 10 points

  • Charaity Level 1 (0 points)



    sorry to bother you but i have a similar proble to the op


    I use to have bootcamp to dual boot windows 8 and osx lion. BUT I wanted to triple boot all that along with windows 7. I stupidly used the disk utility to split my macintosh hd into 2 partitions and now i lost my bootcamp (when i press "alt" and bootcamp menu appears, the windows 8 icon not there).


    anyways i tried following your steps but my results are different to the op.Screen Shot 2012-11-26 at 7.28.44 PM.png


    for the commands, these are my results:


    for "sudo gpt -r -vv show disk0"


    gpt show: disk0: mediasize=500107862016; sectorsize=512; blocks=976773168

    gpt show: disk0: Suspicious MBR at sector 0

    gpt show: disk0: Pri GPT at sector 1

    gpt show: disk0: Sec GPT at sector 976773167

          start       size  index  contents

              0          1         MBR

              1          1         Pri GPT header

              2         32         Pri GPT table

             34          6        

             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

         409640  515423320      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

      515832960    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

      517102496   68562016        

      585664512  391108608      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      976773120         15        

      976773135         32         Sec GPT table

      976773167          1         Sec GPT header


    for "sudo fdisk /dev/disk0"


    Disk: /dev/disk0geometry: 60801/255/63 [976773168 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]


    1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>

    2: AF 1023 254  63 - 1023 254  63 [    409640 -  515423320] HFS+       

    3: AB 1023 254  63 - 1023 254  63 [ 515832960 -    1269536] Darwin Boot

    4: 0C 1023 254  63 - 1023 254  63 [ 585664512 -  391108608] Win95 FAT32L


    i was wondering if you could help me. Thank you

  • Christopher Murphy Level 3 (555 points)

    There is no Apple supported way to do what you want. But to at least regain access to Windows you need to use gdisk to create a new hybrid MBR, adding partitions 2 3 4, and making the 4th one bootable.

  • Charaity Level 1 (0 points)

    ok thank you for your reply.


    Unfortunately Im only use to windows, so I have no idea how to do what you said. Could you please give me a bit more detailed answers. THanks alot .


    i've been doing some research and it seems that if i insert a windows 8 disk into my macbook pro, and then select repair system in the boot menu, this would solve everything. Should I do this? I don't want to screw my macbook up more

  • Christopher Murphy Level 3 (555 points)

    The bulk of this thread has to do with using gdisk to create new hybrid MBRs. A more useful basic summary of hybrid MBRs is found here including the documentation for creating a new hybrid MBR. Windows startup repair might fix some other problem, but I don't know if partition type code 0C is considered valid or not. For sure that partition isn't marked as bootable right now.


    Eventually you're going to have to either learn a lot more than you probably want to about disaster recovery on a multiboot system, or you're going to have to erase the hard drive and start totally from scratch, restoring your data from backups. But if you're going to triple boot you need to know something about these things anyway because there is no supported way to do this on Apple hardware. You'l have to hack your own hybrid MBR because the provided tools will not do this for you, in fact they will attempt to erase your hybrid MBR once you have more than 4 partitions in the GPT.


    OS X by default needs three partitions. Each Windows needs 1. That's 5. There aren't enough entries in the MBR to give everything a unique MBR entry. You could consolidate the GPT, EFI System, OS X, and Recovery HD into the MBR's 0xEE entry, and then you'll have room for Windows 7 and Windows 8 in the MBR. But you will not be able to mount the OS X volume from within either Windows.

  • Charaity Level 1 (0 points)

    Ok cool.


    So I have decided that its too much of a hassle for windows 7 and 8 long with osx lion.

    Now i just want my laptop back to the way it was before. (lion and win 8 only)


    So I tried to repair the mbr table thingy.

    i typed in "sudo gdisk /dev/disk0" to go into interactive mode but its giving me an error:


    "sudo: gdisk: command not found"


    I dont know what to do from here. i was planning on having a defaullt mbr (like apple).


    By what exactly did I do worng? I dont get how splitting my macintosh HD by creating another partition from that, deleted my acess to windows =/

  • Christopher Murphy Level 3 (555 points)

    1. Suggest you try to recover the free space before you do anything else. Post the results of this command.

    diskutil resizevolume limits


    2. GPT fdisk is found here.


    3. By what exactly did I do worng? I dont get how splitting my macintosh HD by creating another partition from that, deleted my acess to windows =/


    Like I said, MBR only allows four entries. Three are used for OS X. There is only one left for one instance of Windows. By adding a fifth partition, Apple's tools remove the hybrid MBR in favor of a protective MBR, which removes access to Windows. That they let you add a fifth partition, actually that they let users modify a "Boot Camped" disk at all, is a violation of their own Technote which says such disks are no longer valid GPT disks and should not be manipulated at all. So in my opinion it's an Apple bug, and I have filed a bug report on it.


    Preferable would be for Disk Utility to refuse to do anything to a disk that has been "Boot Camped" and the only way to revert with GUI tools is if Boot Camp Assistant is run again, and the Boot Camp/Windows partition is deleted first. At least this would be willful, intentional removal of Windows, rather than inadvertent removal. It would also prevent a host of other problems that I think are the source for some of the more obscure problems people have where they lose a single Windows volume in the course of upgrading OS X.


    Anyway, a word of warning for all Boot Camp users is that it's even MORE important for you to regularly back up important files from both environments, especially before making any modifications to either the OS version or the disk layout.

  • Charaity Level 1 (0 points)

    "diskutil resizevolume limits"


    Usage:  diskutil resizeVolume MountPoint|DiskIdentifier|DeviceNode size

            [part1Format part1Name part1Size part2Format part2Name part2Size

             part3Format part3Name part3Size ...]



    Non-destructively resize a disk.  You may increase or decrease its size.



    When decreasing size, you may optionally specify new partitions to create

    to fill the newly-freed space.  Specify these new partitions as in the

    diskutil partitionDisk command.  Ownership of the affected disk is required.



    Valid sizes are floating-point numbers with a suffix of B(ytes), S(512-byte-

    blocks), K(ilobytes), M(egabytes), G(igabytes), T(erabytes), P(etabytes),

    or (%)percentage of the total size of the whole disk.



    A size of "limits" will print the valid range for the current conditions of

    the file system and room to grow up to an immovable object (next partition).



    A size of "R" for the target partition will resize it to the maximum

    possible; "R" cannot be used for the size of new partition triples, if any.



    resizeVolume is only supported on a Journaled HFS+ file system.

  • mncrnich Level 1 (0 points)

    My problem seems parallel with this thread.  I am hoping a smarter person than I on this thread can lend a hand.


    I have dual boot MacPro5,1.  OS X 10.7.5 on one HDD, WIN7 on the other HDD.  I went to clone my "MASTER" WIN7 to another drive.  Unfortunately the "ALT" drive was not clean, it had a copy of WIN7 as well.  My computer booted into this "ALT" WIN7 and scrodded my "MASTER" WIN7.  I can no longer boot into my "MASTER" WIN7, even when I remove "ALT" WIN7 drive.  It seems like something changed on the "MASTER" WIN7.  Something with it's boot record or flag.  It seems awefully close to the problems in this thread. 


    Here are the outputs from the various commands:


    macpro_09:~ scorp$ sudo gpt -r -vv show disk3


    gpt show: disk3: mediasize=500107862016; sectorsize=512; blocks=976773168

    gpt show: disk3: MBR at sector 0

          start       size  index  contents

              0          1         MBR

              1         62        

             63  468840897      1  MBR part 7

      468840960       1536        

      468842496  507926528      2  MBR part 7

      976769024       4144




    macpro_09:~ scorp$ sudo fdisk /dev/disk3

    Disk: /dev/disk3          geometry: 60801/255/63 [976773168 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]


    *1: 07    0   1   1 - 1023 254  63 [        63 -  468840897] HPFS/QNX/AUX

    2: 07 1023 254  63 - 1023 254  63 [ 468842496 -  507926528] HPFS/QNX/AUX

    3: 00    0   0   0 -    0   0   0 [         0 -          0] unused     

    4: 00    0   0   0 -    0   0   0 [         0 -          0] unused



    macpro_09:~ scorp$ sudo gdisk /dev/disk3


    GPT fdisk (gdisk) version 0.8.5



    Partition table scan:

      MBR: MBR only

      BSD: not present

      APM: not present

      GPT: not present






    Found invalid GPT and valid MBR; converting MBR to GPT format.


    you don't want to convert your MBR partitions to GPT format!






    Command (? for help):

  • mncrnich Level 1 (0 points)

    After spending a good hour reading this entire thread, I found a solution which worked!  Thank you Christopher Murphy.



    It's important to use chkdsk again with /f because the journal may say the file system is clean when it isn't. So give /f a shot and see what happens.


    Next read this. You may have to click on the link to show more information. It's not exactly clear what order they want you to try this in, I would do the following three in order all at once, then try a reboot.






    If those don't work, then I'd try this:


    bcdedit /export C:\BCD_Backup


    cd boot

    attrib bcd -s -h -r

    ren c:\boot\bcd bcd.old

    bootrec /RebuildBcd



    That did it.

  • Christopher Murphy Level 3 (555 points)

    diskutil resizevolume [MountPoint|DiskIdentifier|DeviceNode] limits


    For your disk this appears to be /dev/disk0s2

  • Charaity Level 1 (0 points)

    when i type


    "sudo gdisk /dev/disk0s2"


    its giving me the error again:


    "sudo: gdisk: command not found"



    But anyways thank you for your help. I've learnt more about gpt and mbr's.

    I have temporatily solved the problem by installing rEFIt. I can now boot windows from partition 4


    This is enough for me so I am just goin got keep it like this for now.


    Again thanks for your help

  • Christopher Murphy Level 3 (555 points)

    This whole thread, and four posts ago I told you were to find and install gdisk. So the fact you're getting this error message that it's not found indicates you still haven't installed it.

Previous 1 16 17 18 19 20 Next