Previous 1 44 45 46 47 48 Next 1,499 Replies Latest reply: Feb 11, 2016 3:07 PM by SN225 Go to original post Branched to a new discussion.
  • Christopher Murphy Level 3 (555 points)

    Disk Utility thinks it's FAT32 instead of NTFS. Whatever precipitated all of this munged the GPT and the MBR and appears likely to have toasted the file system. It's worth running Windows Startup Repair because it'll do an fsck early on and if that fails then the file system is mostly toast. However, testdisk might be able to find a superblock that has enough correct information in it to get you file access if there's anything you want to try and salvage. But with a busted file system, it basically needs to be recreated.


    I'd try to be clear on what actions precipitated this so you can avoid it in the future. I know that Disk Utility does exactly the wrong thing six ways to Sunday if you try to add one too many partitions (more than 4), but since your disk doesn't have a Recovery HD partition, I don't think that's what happened in your case since you have only three partitions: EFI, OS X, Windows. Lion and Mountain Lion users have four partitions with Windows, and when they use Disk Utility to add a 5th partition, Disk utility hoses the hybrid MBR and Windows won't boot. Typically the user removes the 5th partition, but Disk Utility doesn't correctly restore the hybrid MBR, it sets the wrong type code that identifies it as FAT32 file system, but thinks it's broken (because it's actually NTFS), and then allows the user to try and repair it which actuall in fact will break NTFS.

  • trevorcobb Level 1 (0 points)

    Wow, Christopher Murphy, you are extremely generous and helpful with your time and advice throughout this thread. I'm amazed by the willingness to help strangers you've never met.


    I hope you may be willing to spend some time helping me as well. I've got somewhat of a unique situation (I believe).


    I have a 13" Macbook Pro 9,2 (mid-2012). It came with a 750gb SATA HDD and internal optical drive. I installed a Samsung 840 Pro 256gb SSD in place of the HDD, then put the HDD in place of the optical drive. I have the system set up so that the SSD is my primary OSX drive with one single visible partition. Then I have the HDD set up so that the first 500gb is an HFS partition, and the rest is set aside for bootcamp. It was originally one 750gb single HFS partition, but then I used the boot camp assistant to section off the last 250gb for windows.


    For the life of me I couldn't get a bootcamp install to work off of a Boot Camp Assistant created a x64 Win7 USB stick, until I read somewhere that I needed to actually disconnect the sata connector for my SSD. This worked, and Win7 was able to format from FAT32 to NTFS, then install and boot correctly from the HDD (with the SSD unplugged), and leave the HFS 500gb partition intact.


    Then when I plugged back in the SSD, OSX can see that there is a bootable partition when I go in to "Choose Startup Disk" in SysPrefs, and if I hit the option key while booting, but all I get is a black screen with a blinking cursor. I believe that x64 Win7 is mad at me because I have changed the drive numbers that it uses to references how to boot up properly. I believe the solution may lay in running a Win7 boot repair set of commands, but I can't seem to access the Win 7 recovery console or "Repair Installation" feature using the USB stick that BCA created.


    To complicate matters further, I successfully created a Ubuntu 13.04 USB stick, used rEFIt to boot off of it, and then had it split off and use the second half of my 250gb ntfs partition on the HDD to install linux.


    To complicate things even further, I am using filevault2 with FIPS encryption module to encrypt both the SSD, and the HFS partition on the HDD.


    I have installed rEFIt and used "bless" to have it be my boot selection menu (as instructed here: ning). I can boot successfully into OSX, and I can boot successfully into Ubuntu. I still can't boot into Win7 though.


    Here is the output from a variety of commands I've seen you ask others for: (


    mbltccmbp:~ trevorcobb$ diskutil list


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *750.2 GB   disk0

       1:                        EFI                         209.7 MB   disk0s1

       2:          Apple_CoreStorage                         501.8 GB   disk0s2

       3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3

       4:       Microsoft Basic Data BOOTCAMP                124.0 GB   disk0s4

       5:       Microsoft Basic Data                         115.5 GB   disk0s5

       6:                 Linux Swap                         8.5 GB     disk0s6


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *250.1 GB   disk1

       1:                        EFI                         209.7 MB   disk1s1

       2:          Apple_CoreStorage                         249.2 GB   disk1s2

       3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:                  Apple_HFS Macintosh SSD          *248.9 GB   disk2


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:     FDisk_partition_scheme                        *8.3 GB     disk3

       1:                 DOS_FAT_32 WININSTALL              8.3 GB     disk3s1


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:                  Apple_HFS Macintosh HD           *501.5 GB   disk4


    mbltccmbp:~ trevorcobb$ sudo gpt -r -v show disk0


    gpt show: disk0: mediasize=750156374016; sectorsize=512; blocks=1465149168

    gpt show: disk0: Suspicious MBR at sector 0

           start        size  index  contents

               0           1         MBR

               1           1         Pri GPT header

               2          32         Pri GPT table

              34           6        

              40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

          409640   980102336      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC

       980511976      262144      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

       980774120         792        

       980774912   242186240      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      1222961152   225603584      5  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      1448564736    16582656      6  GPT part - 0657FD6D-A4AB-43C4-84E5-0933C84B4F4F

      1465147392        1743        

      1465149135          32         Sec GPT table

      1465149167           1         Sec GPT header


    mbltccmbp:~ trevorcobb$ sudo gpt -r -v show disk1

    gpt show: disk1: mediasize=250059350016; sectorsize=512; blocks=488397168

          start       size  index  contents

              0          1         PMBR

              1          1         Pri GPT header

              2         32         Pri GPT table

             34          6        

             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

         409640  486717952      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC

      487127592    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

      488397128          7        

      488397135         32         Sec GPT table

      488397167          1         Sec GPT header


    mbltccmbp:~ trevorcobb$ sudo fdisk /dev/disk0

    Disk: /dev/disk0          geometry: 91201/255/63 [1465149168 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]


    1: EE    0   0   1 - 1023 254  63 [         1 -     409639] <Unknown ID>

    2: DA   25 127  15 - 1023 254  63 [    409640 -  980102336] <Unknown ID>

    3: AF 1023 254  63 - 1023 254  63 [ 980511976 -     262144] HFS+       

    *4: 07 1023 254  63 - 1023 254  63 [ 980774912 -  242186240] HPFS/QNX/AUX


    mbltccmbp:~ trevorcobb$ sudo fdisk /dev/disk1

    Disk: /dev/disk1          geometry: 30401/255/63 [488397168 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]


    1: EE 1023 254  63 - 1023 254  63 [         1 -  488397167] <Unknown ID>

    2: 00    0   0   0 -    0   0   0 [         0 -          0] unused     

    3: 00    0   0   0 -    0   0   0 [         0 -          0] unused     

    4: 00    0   0   0 -    0   0   0 [         0 -          0] unused  

  • Christopher Murphy Level 3 (555 points)

    Please start a new thread and paste its URL in this one. This thread is too cluttered to keep track of when multiple people are posting (and hence hijacking) in one thread.

  • Kirihuna Level 1 (0 points)

    So I'm currently waiting for the Haswell refresh of the rMBP. I haven't decided what size I want, more than likely the 15" for quad core ans possible dGPU and I know I'm getting 16GB. My SSD however, is undecided.


    I want either a 256 or a 512GB SSD. The size depends on what I can do.


    I want to partition the 512GB SSD into three parts. ~100GB for OS X, ~100GB for Windows 8, and the other ~300GB as storage that BOTH OSes can access. Is it possible? I read if you leave the 300GB partition as FAT32 you can use it across both, but files can't be larger than 4GB in FAT32.


    Sorry if I'm explaining this badly. Is it possible?


  • akilbasa Level 1 (0 points)

    Hey guys,


    I apologize, but I still haven't been able to recover my windows partition. Christopher Murphy, thanks for your assistance. Could you please help me if you can? And please be a bit more specific, as I'm lost and didn't quite understand what to do. All the 3 bootable partitions are there and I can access all the files, it's just failing to boot windows. It all started after i added another partition for mavericks. used to work fine with mountain lion and windows only. Here's my partition data:

    *** Report for internal hard disk ***



    Current GPT partition table:

    #      Start LBA      End LBA  Type

    1             40       409639  EFI System (FAT)

    2         409640    488690887  Mac OS X HFS+

    3      488690888    489960423  Mac OS X Boot

    4      662568112    818818111  Mac OS X HFS+

    5      818818112    820087647  Mac OS X Boot

    6      820856832    977104895  Basic Data



    Current MBR partition table:

    # A    Start LBA      End LBA  Type

    1              1    977105059  ee  EFI Protective



    MBR contents:

    Boot Code: Unknown, but bootable



    Partition at LBA 40:

    Boot Code: None (Non-system disk message)

    File System: FAT32

    Listed in GPT as partition 1, type EFI System (FAT)



    Partition at LBA 409640:

    Boot Code: None

    File System: HFS Extended (HFS+)

    Listed in GPT as partition 2, type Mac OS X HFS+



    Partition at LBA 488690888:

    Boot Code: None

    File System: HFS Extended (HFS+)

    Listed in GPT as partition 3, type Mac OS X Boot



    Partition at LBA 662568112:

    Boot Code: None

    File System: HFS Extended (HFS+)

    Listed in GPT as partition 4, type Mac OS X HFS+



    Partition at LBA 818818112:

    Boot Code: None

    File System: HFS Extended (HFS+)

    Listed in GPT as partition 5, type Mac OS X Boot



    Partition at LBA 820856832:

    Boot Code: Windows BOOTMGR (Vista)

    File System: NTFS

    Listed in GPT as partition 6, type Basic Data



    Thanks so much!

  • Christopher Murphy Level 3 (555 points)

    I want to partition the 512GB SSD into three parts. ~100GB for OS X, ~100GB for Windows 8, and the other ~300GB as storage that BOTH OSes can access. Is it possible?


    Not via the GUI, Apple Disk Utility will not allow you to have this many partitions and a hybrid MBR. You'll have to do something totally unsupported that may at any time cause Windows to become unbootable. You can use gdisk to create a hybrid MBR, placing the GPT, EFI System, OS X and Recovery HD's into MBR  #1 as type 0xEE (protected) - this happens automatically when you do NOT specify these partitions to be added to the hybrid MBR. Instead, you specify only the Windows and FAT32 partitions to be added, and only make the Windows one bootable.


    As for FAT32, yes that's OK if you're able to live with the file size limitations. I do not recommend using exFAT, because it has only one FAT and isn't as easy to repair if things go bad. If you ever have a crash or power failure it's important to run repair the FAT32 volume because it doesn't have a journal. You should be able to repair it in either Disk Utility or from Windows using chkdsk. Of course the Windows volume is NTFS and Disk Utility should never be used to attempt to repair that should it be needed, only use Windows chkdsk for repairing NTFS, although this shouldn't normally be necessary because it is a journaled file system.

  • Christopher Murphy Level 3 (555 points)

    What you want to do is not supported by Apple, and can't be fixed in the GUI. You can create a new hybrid MBR with gdisk and only add partition 6 to the hybrid MBR, and mark it bootable. More specfics are here.

  • SapphireBabe94 Level 1 (0 points)

    I have a similar problem to the OP but in reverse; After the 5th partition, I can't get into mac OS OR windows. The only way for me to do anything is to install windows off a USB and stay logged on. If I restart I BSOD. Tried to access the other partitions from windows but couldn't. Also tried to use test disk but I couldn't find partitions when I searched them. What else can I do?


    I might just use recurva or idata to attempt to retrieve files and then wipe everything and reinstall mac.

  • waynehevyfromkingston Level 1 (0 points)

    Hey Christopher i went through the first couple pages and i didn't see anything that could help my situation too much since i'm not that familiar with macs, i'm hoping that you can help me out. I have a macbook air 13 inch 2012 model, running os x lion 10.7.5 I decided to install windows 7 ultimate through bootcamp and it worked for me as i used a usb flash drive to install it. I tried twice, the first time worked and had a problem after i installed the windows drivers (I received a message saying "no bootable disk....") i fixed this by pressing the alt-option button at restart and going back to os x. I removed the partition and then redid it with more memory 50g memory on the windows side (I use it for games). I successfully installed windows again and the drivers with no problem. Now is the trouble...I downloaded and installed my game, star wars the old republic. after the 5 hour installation i came back to see my computer at a gray screen???? I restarted several times and saw nothing that i could boot, no recovery HD no Macintosh HD no Windows drive, even when i pressed the alt-option button. Now it takes me to internet recovery when i press command-r. This is where im stuck. I cannot reinstall os x lion and i cant delete or repair anything from disk utility. and the only options in disk utility are disk0 and under it is Mac Os x Base (not sure of the name) but this is all i see. Some help would be greatly appreciated man

  • kbajpai Level 1 (0 points)

    Your above solution solved my problem partially. Here is my partition layout:




    Windows 7 was installed using Bootcamp. Then I used the Mac Disk Utility to shrink the Macintosh HD partition & carved out Windows 8 partition out of it. After that I used gdisk as described in your reply (that fixed Scocth_Brawtch problem) to make the Windows 7 partition visible at boot time as it wasn't avaible when I had created the Windows 8 partition. Then I installed rEFit and used Windows 8 DVD to load the Windows8 to the partition using the newly created partition. After I rebooted I could see 3 choices from rEFit screen:

    1. Mac
    2. Windows on Partition 2
    3. Windows from HD


    When I booted using Windows HD I was taken to Windows8 and I could no longer boot to Windows7. Then I went back to Mac and as per your directions made Windows7 as the boot disk. Now I am unable to boot to Windows8.


    Anytime I have to boot to the other Windows partition I have to follow the "gdisk" procedure to make it bootable from the rEFit screen.


    Also I am unable to see separate partition of Mac and Windows when I boot from either Windows 7 or 8. In windows it shows me GPT protected partition on Disk Management and as combined partition.


    Screen Shot 2013-09-09 at 2.45.11 PM.jpg

    The Bootcamp one is Windows7. I have to the your process everytime I have to switch between Windows 7 and Windows 8, which ever I have to boot to.


    Can you help with that? If you want anymore information just message me.


    Thanks in advance

    Kunal Bajpai

  • Scotch_Brawth Level 3 (820 points)



    OP here.  I see you've been busy.  Hopefully a lot of what's causing people problems will be rectified in Mavericks.  Goodness knows Apple should be taking some of the onus away from you.


    If you've still got the willpower: my Boot Camp install appears to have broken again, though in a different way to before. I've started a new thread here, though it didn't get any useful responses.  There's another thread here at MacRumors that's perhaps a little more clearly laid out.


    I'm actually loathe to lay this one at your door, but if you have the time, it'd be much appreciated.



  • Christopher Murphy Level 3 (555 points)

    Yeah this is just too complicated for the various tools you're trying to use, none of which understand hybrid MBRs very well, except gdisk which can only create them rather than understand all possible intents. I'd just say this isn't supportable, at least it's not something I would do on Apple hardware. I would use a VM, or I'd get a computer with real firmware for booting Windows and Apple doesn't make such a thing.

  • spidi21 Level 1 (0 points)

    Hello, Christopher, I have a question for you, because as it seems like, you know the stuff


    Here's what I did:


    At first I had Macintosh HD and Bootcamp partition.


    Then I booted to Mac, went to Disk Utility, and created a new partition on my Macintosh HD. And then I formated it for MS-DOS (FAT), so that I could see it in Windows and then later formated it in windows for NTFS.




    And then the first problem was that I couldn't boot to Windows 7 - but I solved this with your instructions below.


    I did everything you already said in the first page of this topic about the gdisk ...


    To recap:



    sudo gdisk /dev/disk0


    If you get any error messages at this point, report the error messages, don't proceed further.


    You're now in gdisk interactive mode. Menus/commands are single characters followed by return/enter. So type ? and <enter> and you'll get the main menu listing commands. Type p <enter> and it will print (display) the current GPT. Since you have 5 GPT entries, you can't use a 1 for 1 GPT to MBR scheme like Apple does. The following suggestion is safe, but all hybrid MBRs are non-standard inventions, and therefore I can't tell you how Boot Camp Assistant or Disk Utility will react to this hybrid MBR should you decide to make changes later. What I can tell you is Windows, Linux, and Mac OS X themselves have no problem with this MBR scheme.


    r <enter>        go to the recovery & transformation menu

    h <enter>        create a new hybrid MBR

    5 <enter>        add partion 5 to the MBR

    <enter>          accept the default MBR hex code of 07

    y <enter>        set the bootable flag

    n <enter>        do not protect more partitions

    o < enter>       print (display) the MBR


    You should have two entries. One type EE, one 07, with the 07 entry marked with * under Boot. If you don't, report back. If you do, write out the update partition information, and hope  a power failure doesn't occur for the next few seconds...


    w <enter>     write partition table to disk



    BUT results for my commands were as follows:


    sudo gpt -r -vv show disk0


    gpt show: disk0: mediasize=1000204886016; sectorsize=512; blocks=1953525168

    gpt show: disk0: Suspicious MBR at sector 0

    gpt show: disk0: Pri GPT at sector 1

    gpt show: disk0: Sec GPT at sector 1953525167

           start        size  index  contents

               0           1         MBR

               1           1         Pri GPT header

               2          32         Pri GPT table

              34           6        

              40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

          409640   387349760      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

       387759400      262872        

       388022272   587702272      3  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

       975724544     6416384        

       982140928   971382784      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      1953523712        1423        

      1953525135          32         Sec GPT table

      1953525167           1         Sec GPT header


    AND the diskutil list command:


       4:       Microsoft Basic Data BOOTCAMP                497.3 GB   disk0s4


    Therefore I used 4 instead of 5 in your instructions (in the original topic the 5 was for BOOTCAMP).


    Then ... after I completed everything, I booted with holding the option key and could normally start into Windows.




    BUT HERE is the next PROBLEM: Now I can't see any of my Macintosh HD and my newly created Macintosh MS-DOS (FAT) partition.


    I wanted to format the newly created partition and merged it with my current Bootcamp partition in Windows.



    BUT what seems to be the problem now? If I boot to MacOS, I can see just everything fine; I see all disks and everything. But I lost my 2 partitions in Windows.



    How can I resolve this issue now, without doing everything from scratch?



    I hope you have a solution




  • parikh.rohan0 Level 1 (0 points)

    when i enter the command sudo gdisk /dev/disk0     i get error 2


    it asks type device file name.

Previous 1 44 45 46 47 48 Next