Previous 1 47 48 49 50 51 Next 1,472 Replies Latest reply: Jul 29, 2015 5:16 AM by McVareck Go to original post Branched to a new discussion.
  • braaten1124 Level 1 Level 1 (0 points)

    Could you point me in the direction of a step-by-step guide on how to "... delete the invalid partition 4 first, then add a new  partition, plug in the start and end values from gdisk, then the type code for Windows NTFS volumes which is 0700." after downloading and installing gdisk?

  • braaten1124 Level 1 Level 1 (0 points)

    Nvm, figured it out!

     

    Now, after deleting the old and creating the new partition and choosing the Windows partition at start up, all I get is a black screen with an underscore blinking in the top left corner. Previously I got the "Missing operating system". Does anyone have any idea what the blinking underscore means, or how to fix it?

  • Christopher Murphy Level 3 Level 3 (555 points)

    I don't know of one.

     

    If you actually understand the cause of your problem well enough that you know you need a particular guide, in a 49 page thread that demonstrates the same problem actually has a dozen different causes, then you don't need a step by step guide.

     

    So I'm suggesting that you may not actually know the cause of your specific problem. But seeing as 10.9 was released two days ago and this thread had exploded again, sorta tells me this is due to latent improper resizing of Windows. And then improper behavior by Apple's diskutil to stomp on the the correct MBR with incorrect data without asking the user first.

  • Christopher Murphy Level 3 Level 3 (555 points)

    It's not finding the Windows bootloader.

     

    So you used testdisk and it found an NTFS volume and you were able to navigate files and folders? If yes, then instead of trying to boot Windows, does the BOOTCAMP volume mount read-only in the OS X Finder?

  • braaten1124 Level 1 Level 1 (0 points)

    I used testdisk to find the correct start and end values for the partition (with the correct files and folders). Then, I used gdisk to delete the partition that had the wrong start and end values, and then created a new one with the correct values.

     

    Previously, BOOTCAMP didn't show up in finder, but now it does mount as read-only.

  • Christopher Murphy Level 3 Level 3 (555 points)

    So I would take the opportunity to get the data off the volume while you can as a first step.

     

    Did you create a new hybrid MBR with gdisk? You added partitions 2 3 4, accepted their default hex values, and set partition 4 only to be flagged bootable?

  • braaten1124 Level 1 Level 1 (0 points)

    This http://www.tomshardware.co.uk/forum/209-69-windows-bootcamp-black-screen-blinkin g-cursor-ages-boot solved it - now the windows partition acts exactly as before.

     

    Thanks for all the help!

  • G. Tran Level 1 Level 1 (0 points)

    Same issue here.  I definitely agree that this issue will affect those of us who resized the disk improperly.

     

    That said, it looks like we have the basis of a guide on how to correct the issue.  However, I'm a little fuzzy on what commands/actions I need to do with gdisk.  Can you help?

  • frankywashere Level 1 Level 1 (0 points)

    Yes I'm same boat as G TRan.

     

    Chris could you list out the exact commands I need in GDisk to delete the partition and then the commands to redo the partition with the values that i now have?

  • Christopher Murphy Level 3 Level 3 (555 points)

    No, I'm not going to do that or I'd be doing that for everyone all day long non-stop. It's really simple, you just have to read the on-screen menus, and give it the information it asks for.

  • frankywashere Level 1 Level 1 (0 points)

    hey chris,

     

    that's the problem, the first step i don't know what to type in.

     

    It asks "type device file name"

     

    To me, I don't understand why it would be asking for a "file name"

  • frankywashere Level 1 Level 1 (0 points)

    nevermind chris, i figured it out, low and behold what a google search (and brains) can do!

     

    first step type:

    sudo gdisk

     

    then:

     

    /dev/disk0

  • frankywashere Level 1 Level 1 (0 points)

    Looks like someone has had success, with your route Chris...

     

    Gonna try.

     

    I am using a MacBook Air with OS X Lion Version 10.7.3.


    I installed Windows 7 using Boot Camp Assistant, after installing and using it for a bit I realised I allocated too little space for it. In trying to save time, instead of backing up and wiping out the partition and resizing and restoring Windows, what I did was I resized the Mac partition smaller using Disk Utility, and then booted into Windows and used MiniTool Partition Wizard to resize it larger. At first it went ok, I could boot into Windows after that. But when I booted into Mac, Disk Utility still reported the original Windows size at 50GB, when it's supposed to have been enlarged to 120GB. I clicked verify disk and I suspect it caused all **** to break loose.


    To cut the long story short, right now I can no longer access Windows 7. Disk Utility can't mount the Windows partition and still reports it wrongly at 50GB, and I can't boot into Windows, it shows error message. Trying to repair with Windows repair utility during startup was of no avail.


    After reading and researching for hours on the internet, I'm still not quite sure what to do. I've installed and used testdisk to check the partition status, at first it showed a gap between the Mac and Windows partitions, but after some more checks it shows the Windows partition of the correct size, but I couldn't write the correct partition table as it showed write error.


    Using gdisk shows the inaccurate partition table with a gap between the 2 partitions. I've attached a screenshot showing both utilities and the partition tables.


    So right now I think what I need to do is write the partition table using information from testdisk with gdisk, but I'm not too sure how to do it, do I create new partitions and input the sector values? Or am I mistaken here? I'm still a little confused with GPT and hybrid MBR, when gdisk shows the partition table, that is GPT right, where's the hybrid MBR?


    I would really appreciate it if anyone could help me out here, I've spent many hours almost banging my head for this. Thanks in advance.


    ------


    Resolved it, using gdisk, deleted Windows partition and recreated using data from testdisk. Restarted into rEFIt's boot menu and opened partition tool, synced MBR with GPT. Right now Windows partition is accessible once again!


    Fingers crossed that everything is ok now.

  • Christopher Murphy Level 3 Level 3 (555 points)

    Yes this is non-obvious. It actually needs to be:

     

    sudo gdisk /dev/rdiskX

     

    X= the number of the disk device which is usually 0, but might be 1 if you have more than one disk. It *should* work just using /dev/disk but I've found a bug that sometimes causes a problem so it's better to use /dev/rdisk which is the raw unbuffered disk device. Totally non-obvious.

     

    And anyone reading this about fusion disks or > 3TB disks, all bets are off you guys have totally different rules.

  • Christopher Murphy Level 3 Level 3 (555 points)

    And for what it's worth, so far the edge case (bug) is that sometimes when using /dev/disk0 you get a bogus error that the GPT is corrupt whether it is or not. So you don't know if it's got some problem or not.

     

    When using /dev/rdisk0, it only reports corruption if there is corruption. Same with the built-in gpt command.

Previous 1 47 48 49 50 51 Next