Previous 1 55 56 57 58 59 Next 1,503 Replies Latest reply: Mar 27, 2016 8:09 AM by osdieman Go to original post Branched to a new discussion.
  • Mishtamesh Level 1 Level 1

    The only trouble I've had with it is that if the NTFS drive or partition wasn't unmounted properly then it won't even show up in OS X. Though there must be some way to force mount it, but I haven't tested how reliable that is.

  • Christopher Murphy Level 3 Level 3

    That behavior could be journal related. If it finds the journal is dirty on reboot, it won't mount it because OS X doesn't come with tools to repair NTFS volumes.

  • ticklemedaly Level 1 Level 1

    I might as well ask it now before it gets burried within the following posts. If this would occur, how would one go about correcting the "dirty journal"?

  • Christopher Murphy Level 3 Level 3

    Boot Windows. It will replay the dirty journal, mount the files system read-write, and write the necessary changes to the file system to bring it up to date.

  • ticklemedaly Level 1 Level 1

    Sounds simple enough. Thanks again!!!

  • singularity at 0 Level 1 Level 1

    I have followed this thread as it descirbes my problems after installing Mavericks. Do the steps described by Christopher Murphy to add the bootcamp partition back to the MBR work if my primary OSX partition is encrypted using file vault?


    The example posted by tomd007 on page 50 suggests that I have to add the primary OSX partition to the hybrid MBR in the process of restoring the bootcamp access. Since the OSX partition is encrypted, do I need to point to a specific unencrypted partition that will initialize the decryption process for the primary OSX partition?


    Thanks in advance for any help.

  • Christopher Murphy Level 3 Level 3

    I don't see how you ended up in this situation with FV2 encrypted OS X because those volumes aren't resizable as far as I know. I have my SSD FV2 encrypted and I'm disallowed from resizing it in the CLI, I've never tried it in Disk Utility. Please post the fdisk and gpt results for your disk.

  • singularity at 0 Level 1 Level 1

    My bad. I never tried to resize the partitions, just want to restore the access to my bootcamp partition after Mavericks messed up the MBR.


    Anyway, here are the results for



    gpt show: disk0: mediasize=500107862016; sectorsize=512; blocks=976773168

    gpt show: disk0: Suspicious MBR at sector 0

    gpt show: disk0: Pri GPT at sector 1

    gpt show: disk0: Sec GPT at sector 976773167

          start       size  index  contents

              0          1         MBR

              1          1         Pri GPT header

              2         32         Pri GPT table

             34          6        

             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

         409640  826794504      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC

      827204144    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

      828473680  148299448      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      976773128          7        

      976773135         32         Sec GPT table

      976773167          1         Sec GPT header


    and fdisk

    Disk: /dev/disk0          geometry: 60801/255/63 [976773168 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]


    1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>

    2: AC 1023 254  63 - 1023 254  63 [    409640 -  826794504] <Unknown ID>

    3: AB 1023 254  63 - 1023 254  63 [ 827204144 -    1269536] Darwin Boot

    4: 0C 1023 254  63 - 1023 254  63 [ 828473680 -  148299448] Win95 FAT32L


    I appreciate your help.

  • Christopher Murphy Level 3 Level 3

    You can fix this either with gdisk (gpt fdisk from sourceforge) or the already present fdisk on OS X. Using gdisk you'll create a new hybrid MBR using the already mentioned method, add partitions 2 3 4 and make 4 bootable.


    If you use fdisk to edit the existing MBR rather than make a new one, you'll use setpid command to change partition 4's type code from 0C to 07. And use the flag command to make it bootable.


    sudo fdisk -e /dev/rdisk0

    [ignore error message]

    ? to get the menu of commands

  • Christopher Murphy Level 3 Level 3

    Make sure to write the change to disk when quitting or nothing will change.

  • singularity at 0 Level 1 Level 1

    Thank you for your information. The instructions were straight forward and restored the bootcamp partition to a bootable state again. (Though I now have the flickering screen plus error message problem. But this is another issue. )


    Thank you again.

  • RamosWipeout Level 1 Level 1

    Hi guys, I have now this problem.



    I did both created a third partition (accidentally) and updated to Mavericks. Now the Windows partition is not showing anymore when restarting and using the 'alt' button, it does in disk utility though and I really need to make it work because I have really important data and software there I use for working so please give me a hand.



    The thing is, I don't have that much experience in mac computers and I am finding pretty tough the explanations given here (and there are already 57 pages...) , so anyone who can help me step by step? or maybe already someone did this job and can write me the link? I really appreciate.



    Thanks and really looking forward to hearing from any of you

  • Loner T Level 7 Level 7
    Windows Software



    Post the output of (or look at page 54).


    sudo gpt -r -vv show disk0 and sudo fdisk /dev/disk0

  • RamosWipeout Level 1 Level 1

    Captura de pantalla 2013-11-05 09.13.11.png

    Thanks Loner T for your quick response

  • Christopher Murphy Level 3 Level 3

    1832 sectors free space is less than 1MB so you don't have the same problem as the most recent posts. All you need to do is fix the MBR #4 entry, whose id is set to 0C instead of 07. You can do this with fdisk, which comes with OS X. The commands you need are setpid, which will let you change the 0C to an 07, and the flag command will let you set the boot flag on that #4 partition. And the write command will write the changes, as will the quit command. The abort command, or simply a control-c will cause no changes to take effect.

Previous 1 55 56 57 58 59 Next