Previous 1 2 Next 17 Replies Latest reply: Aug 12, 2015 3:10 PM by MacUser7726
Omniver Level 1 (10 points)

In upgrading to mountain lion I checked the 'back to my mac' option in the iCloud setup, this now has enabled a special "Guest User" account which reboots the computer into a locked down Safari-only mode to entice thieves to go online.


I don't want this.  I've disabled "back to my mac", but this account will not go away.

I've tried unchecking the "Allow guests to log into the computer", but it is greyed out and I'm not allowed to uncheck it, even after unlocking the settings.


Lion used to have a setting under Preferences->Security/Privacy->Advanced where you could set an option "Disable restarting to Safari when screen is locked" to turn this off, but this setting is now gone in 10.8


At my wit's end, need to disable this login. 


Any ideas?

OS X Mountain Lion
  • cbs20 Level 4 (2,785 points)

    That account isn't because of the back to my mac it is because of the Find my Mac iCloud feature. If you disable the Find my Mac the guest account will go away. It allows the thieves to be connected to the internet when they steal your mac and that allows you to log in to the iCloud remotely and locate it, so yes it is meant to entice thieves to go online.

  • Legge Level 2 (175 points)

    I used to have this too with Lion when Find My Mac was on. Now in ML, I don't see it anymore and Find My Mac is still working just fine. Have disabled guest account through Settings->Accounts?

  • Omniver Level 1 (10 points)

    @cbs20 Sorry, mistyped - I meant "Find my Mac" not 'Back to my Mac".


    Find my Mac" is indeed disabled (unchecked in the iCloud interface) - this did not remove the account.  Also logged out of iCloud and back in to verify it is unchecked.


    @legge, as mentioned, the checkbox to disable the guest account is greyed out and I cannot uncheck it. 


    Seems like ML is not removing the account when "Find My Mac" is disbled, unless there is some other place to disable it that I'm missing.

  • stevenfrombrownsburg Level 2 (340 points)

    Open System Preferences > Users and Groups


    Click on the lock and enter your password to enable changes


    Click on Guest User, Uncheck 'Allow Guests to log in to this computer'


    Click on Login Options and set Display login window as * Name and Password.


    Click on the lock to save changes.


    The only way to log in with this is to actually type in the full user name and password of a registered user.

  • Omniver Level 1 (10 points)



    Thanks for the suggestion, please see from above that the "Allow Guest to log in to this computer" is greyed out and can't be changed, and yes, I am authenticated with the lock unlocked. See below:



    Also see that "Find my Mac" is indeed not on:



  • Dahco Level 1 (0 points)

    First off, I don't have this problem, so I'm only throwing out a thought.  However, I have been able to solve most of my issues involving iCloud by completely signing out of the service on my mac, and then re-signing in to iCloud.  In this instance, I would probably try to disable the Guest User via the Users & Groups preference pane after signing out of iCloud, and then sign back into iCloud. Best of luck!

  • Omniver Level 1 (10 points)

    Thanks Dacho, tried that as well, no luck.  On phone now with Apple support to see if they can help figure this out.

  • Omniver Level 1 (10 points)

    No luck with Apple support.  They took screenshots and a system capture and are passing it along to engineering.  If anyone else comes across this, please comment here.  My steps which caused it:


    1) Enabled "Find my Mac" on a computer running FileVault


    This enabled the "Guest User" account both on the login screen as well as as a FileVault user.  Choosing the account reboots the system into a Safari-Only locked down login.  All of this is as expected.


    2) Disable "Find my Mac"  by unceckign the option in iCloud


    The "Guest User" account is still there, can't' be disabled and can't be removed.  From googling a bit, this appears to have occurred in Lion (10.7) as well, but in Lion there was an option in Advanced security settings to "Disable Restarting to Safari when screen is locked"; this option does not appear on my instance of Mountain Lion (10.8)

  • iHussein Level 1 (10 points)

    This is exactly what is happening to me! and i could not find a solution. i re-Installed Mountain Lion 3 times! i guess File vault is what causing this because since i disabeled it and then engabled it that happend! I will take the computer to Apple and see what they can do about it. i think a software update that will be released soon should fix it I'll keep you posted if i found a solution.

  • tigtog Level 1 (0 points)

    Thanks. This has worked for me.  I needed to keep my teenage son OFF my Mac for no other reason than he is soooo clumsy!  

  • Moses3d Level 1 (0 points)

    My two cents here if you please.


    First, I have encountered this back in Lion. Now in ML as well. Let me break this into two parts:


    1. The cause:

    IN MY CASE both on Lion and ML, the Guest Account login item appears after you share your folders when enabling Bak to My Mac feature. I have not used FileVault or created a guest user for any purpose. Just creating the shares leads to this.


    2. The cure:


    a) in Lion - exactly as described in this thread - by going to System Preferences / Security - and then unchecking the Restart Safari thing


    b) in ML - (PLEASE NOTE - THIS IS HOW IT WORKED IN MY CASE!!!) - System Preferences/Users&Groups (unlock the pane) - go to Guest User and here UNcheck "Allow guests to log in to this computer" AND "Allow guests to connect to shared folders" (please remember - you may have a different set of options, mine is such probably because I have sharing enabled).  Then, when you close System Preferences and restart the Mac, you should see only ONE user to log in (with picture, no need to manually type in the user name).


    One more thing: just in case it mattes - I DO NOT have Find My Mac feature enabled, while ALL other iCloud features ARE enabled.


    Hope this helps! Attached is the screen for your convenience.Screen Shot 2012-08-07 at 1.50.11 PM.png

  • Julius CJ Level 1 (0 points)

    This issue has been boggling me to for a while. This is what I just found out:

    first of all, there are 2 types of guest accounts:


    - the guest account that can be en- or disable in users & groups system prefs; use this for your kids or whatever person who use your mac on a regular basis


    - the secure guest account that only gives acces to the internet, this account is automatically engaged when 'find my mac' is checked; if so you'll find a guest button in your lockscreen (when waking up from sleep).

    if you dont want this option in your login screen (startup) in login options next to Display login screen check 'name and password',

    if you DO want this option because you want to be able to track your eventually stolen mac with find my mac and give your not-so-trusted colleague acces to the internet: check 'List and Name'


    Hope this helps

  • imakecpus Level 1 (0 points)

    For what it's worth... I found the System Preferences/Users and Groups click box to "Allow guests to log in to this computer" was greyed out from being modified as well.  I also noticed that the guest account was currently logged in.  After switching to guest and logging out, the box was no longer greyed out and I could disable the guest account.  Not sure if I was in the exact situation as those above, but I seem to remember enabling find my mac. 

  • YolandaDolly Level 1 (0 points)

    Haha imakecups that was the exact answer everyone was looking for! THANKS

Previous 1 2 Next