Previous 1 2 3 Next 218 Replies Latest reply: Nov 16, 2013 7:07 AM by mpvecchi
nathan_h Level 1 Level 1

From my mini, I access some windows servers for data storage, mapping SMB.  For some reason, after upgrading to Mountain Lion, I can't get to those drives (shares) any longer.

 

They  are accessible from other computers on the network, and they are even accessible from a virtual Win7 (Fusion) session on the mini.  But in the main OS X mountain lion environment on the mini, they are not accessible through any of the usual means (Finder, etc).

 

I even installed ForkLift and ForkLift can't get to them either.

 

If I go to GO -> Connect to Server, I get "There was a problem connecting to the server "192.192.192.192".  (Not the real IP.)

 

If I use the existing entry in the list of shares I get "Connection Failed".

 

Needless to say, noting on the server has changed, and Mountain Lion left the shortcuts/share names/startup connection commands (which used to open the server drives when the mini started up) in tact.  But actually connecting and using docs on the server, no dice.

 

What am I missing?


Mac mini, Mac OS X (10.7.4)
Reply by Bernie Case on Jul 31, 2012 4:39 PM Helpful
I work for a NAS vendor and we've had some customers report this issue to us.  My analysis of it, so far seems to indicate that Mountain Lion is behaving differenty than Snow Leopard and Lion in the total amount of data it will accept from the SMB/CIFS server for the list of SMB shares sent to it from the SMB server.  (nerd speak: I'm pulling this from the MaxDataCount field in a network trace) Snow Leopard accepts 16KBLion accepts 16KBMountain Lion accepts 2KB When the server tries responding to Mountain Lion with more than 2KB of data, it fails, because Mountain Lion has said "hey, I can only take 2KB of data for the list of shares."  Mountain Lion knows that the server couldn't respond with the shares, so it goes back to the server to get the share list a different way.  It uses an older method to get the share list and it seems like this is not fully supported by every SMB server out there.  In particular, I know that Windows Server 2003 R2 and Samba seem to support this alternate method, but Windows 2008 R2 does not.  So, for the servers that can't respond to 10.8 with the share list at all, 10.8 errors out and you see that error in your Finder when you try to connect. My feeling here is that this 2KB limit is a bug in 10.8.  I'm going to open up a bug with Apple via Radar.  Maybe it'll get fixed in 10.8.1.
Reply by netispguy on Aug 26, 2012 8:52 AM Helpful
For us, the SMB issue has two parts: 1) Mac -> Win Filesharing2) Windows -> Mac (export shares using SMB). With regards to 1: For most people, simple Finder access has been restored and users are able to see shares that are presented in hierarchal format (e.g. /dir/dir2/share). Files on the shares are retrievable. With regards to 2: We are now able to see the volumes exported by the Mac, including the directory structure and all of the files; however, when trying to stream media from those shares (e.g. mkv, mpeg, iso, etc.), we get an error similar to the following: "the format you are trying to use is either unsupported or you do not have access to the media file".  So, this is still hosed. @nathan_h, we have restored one Mac server and 3 Mac users (two MBP and one iMac) from their specific individual Time-Machine pre-Mt. Lion upgrades back to Snow Leopard and LIFE IS GOOD FOR THESE FOLKS! My conclusion is that if the users do not want/need the new UI and cloud functionality of Lion/Mt. Lion, or just hate the fact the the "Save As.." function now works differently than we have been used to for the past 25-30 years, downgrading to Snow Leopard, which is extremely stable, should be considered. Just make sure you gather their personal files (that might have changed since the upgrade) are archived someplace and if you are using mail that is NOT exchange or iMap (i.e. POP or not resident on a mail server), that you archive the mailboxes so you can restore them.

All replies

  • Dr.Ripco Level 1 Level 1

    I haven't upgraded to ML yet, usually wait till the dust settles, but I have a suggestion.

     

    Are the smb shares username/password protected?

     

    If so, GO -> Connect to Server, try it this way for the server address...

     

    smb://username:password@192.192.192.192

     

    When I went from leopard to lion, this seemed to work on everything, the windows smb shares and solaris (unix) ones.

  • nathan_h Level 1 Level 1

    Thanks for the suggestion.  Excellent idea!  Unfortunately, it results in the same unable to connect message :-(

  • lepling Level 1 Level 1

    Killed mine also.   No dice connecting to a windows file server at all.    Can smb into any other windows server just fine but not the file server

  • magnosantos Level 1 Level 1

    I have issues also.

     

    With a samba share on Linux, ML can see it correctly, but on my Windows Home Server 2011, if i do smb://"server address" i receive and error saying that the share dows not exist on server. Before on Lion i had a list of my shares. On finder the Server apears with a "/" which i can not open.

     

    If i do smb://"server address/share" is works correctly, but i would like to have tha before behaviour. Besides this the only issue that i found after upgrading is the WHS 2011 Lauchpad could not sign in (before in Lion was working).

     

     

    Any ideas on how to solve this?

     

  • nathan_h Level 1 Level 1

    Nope, but it is interesting that smb://"server address/share" works for you.  Doesn't for me.  I assume you are not using the quotation marks in real life.

  • magnosantos Level 1 Level 1

    Yeap. You assume correctly.

    So... all of us are having straging behaviour with SMB in Mountain Lion, that with Lion were working correctly.

     

    Hope Apple fix this.

     

  • DTAdelaide Level 1 Level 1

    I am also having problems accessing SMB Shares. All I get is folders called  "/"

  • Callan1137 Level 1 Level 1

    Typing in "smb://serveraddress/share" also worked for me - however, I do that that same "/" folder if I click on the link that comes up under Shared.

     

    Under Lion simply typing "smb://serveraddress" worked perfectly fine.

  • smnel Level 1 Level 1

    This is also not working for us after upgrading to Mountain Lion. As above, typing "smb://[server]/[folder]" works fine, however typing "smb://[server/" gives the share does not exist error. Hope this gets fixed as this is something we use to view all available shares on a server.

  • arne.caesar Level 1 Level 1

    same here: smb://serveraddress/ doesn't list all shares, only 16 of total >30 are displayed.

    smb://serveraddress/share works.

  • MikeHiow Level 1 Level 1

    I also seem to be having the same/a similar issue.

     

    If I connect to smb://server/ it will not connect.

     

    If I connect to smb://server/share/ it works.

     

    Once connected to a share, if I click on the server in the 'Shared' section of the Finder sidebar I get a single folder named '/'

  • magnosantos Level 1 Level 1

    And i believe that because of this, my Windows Home Server 2011 connector Software does not work.

  • rev2782 Level 1 Level 1

    Same issue with ML, i tried using ftp://10.0.0.10 and it works fine, but smb://10.0.0.10 shows a message that the server doesn´t exist, whatts the difference between Lion and ML in this part?

  • g_pirtle Level 1 Level 1

    Just wanted to let you know that I am not experiencing any issues connecting to SMB shares, but I am bound to an Active Directory domain. Both methods are functioning as they should - Finder -> Go -> Connect to Server -> smb://0.0.0.0 and Finder -> Go -> Network -> Select Server

     

    This isnt particularly helpful, but it does work in certain situations.

Previous 1 2 3 Next