Previous 1 2 3 Next 434 Replies Latest reply: Apr 10, 2016 1:08 PM by _TC10_ Branched to a new discussion.
markmal Level 2 Level 2

There seems to be a new bug introduced to Mail in Mountain Lion. 


In Mail preferences, on the Composing tab, you can still set "Send new messages from account of selected mailbox."  Unfortunately, this setting seems to have no effect and all new mail is sent by default from the first account in your mail accounts list.


Any idea how to work around this? 



iMac / iBook / iPhone, Mac OS X (10.5.2)
Solved by n748 on Mar 14, 2013 2:28 PM Solved

yes! 10.8.3 fixed this for me too!

  • Carlo TD Level 3 Level 3

    works on mine. try changing that pull down menu to select one of your other account.

  • markmal Level 2 Level 2

    Hmm, OK, maybe I'm looking at the wrong setting.  In previous versions of Mail, if I received a msg sent to my account, when I replied to that message Mail would by default send from the same account.


    This doesn't seem to work anymore in Mountain Lion. 


    Now, Mail defaults to whatever account is named in "Send new messages from [account name]" setting.  (And if the account name is "account of selected mailbox," it just uses the first account listed.)


    Is this the behavior you see?

  • Tuttle Level 7 Level 7

    I don't see this behavior.


    I have 18 accounts in Mail, and have just gone through 12 of them, testing your issue. In all cases, my replies were addressed from the account which received the email. In no case did a reply I created show my default sender address.

  • William Lloyd Level 7 Level 7

    This definitely works as it should for me.  So the trick is finding out what's causing your machine to behave incorrectly.  Did you upgrade this machine from 10.7?

  • markmal Level 2 Level 2

    yes, i upgraded from 10.7.

  • glev1 Level 1 Level 1

    I have the same problem in 10.8. I have an email account (.domain) that forwards to my .mac account. In 10.7, with "Send new messages from account of selected mailbox" an email to .domain that was forwarded to my .mac account could be replied to with the sender being .domain. Now in 10.8, the same situation puts the sender as the .mac account. Something has clearly changed. Very annoying.


    By the way, in both cases, I have one inbox with 4 accounts in it. But with 10.7 the email address it was sent to (even if it was forwarded) was used as the sender. Now it is always the account it was received in.


    Not sure which one was a feature and which one is a bug.


    Any thoughts on a work around (other than not forwarding) would be great.

  • glev1 Level 1 Level 1

    Just noticed the the setting is for sending NEW messages. If I select a specific inbox, it does and create a new message, it is from that account. If I just selec the general inbox, it seems to picks one account (not the top one and not the .mac one) to send from.


    My problem is that whenever I used to get an email sent to, when I replied it was always from Now it is always from no matter what I do (because it was forwarded there). Not sure that is the same problem you are having.

  • markmal Level 2 Level 2

    I think this is a slightly different manifestation of the same issue.  (I have the same behavior that when sending from a particular inbox, it selects the correct account.  But because I move messages out of my inboxes to folders on my mac, this problem rears its ugly head.  It used to work correctly until Mountain Lion.)

  • Carlo TD Level 3 Level 3

    ok... from what i see  @ Gary @ markmal first dilema: why are you still using the email still.... everything as gone to I know it might be possible... to use but here is what probably has happend Your smtp address has been changed to default to a specific address. Check your smtp settings. Also consider setting up an icloud account.

  • markmal Level 2 Level 2

    Carlo, I was just using that account as an example.  This problem crosses all my accounts (.mac, .me, icloud, gmail, various personal domains).

  • dbwalker Level 1 Level 1

    I'm having the exact same issue.  Wasn't that way in 10.7, but now in 10.8 if I get an email in my "secondary" account mail created the reply from my primary account, where before it would create the mail from the receiving account.  Haven't tried erasing the account and adding it again but that's up next.


    Update:  erasing and adding it again didn't work


    Message was edited by: dbwalker

  • mountainbiker63 Level 1 Level 1

    @markmal - i am having the same issue since upgrading to mountain lion.  mine under lion use to reply from the account the email was received and with my "send new messages from" set to "account of selected mailbox".  now, with these same settings, it is defaulting always to the first address in my list.  if i change "send new messages from" to a particular email address, then it always sends from this selected email address (regardless of account received on).

  • dbwalker Level 1 Level 1

    I saw on another thread it's a bug that needs to be fixed...but if anyone finds something sooner please post.

  • MacChick77 Level 1 Level 1

    I'm having this same issue. Worked fine until I upgraded. YUK!

Previous 1 2 3 Next