Previous 1 10 11 12 13 14 Next 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock Go to original post Branched to a new discussion.
  • CMathis Level 1 Level 1 (0 points)

    Updated to 10.8.2 - the bug remains.

  • sfare Level 1 Level 1 (0 points)

    Just installed 10.8.2 (final release) and the bug doesn't appear to be fixed. It's interesting to note though that Ernie Stamper seems to be correct in his observation that this behavior doesn't affect smart mailboxes, at least that could provide a temporary work around for some.

  • FreddiePie Level 1 Level 1 (0 points)

    I can't believe APPLE has not fixed this. I have been working with a elevated support person at apple about this, and thought this was for sure going to be fixed in 10.8.2. Wow, I guess I need to look back at Outlook. Apple, how come you are not repsonding to this thread????

  • Barney-15E Level 8 Level 8 (40,030 points)

    FreddiePie wrote:

     

    I can't believe APPLE has not fixed this. I have been working with a elevated support person at apple about this, and thought this was for sure going to be fixed in 10.8.2. Wow, I guess I need to look back at Outlook. Apple, how come you are not repsonding to this thread????

    Apple doesn't respond to any of these threads. It is purely user to user tech support.

  • phineas8 Level 1 Level 1 (0 points)

    I see the problem in Smart Folders too. If you manually or via rules move a message out of the universal Inbox (or any of its account-specific subfolders) into any other non-Inbox folder, when you reply, Mail cc's you on your own message. Plus, depending on the order of the account subfolders under Inbox, it may use the wrong account with which to originate your replies.

     

    There are actually two separate but related problems. The first one may be a "feature" that leads to the iOSification of OS X (boo, hiss). The second (reply account determined by Inbox folder order instead of by Mail preference for same purpose) is clearly a bug.

     

    If both aren't fixed in the near future I will soon stop using Apple Mail.

     

    I'm sick and tired of Apple's recent penchant for making product decisions based on self-serving needs, regardless of user need.

  • Ernie Stamper Level 8 Level 8 (37,550 points)

    The rules for a Smart Mailbox do not move the messages, but link to them in the receiving individual Inbox.  Thus a Smart Mailbox will work correctly to choose the From.  However, you cannot have Moved them first via Rules.

     

    Ernie

  • phineas8 Level 1 Level 1 (0 points)

    I didn't say Smart Folders moved messages. (The whole point is that they are what we used to call virtual folders.) But, as you note, if your messages were moved for any of dozens of good reasons, a Smart Folder won't help you.

     

    In my case, if I don't move messages to a local folder, they will be auto-archived (without any way to fully ressurrect for Mac users) after 30 days. Years ago I put in place rules that move all of my Exchange mail to what is effectively a new Inbox "On My Mac."

  • Ernie Stamper Level 8 Level 8 (37,550 points)

    Just clarifying since my earlier advice to use Smart Mailboxes, at least temporarily until this is fixed, was predicated upon not letting anything Move the messages.

     

    Ernie

  • phineas8 Level 1 Level 1 (0 points)

    Yup.

  • ross70s Level 1 Level 1 (0 points)

    I just want to encourage people to use the feedback form to report this bug:

    http://www.apple.com/feedback/macosx.html

     

    The more people complain the higher the likelyhood it'll be fixed quickly.

  • Sam Pritchard Level 1 Level 1 (0 points)

    I agree absolutely with ross.  This is a problem that is causing many of us using Mail difficulties and the more people who report it to Apple the better.  I have just sent in a report and urge you to do the same.

  • Andy Lawniczak Level 1 Level 1 (0 points)

    So, i found a pretty good workaround. I set up new rules that, instead of moving the messages as they came in, it would simply flag them as gray.   I created Smart Mailboxes for each of my accounts, Which only shows emails to the proper account, which have been flagged as gray. I have messages that i flag red for "To Reply", Yellow for "To do TODAY" and Green for "To do" (eventually).  I set keyboard shortcuts to quickly flag them for one box or the other. Once they are flagged, they only show up under "Flagged", and no longer show up in the smart mailbox for each email.  When i'm done with the email and ready to archive, i use a keyboard shortcut to clear the flag and then move it to an archive folder (I guess you could also just "archive" it)

     

    It's not as simple as I used to have it, but it's a pretty good workaround, and it DOES reply correctly from the right email  address.  The "inbox" is pretty full of ALL the messages that are still flagged and not archived, but the smart folders for each account will be nice and clean.  You should only need to mess with messages in those folders and the flagged ones.

     

    Hope that helps somebody out there

  • Kawanaut Level 1 Level 1 (50 points)

    Andy Lawniczak,

     

    Sounds like a good workaround for those who have this problem due to moving mails into folders etc.

     

    Unfortunately, as I understand, it's not going to help those of us who have issues because we use one IMAP account to download mail from multiple POP3 accounts.

  • Andy Lawniczak Level 1 Level 1 (0 points)

    Yes, i forgot to mention these are all POP accounts through gmail.  Sorry i'm not any help for the issue you posted Kawanaut.

  • nautilus2104 Level 1 Level 1 (0 points)

    I gave up and have started using Postbox. Seems to do all that I want Mail to do. Sparrow would be my ideal, but I can't turn of threaded conversations.

Previous 1 10 11 12 13 14 Next