Previous 1 20 21 22 23 24 Next 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock Go to original post Branched to a new discussion.
  • piero101 Level 1 (0 points)

    I’ve found a solution to the problem:


    1) Close Apple Mail.


    2) Go to Library/Mail/V2/MailData


    3) Take all files which begin with "Envelope" (Envelope Index, Envelope Index-shm etc …) and drag them to the desktop.


    4) Restart Mail.


    5) Click Continue, all mails will get imported again.


    6) Try to reply from various accounts.



    It worked for me, it also fixed a problem I had with attachments (I wasn’t able to attach PDFs).


    Hope this helps!

  • nautilus2104 Level 1 (0 points)

    Not working for me. When I reply from a mailbox that's been sorted using a filter or rule, it still defaults to another email address for that reply.

  • latas Level 1 (0 points)

    I did it. But it didn't fix this issue.

    Well, at least in my case it didn't work.

    I still experience the same problem.


    Thank you.

  • PrincetonMacUser Level 1 (0 points)

    Which "problem" exactly are you trying to solve? Unfortunately, people keep posting solutions to problems that are not the one that this thread is about ... which keeps us all going in circles. For about the 100th time, the bug the original poster (and folks like me) need a fix for is:


    1) user has multiple e-mail addresses, and sorts incoming e-mails into "on my Mac" folders using filters/rules

    2) user replies to one of those sorted e-mails ... and Mail insists on replying from a single default address instead of from the address that actually received the email


    This bug was introduced with Mountain Lion. Earlier versions of Mail behaved correctly (replies always came from the address that received the original email).


    And so far, nobody has posted a fix that works AFAIK. So it appears that only Apple can fix this bug via an update to Mail.

  • Glenn Gutierrez Level 1 (30 points)

    piero101 wrote:


    I’ve found a solution to the problem:



    Sorry, no. I did this recently, so it was probably posted on one of the 21 other pages of this topic, as an answer to a different issue. Unfortunately, all it accomplished here was locking me out of Mail for a long time, while it rebuilt everything. I don't recommend it.

  • Brian Dear Level 1 (35 points)

    I have a solution! I have a solution!


    The solution is I am no longer going to get email notifications about new replies to this discussion which has become a trainwreck of colliding unrelated problems and solutions to the wrong thing and nobody knows anything and it's all utter chaos.


    The facts are that this problem:


    * If you have multiple email accounts, and multiple mailboxes, and rules that filter inbound email for your different accounts to go to the respective custom mailboxes, and then you go read your mail for one of those accounts, and you try to reply, the Mail app does the wrong thing, starting in Mountain Lion -- it now sets the "From" to the first entry in the pull-down list of your mail accounts.


    * It used to do the right thing -- it ALWAYS did the right thing --- which was that it was smart enough to know that this email you're replying to was sent to account B, so it sets the From to account B to match it up appropriately. 


    * Now, with Mountain Lion, it sets to account A when you mean account B and you have to manually set it each and every time you send an email. That is a B-U-G. 


    * Now... I contacted Apple, I contacted the manager of the software developers who oversee the program, and he told me that we should be very happy with the upcoming update to Mountain Lion.  I fully explained the problem to him as I have done here.  So he knew the bug. And the implication is (he isn't allowed to state it clearly but it is implied) that it is fixed in the upcoming update.


    * 10.8.3 is out in beta right now.  I don't have a copy.  I am waiting for the official release of 10.8.3 which should be soon.


    * That's it, I am out of here.

  • chispasco Level 1 (0 points)

    Today like many other days, today I forgot to check and sent an email from the wrong email address (default email address). AGGGGHHHHHHHHH!!!!!!!!!!!


    The way I see it my options are:

    1. Buy another email client
    2. Wait for apple to fix this issue.
    3. Completely change my life to only use a single email address, denying the multifaced world that I live so that Apple Mail works on my Macbook Pro.


    I don't know if there are enough of us here to try to get Apple to listen.




    <Edited By Host>

  • H-Dog Level 1 (70 points)

    Agreed - thanks for this info, also unsubscribing as this thread has become surprisingly unhelpful.

  • CMathis Level 1 (0 points)

    The solution is I am no longer going to get email notifications about new replies to this discussion which has become a trainwreck of colliding unrelated problems and solutions to the wrong thing and nobody knows anything and it's all utter chaos.


    Agreed. It's a wonder that some people can use a computer at all, considering the fact that they can't even read and understand what this discussion is about. No wonder they have problems.

  • piero101 Level 1 (0 points)


    Sorry, I was wrong. The bug reappeared after a restart.




    Yesterday I talked to an Apple support dude on the phone, they never heard of this issue.


    Apple  *****  so hard.


    <Edited By Host>

  • ptm93 Level 1 (0 points)

    I just lived through the original problem of e-mails going out on the wrong account, but in my case I went from everything working right to having the send-from problem, to resolving it.  Here are my observations in the hopes that someone else will be able to solve their issues.  I'm using 10.8.


    Hint:  When composing e-mail, next to your send-from-this-account drop down, if you also see a drop down to choose the SMTP server, then this is sign of the problem I describe below.


    I have 5 e-mail accounts setup, 4 gmail based and 1 exchange.  The gmail ones include a biz google apps domain (i.e. not while the other 3 or standard addresses.  As I mentioned, originally I could choose to send from a specific account and it worked.  Then about 2 weeks ago, the behavior suddenly changed.  I started noticing that next to the send-from drop down was a second drop down where I could choose which SMTP server to use (from a list of 5 different ones).   But it wasn't there all the time.  Turns out it was there if one specfic account was used.


    Since multiple accounts were gmail accounts, the SMTP drop down listed "Gmail" for multiple ones with no way to differentiate which was tied to which gmail account.   Obviously if you choose one smtp server, it will use the account credentials that go with it, i.e. this overrides the account-to-send-from drop down.  To the user, this is subtle and unexpected.   This was crucial to the unintended behavior though.  Also, one of the "Gmail" smtp servers was listed differently as "Gmail (offline)" even though I was receiving e-mail fine which meant it was "online" from my perspective during those 2 weeks.  Obviously the "offline" was just describing access to the out going SMTP side of things. 


    As it turns out the password for the mail app had been blanked for that one account unexpectedly.   It also turns out that that specific account was the same one I was trying to send from all the time, aka my default sending account.  So for 2 weeks I thought I was sending e-mail from my personal account but it was going out from an alternate email account.  It was only when people replied to those e-mails that it became apparent something was wrong.


    Looking at the account settings, the other 4 accounts, all have a check box enabled which essentially says when sending from this e-mail account use just this account's SMTP server (instead of giving you a choice from your other accounts/SMTPs servers).  Of course, the 5th problmatic "offline" account did not have this box checked.  Because that box was not checked, when I was composing an e-mail from that account, I would be presented with that additional drop down to select the SMTP server.  There were no warning or error messages.  


    Fixing my password on that primary account and checking/enabling that box fixed all of the misbehavior and restored it to what it was originally when I chose which account to send from.  And with all 5 accounts now in good shape and limited to using their own server, that SMTP drop-down disappeared.


    Ok, so to tie this back to the original post of why isn't the mail app sending from the account I tell it to:  In my observation it was this corner case of telling it to use an account for which it could not send from the SMTP server (password lost/corrupted, bad port #, etc.).  Instead of the mail app giving an error message to the user, it automatically tried the next account it found, and since that succeeded, it sent the e-mail from there, i.e. not what I told it in the compose window.  In other words, the app chose not to tell the user it had an issue and instead found a work around without notifying the user what it did.  To the user, it looks like the compose window drop down account selector wasn't working, but it couldn't work given there was a SMTP login issue for that selected account.  At least not in my case.


    So now all 5 accounts are set to send using only their SMTP server and that account's login credentials.    The credentials are reverified to all be working again.   The drop down box to choose SMTP server is no longer showing up, and e-mails are no longer getting sent from the unintneded accounts.  The send-from drop down box appears to be working normally again.


    Is this a bug in the mail app?   Although I commend Apple for trying to find a way to send an e-mail from any other account when the chosen account isn't work, I think it is a bug in that the user isn't notified of the underlying issue.   The user said to do one specific thing and the mail app did another thing without sufficient notification.   The choose-an-SMTP-server drop down, in hinesight, hinted at a problem, but less savvy users see the e-mail go out anyway, so why would they think something was wrong without an error message?

  • DWFaust Level 1 (25 points)

    piero101 wrote:



    Sorry, I was wrong. The bug reappeared after a restart.




    Yesterday I talked to an Apple support dude on the phone, they never heard of this issue.


    Apple  *****  so hard.


    <Edited By Host>


    Duh. We’ve been over this hundered (thousands?) of times. None of the silver bullets mention/recommended in this thread will solve the issue because it’s a BUG in the code. It’s on Apple to fix it... but so far, nada.


    There is no magic voodoo to solve the problem.

  • fevoice Level 1 (0 points)

    Tried this and so far it seems to be working. Thanks for sharing your info.

  • nautilus2104 Level 1 (0 points)

    This is not the problem. You have misunderstood the orginal reason for this thread. Go back and read the first few posts.

  • DPBest Level 1 (0 points)

    I too have the same problem since upgrading to Mt. Lion and Mail 6.2:


    Message is sent to account B

    Rule moves message to a folder

    Reply to the message is sent from account A (not B as it was/should be).


    All the plist, outgoing surver, library files ideas have nothing to do with fixing this issue.


    How does one get Apple's attention on this - I have 10 accounts, upgraded two days ago and I'm going absolutely nuts.

Previous 1 20 21 22 23 24 Next