Previous 1 2 3 4 Next 116 Replies Latest reply: Jul 31, 2014 1:08 AM by aminasadi Go to original post
  • dselevan Level 1 Level 1

    I was just at apple store and genius said that happened to him also. He said to tell the computer not to put hard drives to sleep in power settings.

  • ellisonjay Level 1 Level 1

    Kinda sounds to me a little like: "If the air is bad, hold your breath for the rest of your life..."  =)

  • ttrq01 Level 1 Level 1

    I am havine same issues with my 2011 i7 MBA.  It will not come out of Sleep without rebooting. I tried the Preference tweak that the Apple guys told the other user here (don't sleep the SSD's) wihch didn't work.  I am not going to run Unix commands to fix this--Apple needs to get a patch out or tell us how to tweak the preferences.

  • ellisonjay Level 1 Level 1

    @ttrq01 Here is the problem. The default sleep modes on all shipping Macs are 0, and 3.  If you're not in 0, or 3. You're not btw if you're having this issue. Then as they say quite clearly on the man page for pmset, it is "not supported."


    They are not going to "patch" this as it's "not supported", and you should not be in an unsupported configuration unless a 3rd party app made it so. (me assuming) Thus Apple has done nothing, and the blame rests with the app at fault. So I might suggest you figure out the offending app, and send the dev some hate mail. (or kindly ask for an update either will do)

  • ttrq01 Level 1 Level 1



    Thx for the advice and counsel. Guess I am configuring the kernel afterall.  :-)


    Some questions...


    1) can I find out what mode I'm in or should I just change it to 0 or 3?

    2) what is your recommendation -- 0 or 3?

    3) will the offending App keep changing this?

    4) how can I find out offending App?


    Thx again!

  • ttrq01 Level 1 Level 1

    Never mind #2 above. I saw your post. I have MBA so I should select 3?

  • ellisonjay Level 1 Level 1

    I have a MBA too, and I use 25. 3 is the supported mode.


    when in doubt type `man pmset` `pmset -g` shows your current settings.

    Mine did, so I removed it. It was called deepsleep.

    After you repair it, and confirm it's working. Be aware what apps you used if the problem reappears.

  • carlos134 Level 1 Level 1

    I have a 13 inch MId 2011 MBA (SSD) and I am having the same issue. My MBA won't wake up from sleep.

    I checked the my hibernation setting and it was set to 3.  After reading your post I changed it to 25, and again it wouldn't wake up from sleep.


    Now, I have to shutdown the computer everytime to avoid the force shutdown out of hibernation. I called Applecare and they couldn't help me out. It's very disappointing on Apple. Let me know if you figure out something else...

  • ttrq01 Level 1 Level 1

    Thx. Will try your suggestions.

  • ellisonjay Level 1 Level 1

    @carlos134 did you try this: first? I did this before looking at my pmsettings. I have seen others reset their pram as well.

  • w.engelsman Level 1 Level 1

    I have the exact same issues with my 2010 MBP (13"). I Have tried resetting the SMC, PRAM and the hibernate settings. Nothing works. Very annoying. I might have to downgrade back to lion for this.

    Some more information: I have not installed any programs what so ever. This was a complete clean install. The problem started occuring a few days after an upgrade, so I decided to perform a clean install. This did not solve the issues.


    Message was edited by: w.engelsman

  • ttrq01 Level 1 Level 1

    fwiw, I was already showing a "3" hibernate setting.

  • ellisonjay Level 1 Level 1

    @ttrq01 The post I read some where said that the power managment settings got corrupted for him. So he "set" them again, and it fixed his problem.

  • dselevan Level 1 Level 1

    I think unplugging my iMac for 10 minutes fixed it.

    I think it is an enhancement, whatever it is doing, it is turning my LaCie external hd off better now, so my room is much quieter during sleep mode.

  • ttrq01 Level 1 Level 1



    My problem has now been fixed!  I called Apple Technical support and after 2 hours with Level 2, everything is now in order.  I can Sleep the system and Wake it without any issues.  I have been testing it all evening and all is working fine.


    Apple thinks there was a corruption in one or more of the preferences files in the Preferences folder associated with the user account giving me troubles (we determined that my other account was able to sleep/awake fine).  They believe that the corruption happened when I upgraded from Lion last week.  We slowly rebuilt all of my preferences and we were never able to find the offending file but all is now working. 


    In some cases we put back the original preferences files and in other cases it was simple enough to just reset the preferences for an App.  Apple initially tried a number of the remedies discussed in this thread without any success.


    Thanks to all of you for your assistance!

Previous 1 2 3 4 Next