Previous 1 4 5 6 7 8 Next 116 Replies Latest reply: Jul 31, 2014 1:08 AM by aminasadi Go to original post
  • v.danchenkov Level 1 Level 1

    For me the problem was fixed with MacBook Air and MacBook Pro Update 2.0

  • ChrisWRX Level 1 Level 1

    This update fixed mine too.  Hope that helps someone.

  • aminasadi Level 1 Level 1

    The link is broken

  • sitongia Level 1 Level 1

    That's strange.  I just did a search in the Apple Support web pages, the page came up, I clicked on it and was shown that the link is broken.  Then I did the search again, and it is gone from the search results (I guess they have something to remove broken links from search results).


    Since applying the update to my MBA mid-2012, it won't go into standby mode, with hibernatemode 3 and standbydelay at the default 4200 (BTW, what is the parameter "standby", which has a value of 1)?


    Other new strange behavior since the update, but I won't go into that at the risk of hijacking this thread.



  • sitongia Level 1 Level 1

    Thinking that my MBA won't go standby because it is plugged into USB and the cinema display (but everything plugged in is powered off, and Power Nap is off), I uplugged everthing, set hibernatemode to 25 and closed the lid.  Open it back up, and it wakes up just like with hibernatemode 3.  It wakes really fast.  Is the flash disk that fast?  I expect to see the disk hibernate restore graphic going across the screen like my last hard-disk based MBP.


    In other words, hibernatemode 0, 3 and 25 all appear to behave the same to me, including when the MBA has been off (lid closed) overnight.



  • sleepystu Level 1 Level 1

    Same issue:

    - After upgrading from Lion to Mountain Lion (now 10.8.2), cannot wake from any recommended hibernation mode (hibernatemode = 3 or 25).



    - Macbook (late 2008) will not wake from hibernation. System becomes unresponsive at user login screen and screen goes black (but is still powered) after about 20 seconds. Must then hold down power button to shut down.

    - Occurs when hibernatemode set to 3 (after power failure) or 25 (unplugged).


    Temporary "Solutions" that work:

    - Set hibernatemode = 0 (not ideal for a latop, re; when battery dies, must restart).

    - Issue was resolved when a new admin user account created (i.e., default hibernatemode 3 works after battery dies and hibernatemode 25 works when unplugged).



    This means that it is likely at the user level, and likely caused by some other software or conflicting user setting.

    Given that it is specific to the user account, I am not hopeful that a future OS X update will resolve the issue. Also, since all my software seems to work fine, I am not hopeful that a software update will resolve it either. Unfortunately, the only resolution might be to fresh install (without migration!) or to set up a new user account to replace the broken one, and manually reinstall apps and manually move over user files and prefs.

  • ChrisWRX Level 1 Level 1

    I was wrong.  The issue was not solved for me by the updates.


    I did a clean install because I was thinking it was finally solved, and unfortunately the issue came back.  Just to be clear, I started over.  The only migration I did was to allow iCloud to do it's thing.  I redid all my installs, and preference settings one by one.  I thought it was fixed, because I was not able to reproduce the crash by putting the mac to sleep with hibernation settings of 3, or 25.  After about a week my Retina MacBook Pro crashed while sleeping.  At that point I was able to reproduce the crash every time.  So, it seems to come back after a while.  I'm not sure what changed because by the time it came back I was pretty much done reinstalling stuff, and I wasn't watching for the crash any more.  This is relly annoying, and I've given up dealing with it.  I'm just leaving my MacBook set to hiberantion mode 0.


    What's odd is that it doesn't happen on my Mac mini, or my wifes MacBook Air.

  • FleshFear Level 1 Level 1

    I found out that if you make a new user after the installation and use that as the default user it fixes the problem... test now both on a old system and a complet reinstall....

  • sleepystu Level 1 Level 1


    - Since in my previous test (Dec 2, 2012 10:43 AM) hibernatemode =3 and 25 worked with a new user, so I did some more testing to see what could be the difference between my account and a new user account.

    - I found some obvious stuff and some weird stuff that RESOLVED THE ISSUE!

    - First, the obvious. I deleted all of the "Login Items": (System Preferences > Users & Groups > Login Items).

    - Socond, I deleted all of the "Aliases": (System Preferences > Users & Groups > Advances Options). You have to unlock the preference pane first, and control-click the your user account to get the "Advanced Options" menu item. This was the weired part. I had all sorts of aliases in there: some 64-digit alphanumeric strings, duplicates of my account, other strange phrases, etc... This seems like a very strange list of items for user account aliases, so if anyone knows why these were created in the first place, that may shed light on the issue.



    - On my late 2008 Macbook with 10.8.2 installed and Filevault 2 enabled, Hibernatemode 3 and 25 now works after the battery dies.


    Further testing:

    - I have no idea wether it was deleting the login items or deleting the weird aliases, so I will be re-enabling the login items one at a time to figure if one of them was the cause. The aliases are gone for good, so if it is none of the login items causing the problem, it will have been that. If it is one of the login items, one of these software vendors is going to get an earful from me.

    - Here is a list of the login items that I had enabled:

         - Caffeine

         - FFHelperApp

         - BetterTouchTool

         - Yoink

         - Alfred

         - BetterSnapTool

         - Connect360Helper

         - CleanMyDrive

         - TotalFinder

         - Dropbox

         - I also had an encrypted image in the list.


    - I'll reply to this when I get it sorted out.

  • sleepystu Level 1 Level 1


    - I still have my Macbook working with Hibernatemode = 3 or 25.

    - It seems the weird aliases were likely not the cause, although I saw no harm in deleting them, as I don't know whay they could possibly have been for - and may have even posed a security issue.

    - The ONLY login item that was causing an issue was the "FFHelperApp" which is for the application "Function Flip". Not surprising... since this app is NOT supported for Mountain Lion. I have since uninstalled it.



    - I can't imagine that everyone experiencing this issue has Function Flip installed, but maybe it is related to any number of apps that are automatically (or have been added manually) to the Login Items.

    - If the issue reccurs, I will repost, but for now, it seems the issue has been resolved by carefully troubleshooting Login Items.





  • dickies Level 1 Level 1

    I have the same problem, but on a MacPro. Wake from sleep in the apple menu works fine, although slower than before. Wake from hibernation fails ofter and I need to do a hard stut down and start up again to get access.

  • tellboy246 Level 1 Level 1

    On my late 2008 MacBook Pro I have been continually having issues since upgrading to Mountain Lion.


    If I let it sleep overnight with or without power it would just show a black screen in the morning and I would have to press the power button to shut it down and reboot.


    I have been tearing my hair out over this issue.


    I stumbled on this link a few days ago



    It made this suggestion.


    "If your system is set to use hibernate mode and store the contents of RAM, then the SMC will also use a hibernation file, which is located in the folder designated by the hibernatefile variable for the SMC (usually the hidden /var/vm/ folder). To see this file, in the Finder choose "Go to Folder" from the Go menu, and then enter /var/vm/ in the field. When executed you will see a file called "sleepimage" that is the same size as the RAM in your computer (in other words, 4GB or 8GB if you have that amount of RAM installed).

    If for some reason your system is not going into hibernation mode, or shuts down and reboots instead of restoring to a working state after going into hibernation, then you might benefit from deleting the sleepimage file in the /var/vm/ folder and allowing the system to recreate it."

    I deleted the file as suggested and since then I have not had any sleep issues.

    This suggestion may be worth a try for those still having issues.


    All the best

  • sitongia Level 1 Level 1

    I have hibernatemode 0, and yesterday I happened to keep my MBA (mid-2012) on (lid open) all day while it was backing up to an erased disk (because I've been having USB problems since EFI update 2.6, and the disk was corrupted).  I have energy saver set to sleep after 3 hours while on power (and the backup would take 2 hours).  When I got back to it later in the day, it was asleep and would not wake up.  Had to power-cycle it by holding the power key down for a long time.

  • Paul_31 Level 6 Level 6

    When I had the failure to wake from sleep problem from some point in OS X 10.6.x through to 10.8.1 the only 'fix' that worked for me 100% of the time was: System Preferences>Energy Saver and set 'computer sleep' to 'never'.

    Since I've been on 10.8.2 the problem has gone away but looking at these forums it seems that some are still affected.

  • williamrice Level 1 Level 1

    Thank you aqnguyen87 - installing the latest firmware for my OCZ Vertex 2 has completely resolved sleep related issues on my Mac Pro 4,1 running Mountain Lion 10.8.2 - great suggestion!

Previous 1 4 5 6 7 8 Next