Previous 1 2 3 Next 30 Replies Latest reply: Mar 7, 2013 6:09 AM by ath.pap. Go to original post
  • Ravindra Holalkere Level 1 (105 points)

    I assume you have MS Office for Mac on your machine... if so, run MS Autoupdate to see if there is an update you can install for excel. Perhaps it will work out same as with LindaSMu after the OOO update she did.


    I assume you have tried repairing permissions

  • LindaSMu Level 1 (0 points)

    Yes. "Interesting" is an interesting word!

  • Tony@Mobile Level 1 (0 points)

    I had this too. After some experimenting, I could select from the Archive app, and Text edit, but not Open Office.


    I think the issue is in your security settings, which have changed with Mountain Lion. Go to the Settings app and select Security and Privacy. Click on the 'Allow applications downloaded from anywhere'. The default is to only allow those downloaded from the App store and identified developers. You will need to log in as an administrator to do this.

  • LindaSMu Level 1 (0 points)

    My problem was solved when I updated to the latest Open Office software and clicked on "Allow applications downloaded from anywhere." It was a long, frustrating series of exercises, trying a variety of fixes, but this worked for me.

  • Lost in Asia Level 3 (540 points)

    Thanks for suffering the pain for all this - your pain likely saved me many hours of trying to figure out what was going on when I had the same problem!


    Note that, rather than totally changing to "Allow applications from anywhere", you can just allow an exception for OpenOffice (copied from somewhere in Mac's Help Center):


    1. In the Finder, locate the app you want to open. Most apps can be found in the Applications folder.
    2. Press the Control-key and click the app icon.
    3. Choose Open from the pop-up menu.
    4. Click Open.

    The app will be stored as an exception to your security settings, and you will be able to open it in the future by double-clicking it.


    I did it this way, although to be honest the whole "unidentified developer" thing is proving so annoying I may soon switch it off anyway.

  • LindaSMu Level 1 (0 points)

    Glad it was helpful. As I remember now (it was August when I had the problem), I did just allow the exception for OpenOffice. Good to go until the next glitch!

  • eh45 Level 1 (0 points)

    Same problem here. Could change "always open with" to any app except OO.


    After a clean installation of ML I had installed OO3.4 at first but then deinstalled it *)  using app cleaner; then installed OO3.3.0 which always worked fine in snow leopard and lion.

    Reparing permissions (none found) and "allow apps from anywhere" made no difference.


    How do I get rid of ALL OO related system files and settings when I deinstall (plists, etc or whatever they are) - I have the suspicion that this may resolve the issue.


    *) on my system OO3.4.1 crashes when saving as .doc. Also did on lion.

  • LindaSMu Level 1 (0 points)

    Here is the advice that was given to me several months ago.  (I have OS X 10.8.2 and am using OpenOffice 3.4.1.) The info below worked ONLY when I upgraded to 3.4.1. Good luck -- and thanks, again, to the person who helped me!


    Select the document in Finder, right click (control click) to get the contextual menu, choose Open With. A list of typical apps for the doc type would be visible. DON'T choose directly from there. Instead, click on Other at the end of the list. This will open a Choose Application window; select 'All Applications' in the Enable dropdown. Choose OOO and check the 'Always open with' option.

  • amadasoy Level 1 (0 points)


    just want to say, that i am having a similar problem. only with some differences.


    i upgraded my older mac to ML recently, and OO (version 3.3) had no problem with the transition. no permission problems... odt files still open with OO. yay!


    however, on my NEW mac which of course came with ML installed... i installed OO (version 3.3), since that's all i had on hand, and can't make it the default for opening .odt files, as mentioned by other users above.


    one problem is, my issue might be solved easily if i had internet access, but i can't connect because of another problem w/ the new mac (ie, java SE 6 not having come installed on the new mac - actually seems to be an issue with ML because that happened with the upgrade to ML on my old mac as well - and is the reason that i can't install my usb modem on my new mac, urgh!).


    i checked out all the suggestions above, and none have worked. for instance:

    >>get info>>open with>>open office>>change all... just bounces back to textedit and does nothing.

    >>security&privacy>>general>>allow applications downloaded from... anywhere is selected... i had already changed that.

    >>right click>>open with>>oo... well, that's all fine, but i want to NOT have to tell it to do that EVERY. time.

    >>right click>>open with>>other...>>open office>>check - always open with... this is for this document ONLY.


    so. my last idea is to download OO 3.4.1 onto my older mac (that has internet connection), transfer via EHD to my new obstinate mac, and HOPE it works... i'll report back when i'm all done with that.


    VERY annoying because, i absolutely adore OO, and use it CONSTANTLY. i will be quite distressed if this turns out to be an irresolvable issue.

  • eh45 Level 1 (0 points)

    Found the following solution on the web. You won' believe it, but it actually works ( for me at least with a clean install mountain lion and OO3.3).


    Select any .doc file, LOCK it (mark the checkbox in the get info window), then choose  to always  "open with" as described in variuos posts above), and then UNLOCK again. Hey presto!

    Do the same with .xls and any other filetypes.


    Tried all other methods including uninstalling oo3 and apple pages (using app cleaner and  removing all related files i could find manually), upgrading to latest version OO3.4, nothing worked.


    (OO3.4 crashes when saving a doc on ms office doc format, i don' have ms office)


    Good luck, Edwin

  • amadasoy Level 1 (0 points)

    edwin, thanks for trying...


    that doesn't work for me, though i did try again, just in case!

    in the get info window, even though the pull down has open office as an option, when i click it, it auto reverts to text edit. the SAME thing happens when i right click, open with, other..., choose open office, check always use this application. it still reverts back to text edit when i try to open the same document the next time.

    very annoying.


    but i think i'm onto something as far as my problem goes, and if it works, i'll be back to share soon.

  • amadasoy Level 1 (0 points)

    oh, wait!! i was doing something wrong the first try and re-read your post, edwin, and tried again and wham-o!

    it works!!


    here's what edwin was saying, in pictures... i think. anyway, it's what i did. and it worked!!



    just to reiterate.

    >>right click>>get info

    >>sharing & permissions

    1) click unlock (the padlock picture in bottom right corner) - enter admin pasword

    2) check box >> locked -- i don't know if this is irrelevant, but i clicked it when fixing the problem on both of my macs

    3) change the 'open with:' option to OpenOffice (pop up to allow changes) & then go back and undo everything you did previous.



    thanks SO much.

  • MadMacs0 Level 5 (4,700 points)

    Well, I'm glad it all worked for you but...

    amadasoy wrote:


    1) click unlock (the padlock picture in bottom right corner) - enter admin pasword

    That padlock only affects the Sharing and Permissions section of the get info dialog, so it should not be necessary to carry out the other two steps.

  • amadasoy Level 1 (0 points)

    i know. it shouldn't have worked. but then again, it shouldn't have stopped working in the first place!

    i tried it with just clicking the 'locked' box above, without the padlock. i tried the padlock without the locked box.

    and got nothing.


    it could be that somewhere along the way i made a mistake, but in the end that WAS the winning combination!

  • amadasoy Level 1 (0 points)

    oh and ps. it actually does seem that it had to do with permissions, and that was the secret combo to unlock the whole thing, because previously when i tried to change the default program... nothing. but when i unlocked down there before making the changes it asked for the admin password, which was more than i got before. just sayin'.