1 2 3 4 Previous Next 234 Replies Latest reply: Feb 10, 2014 1:39 PM by Wonderkid Go to original post
  • 15. Re: Mountain Lion disconnect from Ethernet in sleep mode
    Itzhak_smurfy Level 1 Level 1 (0 points)

    I have the same problem too.

    iMac 21.5 Mid 2010

    Processor  3.06 GHz Intel Core i3

    Memory  4 GB 1333 MHz DDR3

    Graphics  ATI Radeon HD 4670 256 MB

    Software  OS X 10.8 (12A269)

  • 16. Re: Mountain Lion disconnect from Ethernet in sleep mode
    margate Level 1 Level 1 (0 points)

    Same here

     

     

    Recently after upgrading to Mountain Lion I found that my wired Lan show up as unplugged after sleep, I tried

     

    sudo ifconfig en0 down

    sudo ifconfig en0 up

     

    which seems to execute very fast, but does not work

     

    I tried logout/in,

     

    The only things there help for now is a reboot and offcause shutdown and start next morning works too.

     

    iMac 27 May 2011

    Model Identifier 12,2

    Model Number A1312

     

    LAN is 1Gb

     

    I still have Lion on another partition which works perfectly

     

    I suspect a driver issue, so how do I reload the Network LAN Driver

     

    Any Idea's will be appriciated

  • 17. Re: Mountain Lion disconnect from Ethernet in sleep mode
    megabyzus Level 1 Level 1 (0 points)

    Hey folks, I have this problem solved.  I purchased a 2011 iMac for iOS development a few days ago (I'm brand new to Apple products). I need to access it remotely (from outside my home network) from my win 7 computer because of my work logistics.  Here is what I do:

     

    - Installed logmein on it and set proper port forwarding on router. (I assume you have this done properly)

    - installed UltraVNC viewer on my win 7 and set IT'S port forwarding on the router as well. (there is a simple alternative to this.  See NOTE below)

     

    Now I do realize have TWO VNC systems, BUT when I kick off UltraVNC viewer on my win 7 PC it does WAKE ON LAN my sleeping iMac successfully.  I immediately quit from it and use logmein because I like its interface better and it's faster too. I continue to use Logmein on my PC and it accesses my iMac properly. I use it consitently and it works relatively well.

     

    NOTE: Instead of UltraVNC, I also have installed a wake on lan app on my android and it is able to start my iMAc through wireless (not wi fi) consistently, i.e. it is remote and outside of my network. So alternatively, you can use this instead of UltraVNC installed on your remote computer.  If you do go with UltraVNC make sure you don't use CNET's installer--it's a spam installer.  Use UltraVNC's own installer (instructions available on their forums and they warn of this as well).

     

    I hope this helps!

  • 18. Re: Mountain Lion disconnect from Ethernet in sleep mode
    margate Level 1 Level 1 (0 points)

    A few days ago, are you sure it's is a Mountain Lion, not sure at all it reach the stores in a week.

     

    Anyway to took your idea and tried to wake from LAN, No Luck

     

    There is link on she switch of mine, but status is still unplugged in OSX and ifconfig show

     

    en0: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500

              options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>

              ether 40:6c:8f:04:b8:db

              media: autoselect (none)

              status: inactive

     

    vs.

     

    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

              options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>

              ether 40:6c:8f:04:b8:db

              inet6 fe80::426c:8fff:fe04:b8db%en0 prefixlen 64 scopeid 0x4

              inet 192.168.1.6 netmask 0xffffff00 broadcast 192.168.1.255

              media: autoselect (1000baseT <full-duplex,flow-control>)

              status: active

     

    also i use DHCP (reserved)

  • 19. Re: Mountain Lion disconnect from Ethernet in sleep mode
    margate Level 1 Level 1 (0 points)

    Folks,

     

    I filed a bug report, so lets see what happens

  • 20. Re: Mountain Lion disconnect from Ethernet in sleep mode
    JRH321 Level 1 Level 1 (0 points)

    I had this problem with Mountain Lion.  I hardcoded my WIFI router to use Channel 11 instead of Automatic (I found it was on Channel 6) and it fixed it.  I think it is either a bug in the search algoritm ot there is a timeout for channel searching that is wrong.  In any case a hardcode to Channel 11 fixed it.

  • 21. Re: Mountain Lion disconnect from Ethernet in sleep mode
    megabyzus Level 1 Level 1 (0 points)

    I had this scheme running both on Lion AND I have it currently runing on my very recent Mountain Lion install. I was never able to WOL using Logmein alone (I think even Logmein acknowdledges that).

     

    Unless there is something wrong with your particular unit/iMac, I would focus on getting WOL working on it first (I have an iMac and have changed my Preferences in Energy settings to allow WOL.) before moving on to Logmein.(or whatever VNC).

     

    I use an Android app called 'Wake on Lan' to WOL my iMac externally (there are many). Since you're WOLing externally, make sure you use your iMac's GLOBAL IP address (lots of online sites available to easily find that) and the port you have opened for that app on your router. Use THAT ip address and THAT port on the WOL app (or for the installed UltraVNC on your PC). This particular Android WOL app also requires your iMac's MAC address (find it from 'About Your...' on your iMac unit). You need all three for an external/nonhome WOL. Also make sure you have the proper ports forwarded on your router to your iMac's INTERNAL/HOME IP address.so when the router gets an external WOL signal it routes it properly internally to your iMac unit to wake it up.  Each WOL app uses a different 'well known' port.  The 'wake on lan' Android app, for example, uses port 9 so port 9 needs to be forwarded on your router to your iMac's INTERNAL IP.  On the other hand, UltraVNC that I use normally, (installed on my PC) need ports 5900 and 5800 forwarded on the router if I recall correctly (please confirm yourself).

     

    BTW, judging from the posts here, I would wager, the bug's with Logmein rather than Mountain Lion.

     

     

    I hope this helps.

  • 22. Re: Mountain Lion disconnect from Ethernet in sleep mode
    megabyzus Level 1 Level 1 (0 points)

    *EDIT*:  I just noticed you have different generations of iMacs from mine.  As such, it very well could be a problem with your units.

  • 23. Re: Mountain Lion disconnect from Ethernet in sleep mode
    margate Level 1 Level 1 (0 points)

    In my case it is the WIRED Ethernet, I dont use Wifi.

     

    @medabyzus, recognize that all the others didn't had issue prior to Mountain Lion upgrade, so it is hardly a HW issue, also Lion is workning where folks tried it incl me.

     

    1st post is about accessing iPhone and other computers from iMac, a few of the post is about remote access incl you, but it seems to be the same issue? within OSX 10.8

     

    So put your imac to sleep in afternoon, wake it up next morning with mouse/keyboard and check your network

  • 24. Re: Mountain Lion disconnect from Ethernet in sleep mode
    cbratschi Level 1 Level 1 (0 points)

    I have the same problem with my Mac Mini (2011 edition). All my servers were down after upgrading to Mountain Lion. Only switching off sleep mode helped. I am using a cable connection.

     

    Lion never activated sleep mode but ML does. The sleep mode criteria surely have changed.

  • 25. Re: Mountain Lion disconnect from Ethernet in sleep mode
    megabyzus Level 1 Level 1 (0 points)

    @margate,  I didn't say it was a HW issue (although possible).  I implied it might be the new OS misbehaving on these different machine. 

     

    But to re-iterate, my iMac 2011 (purchased a week ago which I promptly updated to Mountain Lion) is consistenty WOLing and I am consistently able to you Logmein.  Again, I was never able to WOL with Logmein alone and I always had to use another mechanism to WOL before using Logmein, in my case 'wake on lan' app on my Android or UltraVNC o my PC.

     

    I have had my machine asleep many many times and have always been able to WOL it remotely regardless of how log it's been asleep and when.

  • 26. Re: Mountain Lion disconnect from Ethernet in sleep mode
    chmeul Level 1 Level 1 (0 points)

    Did you try to reorder the network devices order as suggested in:

     

    https://discussions.apple.com/thread/3290988

     

    For me this solved the problem.

  • 27. Re: Mountain Lion disconnect from Ethernet in sleep mode
    margate Level 1 Level 1 (0 points)

    Hi Gents

     

    I increased the DHCP minimun lease time from 2 hours (7200 sec) to 7 days (604800 sec) and DHCP maximum lease time from 1 day (86400 sec) to 8 days (691200 sec) on August 6th, my iMac has been to sleep 4-5 times, doing these I haven't lost access to my wired LAN on resume

     

    I'll Keep monitoring....

  • 28. Re: Mountain Lion disconnect from Ethernet in sleep mode
    hilltop415 Level 1 Level 1 (0 points)

    margate...having the same problem described here with ethernet...brand new imac with ML.  How do you change the DHCP lease times you've described and is it still working for you?  Thanks.

  • 29. Re: Mountain Lion disconnect from Ethernet in sleep mode
    margate Level 1 Level 1 (0 points)

    Hi

    The DHCP change turned out to be better, but it didn't solved the loss of network, however I also noticed that my iMac didn't really went to sleep (black screen, a few clicks, but no sleep), so I followed this (2nd reply)  to verify disks, SMC Reset and rebooted in Safe mode to clear some caches.

     

    This worked for me (3 days), doing resume and a ifconfig right after, the interface has no IP address, seconds later it has it, so iMac sends a DHCP request on resume, no matter the lease time.

     

    @hiltop415, it is in the routers DHCP settings, but try this first.

1 2 3 4 Previous Next