Previous 1 2 3 Next 43 Replies Latest reply: Jan 26, 2016 11:29 AM by LuckyKnuckle7
TMcJilton Level 1 (0 points)



   I recently upgraded to Mountain Lion and upon performing a clean install, I decided it was a good idea to start fresh with my external HDD which I use for Time Machine. After backing up my files from the external HDD, I used Disk Utility to perform an erase. However this drive, whcih was "encrypted", had some kind of an error while erasing and now I cannot seem to unlock the drive.


When I connect the drive it does not show up in Finder. When I open Disk Utility, the drive shows up, but will not allow me to make any changes. All of the tabs are gone except for first aid and partition, and it will not allow me to create a partition on the drive. It says "The partition contains a locked disk and can not be resized until it is unlocked".



MacBook Pro, Mac OS X (10.7.2)
  • GeertN Level 1 (0 points)

    I have the same problem but with my Macbook Air's internal SSD. So basicaly, i cannot install Mountain Lion on my computer. I'm looking forward to a solution.


    I wanted to erase my (encrypted) partition and make a new (encrypted) one. Then I got a failure message, the partition was gone and well like I said, I cannot make a new one.

  • wesfina Level 1 (0 points)

    I'm having this exact problem. All options are grayed out in disk utility

  • GeertN Level 1 (0 points)

    I have found a fix that worked for me. I booted from the recovery disk, from there I could still see my partition. I erased it an made a new one.


    My source: ypt-your-filevault-2-encrypted-boot-drive/



    Good luck!

  • TMcJilton Level 1 (0 points)

    I have actually tried this. I booted the recovery disk, and used disk utility from there but it is still locked.

  • wesfina Level 1 (0 points)

    Luckily I have another Mac and was able to boot the problem Mac into target disk mode and run disk utility on the working Mac. Was able to erase the partition no problem then. Mountain lion installing now. Hopefully you can find access to another mac

  • TMcJilton Level 1 (0 points)

    So I have fixed the issue and wanted to share my method, and results. I had access to another machine, and uesd a third party disk utility program to delete the partition and start fresh. If I had known my drive had a USB port as well as the Fire Wire that I use for my Mac, I would have simply done this from the beginning. In any case, it seems that for whatever reason OS X's Disk Utility didnt have the capability of simply deleting the partition.

  • Eddie Yam Level 1 (0 points)

    I got the same problem with my external HDD (with 2 partitions) while I was using one of the encrypted partition as Time Machine backup. I could not erase it after I upgrade to Mountain Lion, and it shown "this patition contain a locked disk and can not be resized until it is unlocked" in Disk Utility.


    Finally I get it fixed by the "diskutil" command in "Terminal" in "OSX > Applications > Utilities".


    I used the command "diskutil" to verify the UUID of the "Logical Volume Group (LVG)" of the locked partition.

    Screen Shot 2012-08-03 at 11.04.04 AM.png

    Then use the command to delete the LVG.

    ** All logical volume under this groiup will be deleted!!

    Screen Shot 2012-08-03 at 11.05.15 AM.png


    Once the operation finished, I am able to recreate the partition in Disk Utility.


    Hope this help!!

  • DmncnGy Level 1 (0 points)

    This solution is a much better approach than grabbing the disk and using a partition tool on another machine. Thank you, worked for me. (This is for the solution Eddie Yam posted.)

  • Seth Loktar Level 1 (0 points)

    Eddie's solution worked for me too. Took me about an hour to find this thread, and 2 minutes to regain access to my HD. Thanks!

  • Gordito73-me Level 1 (5 points)

    My apologies for "hijacking" this thread but looks like you all know what you are talking about and I have searched the web for over an hour without finding a solution to my problem. Maybe Eddie Yam can help me.


    I had an external HDD where I stored encrypted secondary backup of my iMac. After upgrading the iMac to Mountain Lion I brought the HDD from remote location to update the backups on it. Time Machine stated there is not enough room in the volume, so I just went to Disk Utility and erased it. I am very well organized and I knew I could just wipe the disk clean as I have another functional backup. Not so smart. Now I have the external HDD mounted but I can't use it for back up and I can't reformat or repartition it. (see below)


    Screen Shot 2012-08-06 at 21.26.49.png

    It states that "This partition contains a locked disk and can not be resized until it is unlocked" I tried to used the method Eddie suggested but I get the following:

    Screen Shot 2012-08-06 at 21.26.53.png

    I appreciate your help in unlocking my external HDD and making it useable again. Thank you.

  • Eddie Yam Level 1 (0 points)

    According to the screenshot attached, the UUID should be the long string follow by "Logical Volume Group", which is "6B88...8BE2", let's try to amend your command by replace "UUID" to "6B88...8BE2".


    Hope it helps!

  • Gordito73-me Level 1 (5 points)

    Thank you Eddie, that helped. Also, I was using the wrong command, I had to type in "diskutil corestorage delete 6B885E57-6D7E-4CB6-B2AA-507DD9A58BE2" Thank you very much for your quick reply.

  • ec92009 Level 1 (0 points)

    You saved my 1.5 tb external HDD. Thanks.

  • lost9505 Level 1 (0 points)

    hi this is the thred ive been looking for, for two days. Eddie im a super noob and so good with termial can you send me a list of commands to use to reclaim my harddrive. its a seagate 1tb external and im pretty sure i deleted a partion or something in it because now all it says in disk utility is Expansion and i cant mount or format or partion please help ive included a screen shot.


Previous 1 2 3 Next