Previous 1 2 Next 18 Replies Latest reply: Mar 10, 2013 8:22 PM by Ca Ike
bhadash Level 1 Level 1 (0 points)

I accidentally disconnected my iPod Classic before it ejected from my Mac (OS 10.6.8 and iTunes 10.6.3).  The iPod plays fine, but when I connect it to the Mac, although the iPod screen reads "connected, eject before disconnecting", it does not show up either on the desktop (I keep it in disk mode) or in iTunes. I reset it three times.  I also tried a different USB port.  Neither resolved the problem.  I cannot restore it to factory setting since it does not show up in iTunes.  I have no idea what to do to try to fix the problem.


Mac OS X (10.6.8)
  • planb77 Level 7 Level 7 (32,290 points)

    By a reset I assume you mean pressing and hold both the Select (Center) and Menu buttons together long enough for the Apple logo to appear?

     

    Have you tried using a different USB cable to help rule out a damaged/faulty cable?

     

    Otherwise, work through the remaining items in this Apple support document.

    iPod not recognized in iTunes and Mac desktop

     

    B-rock

  • bhadash Level 1 Level 1 (0 points)

    Thank you for the suggestions.  By reset I do mean that I pressed Select and Menu simultaneously and waited for the Apple logo.  I also did try a different cable.  That did not work either.  I also checked to make sure the software was up-to-date and went through the suggestions found in the link you referred to, but the problem remains. 

     

    Our iPod Touch and iPhone have no problems (same cable, same computer, same USB, etc.).  The issues are just with the iPod Classic so I assume I messed it up somehow when I disconnected it without ejecting it first.

  • planb77 Level 7 Level 7 (32,290 points)

    Check the iPod's dock connector port for any signs of damaged/bent/corroded pins.  If there is any debris lodged in there, take a can of compressed air to it to try and blow it out.

     

    Can you try and connect the iPod to another PC or Mac to see if it's recognized properly on that machine? This will help determine if it's an iPod issue or Mac issue.

     

    B-rock

  • bhadash Level 1 Level 1 (0 points)

    I greatly appreciate all of your suggestions.

     

    I connected the iPod to our laptop, but the same thing happened: the iPod screen showed the message "connected, eject it before disconnecting", but the device did not show up on the laptop's desktop and nothing happened when I opened iTunes. (Since the iPod is not showing up on the Mac, the only way I seem to be able to safely disconnect it is to shut down the computer.  Then the iPod screen notes that it is safe to disconnect.)

     

    The iPod's dock connector seems okay as far as I can tell from looking at it.  Also, I am currently using it with some speakers that use the dock connector port and it is working fine.  So that seems to confirm that all the pins are okay and there is no debris getting in the way.

  • planb77 Level 7 Level 7 (32,290 points)

    Well something still points to the issue with the iPod and it's dock connector if it's not working properly on either machine.  Do you have another USB cable if you can try?


    What happens if you manually force the iPod into disk mode?

    http://support.apple.com/kb/HT1363

     

    Does the iPod anywhere in Device Manager when it's connected?

     

    B-rock

  • bhadash Level 1 Level 1 (0 points)

    I have tried a different USB cable, but it did not solve the problem.

     

    I keep the iPod in disk mode so I can add and edit notes that I keep on it, but I did follow the directions in the link you provided.  It went into disk mode okay.  When I connected it to the computer, I again got a "do not disconnect" message, but the iPod again did not show up either in iTunes or on the desktop.

     

    I do not know what Device Manager is and I could not find it on the Mac.  Your question, however, prompted a memory of disk utility.  When I pluged the iPod into the computer and opened disk utililty, the following showed up on the left side in black "79.82 GB Apple iPod Media" and under it is the greyed out name of the iPod.  If I click on the name of the iPod, the following information shows up:

     

    Mount Point: not mounted

    Format: Mac OS Extended (Journaled)

    Owners Enabled: -

    Number of Folders: -

    Capacity: 79.82 GB (79, ... Bytes)

    Available: -

    Used: -

    Number of Files: -

     

    If I click on the "79.82 GB Apple iPod Media" (as noted above, this is in black above the greyed out name of the iPod) I get the following information:

     

    Disk Description: Apple iPod Media

    Connection Bus: USB

    Connection Type: External

    USB Serial Number: 000A...

    Total Capacity: 79.82 GB (79, ... Bytes)

    Write Status: Read/Write

    S.M.A.R.T. Status: Not Supported

    Partition Map Scheme: Apple Partition Map

  • planb77 Level 7 Level 7 (32,290 points)

    Perhaps it would help to try and complete a low level reformat of the iPod's hard drive using Disk Utility.  See this page for instructions.

    http://www.methodshop.com/gadgets/ipodsupport/erase/

     

    B-rock

  • bhadash Level 1 Level 1 (0 points)

    I will need to think about it a lot before I use Disk Utility.  The directions in the link are for erasing the iPod.  Although I am currently unable to update the iPod, sync it, or change any of its content, it does play perfectly using both earbuds and an external speaker.  Therefore, I can still access and use all of its content.  My concern is that if I erase it using Disk Utility and then it continues to not show up in iTunes, it will be left with nothing but a dead device.  So this is a decision that will require some delibration.

  • planb77 Level 7 Level 7 (32,290 points)

    It sounds like you don't have iPods set up to show mounted on your Mac's desktop.  To enable this head to Finder -> Preferences and make sure there is a tick mark next to CDs, DVDs, and iPods under Show these items on the desktop.

     

    If it does show as mounted after that, see this article before deciding to go for the low level reformat.

    iPod does not appear in iTunes or iPod updater in Mac OS X

     

    B-rock

  • bhadash Level 1 Level 1 (0 points)

    The Finder preferences have been set appropriatelly for years and the iPod has always mounted on the desktop fine until a week ago.  I did check to make sure no one had changed the preferences, but they are still set appropriately.  Thank you for the suggestion, however, because I would not have checked otherwise.

  • planb77 Level 7 Level 7 (32,290 points)

    Did you see that article I linked above as well?  I'm running a little low on other possible suggestions.  None of these seems to add up for some reason... :S

     

    Instead of doing the reformat option, you could also try to first repair the iPod's hard disk instead.

     

    B-rock

  • bhadash Level 1 Level 1 (0 points)

    I did see the article.  The article itself seemed to be for when an iPod appears in the Finder in Mac OS X, but does not appear in the iTunes Source list, which is not the case for me.  Mine is not showing up anywhere.  Unfortunately, when I went to the articles link for "If iPod is not showing up anywhere, then try these steps first", it ultimately brought be back to steps I have already tried. 

     

    I also clicked on the grey name of the iPod in Disk Utilities and then clicked on Mount, but I got a message stating that the iPod could not be mounted.  The message suggested running First Aid, but when I checked on-line I found the following information (http://support.apple.com/kb/HT1782):

     

    You may experience some issues if you try to verify or repair any unmountable, non-startup disk.

    Issues may occur if you try to verify or repair unmountable disks

    Disk Utility may stop responding without displaying an error message, or stall your computer for several seconds, when trying to verify or repair some non-startup volumes that can't be unmounted.

    If you try to verify a volume that is not your startup disk but for some reason Disk Utility can't unmount the volume (for example, the disk may have open files), the verification will appear to start but then stop without displaying any alert message. If you look in the Console (/Applications/Utilities/), you will see an entry like this:

    Verifying volume “Storage”
    The disk “Storage” could not be unmounted
    Could not unmount disk for verification, attempting live verify

    If you try to repair a disk that cannot be unmounted, the repair will appear to start, but then stop as Disk Utility displays this message: "Repairing disk failed with error. Could not unmount disk."

    It also stated, Once you start a Live Verification, you may not be able to cancel it, depending on how far along it has progressed --- and that concerned me.

    If I am reading the above correctly, it does not seem as if Disk Utilities will work if the device is unmountable.  Also, I am concerned about doing something that might damage the iPod further.

  • planb77 Level 7 Level 7 (32,290 points)

    Sounds like there is a possibility of a damaged hard disk. 

     

    Try and do a disk diagnostic as described by turingtest2.  The post also explains what each of the numbers mean.  Your iPod's hard disk could be dying.

    https://discussions.apple.com/thread/3784647?start=0&tstart=0


    B-rock

  • bhadash Level 1 Level 1 (0 points)

    You have no idea how much I appreciate all of your help.  This is what I got for numbers and, if I am understanding them correctly, I think they are okay:

     

    Retracts: 1

    Reallocs: 0

    Pending Sectors: 0

    PowerOn Hours: 26

    Start/Stop Hours: 2563

    Temp: Current 35c

    Temp: Min 7c

    Temp: Max 53c

Previous 1 2 Next