Previous 1 2 3 Next 39 Replies Latest reply: Oct 20, 2014 10:12 AM by Skjeflo Go to original post
  • °Bernz° Level 1 (10 points)

    I know this sounds weird, but I did get some lag on my new account from time to time. After a few weeks, it became fast.

     

    ...

     

    I suspect that the iCloud data center has something to do with it, because I didn't change anything afterwards and the performance changed...

     

    If someone has insight in this, maybe it could shed some light on the problem.

     

    Bottom line: I migrated my account and since then, I get instant results with my iCloud calendar. I sure hope this can help getting your fix.

  • chris09 Level 1 (0 points)

    I've had a lot of trouble with this issue too. I've found a post that was related to high CPU usage and the calendar app (iCal). So I've used the instructions to sucessfully fix the sluggish (3-5 sec) response of the Calendar app.

     

     

    How To Stop CalendarAgent From Eating CPU

    Posted on 8/19/2012

    Recently ran into an issue with Calendar causing a huge CPU spike. Checking the system.log I noticed the following repeatedly in my log:

    CalendarAgent is essentially Calendar’s backend (that’s how it’s also able to power the notification center). The best resolution I’ve found is to completely clear out the calendar and recreate it. Process I used was as follows:

     

    1. Remove the Calendar from “Mail, Contacts & Calendars” pref panel (just uncheck from the account). Then go into Calendar and make sure the account is removed. If it’s not, remove it.
    2. Delete ~/Library/Calendars/
    3. Delete ~/Library/Preferences/com.apple.iCal.plist
    4. Go back into the “Mail, Contacts & Calendars” pref panel, put the calendar back. Give it some time to download.

    http://robert.accettura.com/blog/2012/08/19/how-to-stop-calendaragent-from-eatin g-cpu/

     

    I hope this helps.

     

    Cheers,

    C.

  • MetallicAsh Level 1 (0 points)

    I've had simular replies as this and even after doing the things in the post I have the same problems.

  • ecrissman Level 1 (0 points)

    Thank you chris09 and all that suggested the fix for this. I deleted my calendar folder and the plist file, added the calendars back, and the sluggishness is gone. Just a note, OS X hides the User/Library folder now, so you have to use CLI or an app like Deeper or Tinker Tool to show hidden files.

  • chris09 Level 1 (0 points)

    I'm happy it helped someone as well. Just as a comment, it turns out that my system had some other big issues like Evernote crashing a lot of times. PDF handling and window managment was also really problematic. Why am I saying this? Well it turns out I've been importing / rsycing my system with updates since OSX 10.5 and there seems to be a lot of issues that did accumulate. In the end I've decided to do a completely new system installation with 10.8.3. Now my system runs much much faster and smoother. I know it is a massive pain in the neck but it did really pay off.

     

    Cheers,

    C.

  • TorLance Level 1 (0 points)

    Thanks Ferd II. I performed your steps as outlined above, making sure to restart after removing each of the files under .../Preferences and .../Calendar and my MacBook Pro's Calendar was immediately responsive again. No more pinwheels/beachball when I edited Calendar events. THANK YOU!

     

    "Try removing the com.apple.iCal.plist file from your Macintosh HD/Users/yourusername/Library/Preferences Folder. To find that Library folder, use Finder>Go Menu>Depress the "Option" key>Library. Drag the .plist file to your desktop, and log out/in or restart.

     

    Then go to your Macintosh HD/Users/yourusername/Library/Calendars Folder and remove any files with "Cache" as a part of the file name. Use the same method as listed above to get to the correct Library Folder. Log out/in, or restart and check Calendars for functionality."

  • Ferd II Level 7 (25,770 points)

    Glad to hear that procedure worked for you.

  • fides012 Level 1 (0 points)

    Your suggestions helped me too Ferd II. This issue has been annoying me for a couple of months now, but I thought it was due to one of my Exchange accounts. Thank you so much for your help.

  • Ferd II Level 7 (25,770 points)

    Glad to help!

  • classwinner Level 1 (0 points)

    Thanks Ferd II it worked perferctly fine for me - I had the slow calendar issue on OSX 10.8.4

     

    Now it's as fast as a rocket again. Thanks

  • Ferd II Level 7 (25,770 points)

    You are welcome...glad to help you too!

  • kyzla Level 1 (0 points)

    I followed Ferd's instructions to a T, and everything seems to be working just fine. My question though.... what am I supposed to be doing with the plist file on my desktop? I've got two now (I've done the process twice)....

  • Ferd II Level 7 (25,770 points)

    kyzla,

     

    They can be safely be deleted using Trash.

     

    Glad to hear that you found the information useful.

  • 1Maxxx Level 1 (0 points)

    Worked perfectly for me too Ferd !

    I am on OS X 10.8.4 and had 3-5 second beachballs each time I added / edited an entry like date, time and location. I was even considering going back to MS Outlook.... ;-)

  • Ferd II Level 7 (25,770 points)

    You are welcome...thanks for the feedback.