11 Replies Latest reply: May 21, 2015 7:31 PM by Bkat
spencer1908 Level 1 (0 points)

I want to get rid of my on my mac data from address book locally on my imac and just use the icloud data to populate address book.  Someone else set up my other machines in the office that way, and I want to do it the same on this imac.  How can I do this?

Thank you.


iMac, Mac OS X (10.7.4)
  • Winston Churchill Level 10 (95,708 points)

    You can delete it simply by selecting it and hitting the delete key, so I suspect that you really wish to move it to your iCloud group in address book. You can copy contacts from your "on my Mac" group to your iCloud group by simply selecting them and dragging then to the iCloud group.

     

    This user tip might help you understand how accounts work with Address Book

  • spencer1908 Level 1 (0 points)

    I should have been more specific. All contacts and groups within the contacts have been moved to an icloud data set.  I have been able to delete the different groups within my "on my mac" data set, but I have not been able to get rid of the "on my mac" header which will not delete.  My other machines only have an icloud data set, which is what I would prefer for this machine.

  • spencer1908 Level 1 (0 points)

    Sorry for the nomenclature issues - when I say data set,  I think that is really the account.  I am trying to get rid of the "on my mac" account.  The groups wihtin the "on my mac" account have been deleted, but the contacts are still duplicating if I select All Contacts and it pulls up the "on my mac" account and the icloud accounts together.

  • Winston Churchill Level 10 (95,708 points)

    The On My Mac heading should disappear when there are no more contacts left in it. Check that you don't have anything in the search field when you look for On My Mac Contacts, also check that iCloud is selected as your default account in your Address Book preferences.

     

    This user tip might help you understand how accounts work with Address Book.

  • Melvin! Level 1 (5 points)

    Spencer 1908,

     

    Here is how it works in Lion:

     

    Open up Address Book

     

    Preferences

     

    Accounts

     

    Highlight "On My Mac"

     

    Hit the "-" to delete the account.

  • lbcourtney3 Level 1 (0 points)

    FYI the "-" is disabled in Preferences, Accounts.  I've been trying to remove "On My Mac" from my Contacts as well.

  • Csound1 Level 8 (46,982 points)

    lbcourtney3 wrote:

     

    FYI the "-" is disabled in Preferences, Accounts.  I've been trying to remove "On My Mac" from my Contacts as well.

    If there is anything in the account it will not delete, empty it and it will disappear (unless set as the default account in Contacts Preferences) if it is the default, change it, then delete.

  • Csound1 Level 8 (46,982 points)

    spencer1908 wrote:

     

    Sorry for the nomenclature issues - when I say data set,  I think that is really the account.  I am trying to get rid of the "on my mac" account.  The groups wihtin the "on my mac" account have been deleted, but the contacts are still duplicating if I select All Contacts and it pulls up the "on my mac" account and the icloud accounts together.

     

    Ensure that the 'On My Mac' account is NOT set as the default (Contacts>Preferences>General>Default Account), you can't delete it if it is, or if it is not empty.

  • aoitsukinosuke Level 1 (0 points)

    https://discussions.apple.com/thread/3222240

     

    Solved my problem, hope it does yours, too.

  • kssmithmac Level 1 (0 points)

    Thanks

  • Edson Costa Level 1 (0 points)

    Hi Csound1,

     

    I am stogling with the same issue posted on this discussion.

     

    Exchange2013 and raw contacts populated on my contacts as well as on the exchange server (I have seeing it using a PC and outlook).

     

    You sugest to clean on My Mac contacts. Do not set on My Mac as a default account. Following is what I found:

     

    There is no way to get out the on My Mac account from contacts.

    There is no way set any default account on contacts>preferences>general

    The on My Mac contacts list IS EMPTY and the '-' sign is hidden on the contacts>preferences>accounts.

    When I turn on my Exchange Account on my contacts are downloaded from the server, however, I still not able to set ANY DEFAULT ACCOUNT at all.

     

    If I leave like it is 2 days later I will have at least a dozen of those expurious emails on my contacts list.

     

    Thanks,

     

    Edson

  • bveach Level 1 (0 points)

    The last step that I finally figured out was that not only can you not have any contacts in your "on my mac" file, you also can't have any group names, even if they're empty.  Once I deleted the groups, "on my mac" disappeared.

  • Bkat Level 1 (0 points)

    Thanks.  Deleting the group was the secret.